aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2001-01-06 01:39:14 +0800
committeralex <alex@FreeBSD.org>2001-01-06 01:39:14 +0800
commitf3e583d3c295f0116a2661fe50b585f558986a6d (patch)
treef1cca4bc3f7ac6120f726e24771f9fad3b018a00
parent72186ad347b902339e1bd875c19874e50a38ee1f (diff)
downloadfreebsd-ports-graphics-f3e583d3c295f0116a2661fe50b585f558986a6d.tar.gz
freebsd-ports-graphics-f3e583d3c295f0116a2661fe50b585f558986a6d.tar.zst
freebsd-ports-graphics-f3e583d3c295f0116a2661fe50b585f558986a6d.zip
Add glitter 1.0.b.1, a free GTK based binary downloader.
PR: 23407 Submitted by: Greg Greenaae <greg@gregnet.net>
-rw-r--r--news/Makefile1
-rw-r--r--news/glitter/Makefile28
-rw-r--r--news/glitter/distinfo1
-rw-r--r--news/glitter/files/patch-aa14
-rw-r--r--news/glitter/pkg-comment1
-rw-r--r--news/glitter/pkg-descr4
-rw-r--r--news/glitter/pkg-plist3
7 files changed, 52 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index 93fb52d8b91..6c77f9f445e 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -10,6 +10,7 @@
SUBDIR += diablo
SUBDIR += dnews
SUBDIR += fidogate
+ SUBDIR += glitter
SUBDIR += grn
SUBDIR += gup
SUBDIR += ifmail
diff --git a/news/glitter/Makefile b/news/glitter/Makefile
new file mode 100644
index 00000000000..71b94ed28ab
--- /dev/null
+++ b/news/glitter/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: glitter
+# Date Created: 09 Dec 2000
+# Whom: Greg Greenaae <greg@gregnet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= glitter
+PORTVERSION= 1.0.b.1
+CATEGORIES= news
+MASTER_SITES= http://mews.org.uk/glitter/\
+ ftp://ftp.gregnet.net/pub/FreeBSD/ports/news/glitter/
+DISTNAME= ${PORTNAME}-1.0beta1
+
+MAINTAINER= greg@gregnet.net
+
+USE_X_PREFIX= yes
+USE_GTK= yes
+WANT_GNOME= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+.endif
+
+.include <bsd.port.mk>
diff --git a/news/glitter/distinfo b/news/glitter/distinfo
new file mode 100644
index 00000000000..a427b7a1fae
--- /dev/null
+++ b/news/glitter/distinfo
@@ -0,0 +1 @@
+MD5 (glitter-1.0beta1.tar.gz) = ae0b9d0a9b40899baa935306fb64ce58
diff --git a/news/glitter/files/patch-aa b/news/glitter/files/patch-aa
new file mode 100644
index 00000000000..c3b74d530df
--- /dev/null
+++ b/news/glitter/files/patch-aa
@@ -0,0 +1,14 @@
+*** src/nntp.c.orig Sun Mar 26 23:59:55 2000
+--- src/nntp.c Sat Dec 9 13:21:50 2000
+***************
+*** 16,21 ****
+--- 16,24 ----
+ *
+ */
+ /* nntp.c */
++ #include <unistd.h>
++ #include <netinet/in.h>
++ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
diff --git a/news/glitter/pkg-comment b/news/glitter/pkg-comment
new file mode 100644
index 00000000000..c05b3d36c69
--- /dev/null
+++ b/news/glitter/pkg-comment
@@ -0,0 +1 @@
+A free GTK based binary downloader
diff --git a/news/glitter/pkg-descr b/news/glitter/pkg-descr
new file mode 100644
index 00000000000..d7bd9b36de8
--- /dev/null
+++ b/news/glitter/pkg-descr
@@ -0,0 +1,4 @@
+glitter is a free binary downloader *NIX based machines running
+X11R6 or later.
+
+- Greg Greenaae <greg@gregnet.net>
diff --git a/news/glitter/pkg-plist b/news/glitter/pkg-plist
new file mode 100644
index 00000000000..10639c589ac
--- /dev/null
+++ b/news/glitter/pkg-plist
@@ -0,0 +1,3 @@
+bin/glitter
+bin/gary
+share/gnome/apps/Internet/glitter.desktop