aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-03 02:24:01 +0800
committerantoine <antoine@FreeBSD.org>2014-02-03 02:24:01 +0800
commitf46328ae7f5437cb5c146aea6235539cc0c2d6ba (patch)
tree72be1c697f6ecc898228c6723a75ebb643d57e84
parent696f9b6e95c72fb4a8a1a51772e93b5563a94132 (diff)
downloadfreebsd-ports-graphics-f46328ae7f5437cb5c146aea6235539cc0c2d6ba.tar.gz
freebsd-ports-graphics-f46328ae7f5437cb5c146aea6235539cc0c2d6ba.tar.zst
freebsd-ports-graphics-f46328ae7f5437cb5c146aea6235539cc0c2d6ba.zip
Stage support
-rw-r--r--graphics/cinepaint/Makefile24
-rw-r--r--graphics/cinepaint/pkg-plist2
2 files changed, 12 insertions, 14 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index d74e2a8b135..3a09e12f7b6 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -13,24 +13,23 @@ COMMENT= Editing tool used for painting and retouching of movies
LICENSE= GPLv2 LGPL21 MIT
LICENSE_COMB= multi
-LIB_DEPENDS= IlmImf:${PORTSDIR}/graphics/OpenEXR \
- ftgl:${PORTSDIR}/graphics/ftgl \
- jpeg:${PORTSDIR}/graphics/jpeg \
- lcms:${PORTSDIR}/graphics/lcms \
- png15:${PORTSDIR}/graphics/png \
- tiff:${PORTSDIR}/graphics/tiff \
- fltk:${PORTSDIR}/x11-toolkits/fltk
+LIB_DEPENDS= libIlmImf.so:${PORTSDIR}/graphics/OpenEXR \
+ libftgl.so:${PORTSDIR}/graphics/ftgl \
+ libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ liblcms.so:${PORTSDIR}/graphics/lcms \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff \
+ libfltk.so:${PORTSDIR}/x11-toolkits/fltk
OPTIONS_DEFINE= OYRANOS PRINT
OYRANOS_DESC= ICC profile support via Oyranos
PRINT_DESC= Gutenprint (gimp-print) plugin
-USES= gettext pkgconfig
+USES= desktop-file-utils gettext gmake pkgconfig
USE_XORG= xmu
USE_GNOME= gtk20
USE_GHOSTSCRIPT_RUN=yes
USE_PYTHON= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libtoolize aclocal automake autoconf
LIBTOOLIZE_ARGS=--force
ACLOCAL_ARGS= -I aclocal
@@ -42,19 +41,16 @@ LDFLAGS+= -L${LOCALBASE}/lib
PLIST_SUB= VER="${DISTVERSION}"
-MAN1= cinepaint.1 cinepainttool.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MOYRANOS}
-LIB_DEPENDS+= oyranos:${PORTSDIR}/graphics/oyranos
+LIB_DEPENDS+= liboyranos.so:${PORTSDIR}/graphics/oyranos
.else
CONFIGURE_ENV+= ac_cv_path_OY_CONFIG=no
.endif
.if ${PORT_OPTIONS:MPRINT}
-LIB_DEPENDS+= gutenprint:${PORTSDIR}/print/gutenprint-base
+LIB_DEPENDS+= libgutenprint.so:${PORTSDIR}/print/gutenprint-base
PLIST_SUB+= PRINT=""
.else
CONFIGURE_ARGS+= --disable-print
diff --git a/graphics/cinepaint/pkg-plist b/graphics/cinepaint/pkg-plist
index b0a9fa5c644..d87785d79b3 100644
--- a/graphics/cinepaint/pkg-plist
+++ b/graphics/cinepaint/pkg-plist
@@ -117,6 +117,8 @@ lib/libcinepaint_fl_i18n.la
lib/libcinepaint_fl_i18n.so
lib/libcinepaint_fl_i18n.so.1
libdata/pkgconfig/cinepaint-gtk.pc
+man/man1/cinepaint.1.gz
+man/man1/cinepainttool.1.gz
share/aclocal/cinepaint.m4
share/applications/cinepaint.desktop
%%DATADIR%%/%%VER%%/brushes/10x10squareBlurf16.gbr