aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2015-06-12 10:28:56 +0800
committerswills <swills@FreeBSD.org>2015-06-12 10:28:56 +0800
commitf4ed5ad2834b1e03d3022f6572b537c118cc88d1 (patch)
treef79921a62c7da0a809802ed90ba3a7e1188e0c50
parent051e3cf872dc8b1a113b09ea3865419b24016ac9 (diff)
downloadfreebsd-ports-graphics-f4ed5ad2834b1e03d3022f6572b537c118cc88d1.tar.gz
freebsd-ports-graphics-f4ed5ad2834b1e03d3022f6572b537c118cc88d1.tar.zst
freebsd-ports-graphics-f4ed5ad2834b1e03d3022f6572b537c118cc88d1.zip
devel/godep: create port
godep helps build packages reproducibly by fixing their dependencies. WWW: https://github.com/tools/godep
-rw-r--r--devel/Makefile1
-rw-r--r--devel/godep/Makefile40
-rw-r--r--devel/godep/distinfo6
-rw-r--r--devel/godep/pkg-descr3
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4d2d66ae38a..49addfe4ae2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -625,6 +625,7 @@
SUBDIR += go-uuid
SUBDIR += gob2
SUBDIR += gobject-introspection
+ SUBDIR += godep
SUBDIR += godot
SUBDIR += goffice
SUBDIR += goffice010
diff --git a/devel/godep/Makefile b/devel/godep/Makefile
new file mode 100644
index 00000000000..e06846263eb
--- /dev/null
+++ b/devel/godep/Makefile
@@ -0,0 +1,40 @@
+# $FreeBSD$
+
+PORTNAME= godep
+PORTVERSION= 0.0.0.2015061101
+CATEGORIES= devel
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= Godep helps build packages reproducibly
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/go:${PORTSDIR}/lang/go
+
+USE_GITHUB= yes
+GH_ACCOUNT= tools:DEFAULT kr:fs golang:tools
+GH_PROJECT= godep:DEFAULT fs:fs tools:tools
+GH_TAGNAME= e28aafa:DEFAULT 2788f0d:fs a6d2a42:tools
+
+PLIST_FILES= bin/godep
+
+STRIP= # stripping can break go binaries
+
+post-patch:
+ @${MKDIR} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}
+.for src in .gitignore License Readme.md dep.go doc.go get.go go.go main.go \
+ match_test.go path.go pkg.go restore.go rewrite.go rewrite_test.go \
+ save.go save_test.go update.go update_test.go util.go vcs.go
+ @${MV} ${WRKSRC}/${src} \
+ ${WRKSRC}/src/github.com/tools/${PORTNAME}
+.endfor
+ @${MKDIR} ${WRKSRC}/src/github.com/kr
+ @${MKDIR} ${WRKSRC}/src/golang.org/x
+ @${MV} ${WRKSRC_fs} ${WRKSRC}/src/github.com/kr/fs
+ @${MV} ${WRKSRC_tools} ${WRKSRC}/src/golang.org/x/tools
+
+do-build:
+ @cd ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}; ${SETENV} ${BUILD_ENV} GOPATH=${WRKSRC} go build
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/github.com/${GH_ACCOUNT}/${PORTNAME}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/godep/distinfo b/devel/godep/distinfo
new file mode 100644
index 00000000000..0a4ac4f8714
--- /dev/null
+++ b/devel/godep/distinfo
@@ -0,0 +1,6 @@
+SHA256 (tools-godep-0.0.0.2015061101-e28aafa_GH0.tar.gz) = a7dcdd7d7381e79e5c48f1abb44edabeed184c9c0aea3c1d58e8cafc57943fde
+SIZE (tools-godep-0.0.0.2015061101-e28aafa_GH0.tar.gz) = 20441
+SHA256 (kr-fs-2788f0d_GH0.tar.gz) = 51899cf8a55f8feefcdd33c04cf5e74937319d45ce0f04aa175188573f3284c9
+SIZE (kr-fs-2788f0d_GH0.tar.gz) = 4361
+SHA256 (golang-tools-a6d2a42_GH0.tar.gz) = f46a91af2efc4ad3bbb4c8196183e1d396fefe2b33d8720c4198a5585f06780e
+SIZE (golang-tools-a6d2a42_GH0.tar.gz) = 1625666
diff --git a/devel/godep/pkg-descr b/devel/godep/pkg-descr
new file mode 100644
index 00000000000..a34db84a8ee
--- /dev/null
+++ b/devel/godep/pkg-descr
@@ -0,0 +1,3 @@
+Godep helps build packages reproducibly by fixing their dependencies.
+
+WWW: https://github.com/tools/godep