aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-02-11 17:12:35 +0800
committergahr <gahr@FreeBSD.org>2013-02-11 17:12:35 +0800
commitf8c7878fd6d03dc5071c60c36e52e02c7e14169b (patch)
tree3b9975e9214ba4ff659364d76a0df026590b91c6
parent89d83d50570f789ce79651b9a931828332c8c6b5 (diff)
downloadfreebsd-ports-graphics-f8c7878fd6d03dc5071c60c36e52e02c7e14169b.tar.gz
freebsd-ports-graphics-f8c7878fd6d03dc5071c60c36e52e02c7e14169b.tar.zst
freebsd-ports-graphics-f8c7878fd6d03dc5071c60c36e52e02c7e14169b.zip
- Unbreak on amd64 and sparc64
- Take maintainership - Add regression-test target - Trim Makefile header
-rw-r--r--devel/libpeak/Makefile22
-rw-r--r--devel/libpeak/files/patch-configure29
-rw-r--r--devel/libpeak/files/patch-peak_engine_mode_kqueue.c12
-rw-r--r--devel/libpeak/files/patch-peak_signal.c12
4 files changed, 63 insertions, 12 deletions
diff --git a/devel/libpeak/Makefile b/devel/libpeak/Makefile
index 346b6cb9520..d20bce955ca 100644
--- a/devel/libpeak/Makefile
+++ b/devel/libpeak/Makefile
@@ -1,27 +1,25 @@
-# ex:ts=8
-# Ports collection makefile for: libpeak
-# Date created: Mar 18, 2005
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= libpeak
PORTVERSION= 0.1.2
-PORTREVISION= 0
CATEGORIES= devel
MASTER_SITES= SF/peak/${PORTNAME}/${PORTVERSION}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= gahr@FreeBSD.org
COMMENT= Parallel Events and Asynchronous tasKing Library
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64 sparc64
USE_GMAKE= yes
GNU_CONFIGURE= yes
-MAKE_ARGS= CFLAGS="${CFLAGS}" PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- LIBS="${PTHREAD_LIBS}"
USE_LDCONFIG= yes
-USE_AUTOTOOLS= libtool
+
+regression-test: build
+ ( \
+ cd ${WRKSRC}/tests; \
+ alltests=`ls *.c | sed -e 's|\.c||g'`; \
+ ${MAKE} $$alltests && ./test-suite.pl $$alltests \
+ )
.include <bsd.port.mk>
diff --git a/devel/libpeak/files/patch-configure b/devel/libpeak/files/patch-configure
new file mode 100644
index 00000000000..4e89d06e46c
--- /dev/null
+++ b/devel/libpeak/files/patch-configure
@@ -0,0 +1,29 @@
+--- configure.orig 2007-05-24 15:25:29.000000000 +0200
++++ configure 2013-02-11 09:41:56.000000000 +0100
+@@ -2514,7 +2514,7 @@
+
+ cflags='-O2 -g -Wall'
+ default_includes=' -I. -I$(srcdir) -I$(top_builddir)'
+-includes='-I- -I$(top_builddir)'
++includes='-I$(top_builddir)'
+
+ case "$host" in
+ *-*-aix*)
+@@ -2661,7 +2661,7 @@
+ arch=powerpc
+ ;;
+
+- i*86-* | x86-* | x86_64-*)
++ i*86-* | x86-* | x86_64-* | amd64-*)
+ arch=x86
+ ;;
+
+@@ -22321,7 +22321,7 @@
+ ac_cv_header_stdint_x="no-file"
+ ac_cv_header_stdint_o="no-file"
+ ac_cv_header_stdint_u="no-file"
+- for i in stdint.h $inttype_headers ; do
++ for i in inttypes.h stdint.h $inttype_headers ; do
+ unset ac_cv_type_uintptr_t
+ unset ac_cv_type_uint64_t
+ { echo "$as_me:$LINENO: checking for uintptr_t" >&5
diff --git a/devel/libpeak/files/patch-peak_engine_mode_kqueue.c b/devel/libpeak/files/patch-peak_engine_mode_kqueue.c
new file mode 100644
index 00000000000..fc342f9b8fb
--- /dev/null
+++ b/devel/libpeak/files/patch-peak_engine_mode_kqueue.c
@@ -0,0 +1,12 @@
+--- peak/engine_mod_kqueue.c.orig 2013-02-11 09:50:18.000000000 +0100
++++ peak/engine_mod_kqueue.c 2013-02-11 09:51:01.000000000 +0100
+@@ -47,6 +47,9 @@
+ #include <time.h>
+ #include <unistd.h>
+ #include <sys/event.h>
++#ifdef HAVE_SYS_SIGNAL_H
++#include <sys/signal.h>
++#endif
+ #ifdef HAVE_SIGNAL_H
+ #include <signal.h>
+ #endif
diff --git a/devel/libpeak/files/patch-peak_signal.c b/devel/libpeak/files/patch-peak_signal.c
new file mode 100644
index 00000000000..61244b2aaab
--- /dev/null
+++ b/devel/libpeak/files/patch-peak_signal.c
@@ -0,0 +1,12 @@
+--- peak/signal.c.orig 2013-02-11 09:43:19.000000000 +0100
++++ peak/signal.c 2013-02-11 09:49:07.000000000 +0100
+@@ -45,6 +45,9 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <string.h>
++#ifdef HAVE_SYS_SIGNAL_H
++#include <sys/signal.h>
++#endif
+ #ifdef HAVE_SIGNAL_H
+ #include <signal.h>
+ #endif