aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordwcjr <dwcjr@FreeBSD.org>2002-05-16 23:51:16 +0800
committerdwcjr <dwcjr@FreeBSD.org>2002-05-16 23:51:16 +0800
commitf8d26c6a83da2b53108a6ad19d831497f67295f4 (patch)
treecaca2b93f6619e484e43fc1c8cfd87f6b128e8df
parent074f0d0fada94d47eded565b6dd0786c59790a80 (diff)
downloadfreebsd-ports-graphics-f8d26c6a83da2b53108a6ad19d831497f67295f4.tar.gz
freebsd-ports-graphics-f8d26c6a83da2b53108a6ad19d831497f67295f4.tar.zst
freebsd-ports-graphics-f8d26c6a83da2b53108a6ad19d831497f67295f4.zip
Improve maildir support
PR: 38147 Submitted by: maintainer, lioux
-rw-r--r--mail/mutt-devel/Makefile31
-rw-r--r--mail/mutt-devel/files/extra-maildir-patch-Makefile.am10
-rw-r--r--mail/mutt-devel/files/extra-maildir-patch-globals.h10
-rw-r--r--mail/mutt-devel/files/extra-maildir-patch-init.h18
-rw-r--r--mail/mutt-devel/files/extra-maildir-patch-mh.c111
-rw-r--r--mail/mutt-devel/files/extra-maildir-patch-mutt.h44
-rw-r--r--mail/mutt-devel/files/maildir_clean_dir.c120
-rw-r--r--mail/mutt-devel/files/maildir_clean_dir.h42
-rw-r--r--mail/mutt-devel/pkg-plist40
9 files changed, 423 insertions, 3 deletions
diff --git a/mail/mutt-devel/Makefile b/mail/mutt-devel/Makefile
index 8ed6236a46c..1b55873c310 100644
--- a/mail/mutt-devel/Makefile
+++ b/mail/mutt-devel/Makefile
@@ -49,10 +49,13 @@
#
# If you want to enable the pgp_outlook_compat function for use with pgp define:
# WITH_MUTT_PGP_OUTLOOK_PATCH
+#
+# If you want to enable some functions whoch improve maildir handling define:
+# WITH_MUTT_MAILDIR_PATCH
PORTNAME= mutt-devel
PORTVERSION= 1.3.99
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES+= mail
.if defined(WITH_MUTT_NNTP)
CATEGORIES+= news
@@ -98,6 +101,18 @@ pre-build:
s/^(AUTOMAKE = ).+/\1${AUTOMAKE}/; s/^(AUTOHEADER = ).+/\1${AUTOHEADER}/" \
${BUILD_WRKSRC}/Makefile
+.if defined(WITH_MUTT_MAILDIR_PATCH)
+.for file in Makefile.am globals.h init.h mh.c mutt.h
+EXTRA_PATCHES+= ${WRKSRC}/patch-${file}
+pre-patch::
+ ${CP} ${PATCHDIR}/extra-maildir-patch-${file} ${WRKSRC}/patch-${file}
+.endfor
+.for file in maildir_clean_dir.h maildir_clean_dir.c
+pre-patch::
+ ${CP} ${PATCHDIR}/${file} ${WRKSRC}/${file}
+.endfor
+.endif
+
.if !defined(PATCH_VERSION)
PATCH_VERSION= ${PORTVERSION}
.endif
@@ -294,7 +309,7 @@ PLIST_SUB+= SUB_ADD_D="@comment "
PLIST_SUB+= SUB_ADD_E="@comment "
PLIST_SUB+= SUB_ADD_F="@comment "
PLIST_SUB+= SUB_ADD_G="@comment "
-PLIST_SUB+= SUB_PGP_A="@comment "
+PLIST_SUB+= SUB_PGP_A=""
.else # patches
PLIST_SUB+= SUB_ADD_A="@comment "
PLIST_SUB+= SUB_ADD_B="@comment "
@@ -330,11 +345,21 @@ PLIST_SUB+= SUB_PGP_A="@comment "
post-patch::
${PATCH} ${PATCH_ARGS} < ${PATCHDIR}/extra-patch-nodoc-contrib
.endif
-.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH)
+.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH) && !defined(WITH_MUTT_MAILDIR_PATCH)
PLIST_SUB+= SUB_PGP=""
.else
PLIST_SUB+= SUB_PGP="@comment "
.endif
+.if defined(WITH_MUTT_MAILDIR_PATCH) && !defined(WITH_MUTT_PGP_OUTLOOK_PATCH)
+PLIST_SUB+= SUB_MAILDIR=""
+.else
+PLIST_SUB+= SUB_MAILDIR="@comment "
+.endif
+.if defined(WITH_MUTT_PGP_OUTLOOK_PATCH) && defined(WITH_MUTT_MAILDIR_PATCH)
+PLIST_SUB+= SUB_MAILDIRPGP=""
+.else
+PLIST_SUB+= SUB_MAILDIRPGP="@comment "
+.endif
.if ${SGML_USED} == yes
BUILD_DEPENDS+= sgmlfmt:${PORTSDIR}/textproc/sgmlformat
post-patch::
diff --git a/mail/mutt-devel/files/extra-maildir-patch-Makefile.am b/mail/mutt-devel/files/extra-maildir-patch-Makefile.am
new file mode 100644
index 00000000000..0ec79260aa5
--- /dev/null
+++ b/mail/mutt-devel/files/extra-maildir-patch-Makefile.am
@@ -0,0 +1,10 @@
+--- Makefile.am.orig Wed Feb 21 02:42:38 2001
++++ Makefile.am Wed Feb 21 02:42:20 2001
+@@ -29,6 +29,7 @@
+ commands.c complete.c compose.c copy.c curs_lib.c curs_main.c date.c \
+ edit.c enter.c flags.c init.c filter.c from.c getdomain.c \
+ handler.c hash.c hdrline.c headers.c help.c hook.c keymap.c \
++ maildir_clean_dir.c \
+ main.c mbox.c menu.c mh.c mx.c pager.c parse.c pattern.c \
+ postpone.c query.c recvattach.c recvcmd.c \
+ rfc822.c rfc1524.c rfc2047.c rfc2231.c \
diff --git a/mail/mutt-devel/files/extra-maildir-patch-globals.h b/mail/mutt-devel/files/extra-maildir-patch-globals.h
new file mode 100644
index 00000000000..f934a27b923
--- /dev/null
+++ b/mail/mutt-devel/files/extra-maildir-patch-globals.h
@@ -0,0 +1,10 @@
+--- globals.h.orig Wed Feb 21 01:20:19 2001
++++ globals.h Wed Feb 21 01:23:54 2001
+@@ -123,6 +123,7 @@
+ WHERE unsigned short Counter INITVAL (0);
+
+ WHERE short HistSize;
++WHERE short MaildirTmpClnInterval;
+ WHERE short PagerContext;
+ WHERE short PagerIndexLines;
+ WHERE short PopPort;
diff --git a/mail/mutt-devel/files/extra-maildir-patch-init.h b/mail/mutt-devel/files/extra-maildir-patch-init.h
new file mode 100644
index 00000000000..8a549c58bb0
--- /dev/null
+++ b/mail/mutt-devel/files/extra-maildir-patch-init.h
@@ -0,0 +1,18 @@
+--- init.h.orig Tue Jul 18 04:46:46 2000
++++ init.h Tue Feb 20 20:46:56 2001
+@@ -860,6 +860,15 @@
+ { "mailcap_sanitize", DT_BOOL, R_NONE, OPTMAILCAPSANITIZE, 1 },
+ /*
+ ** .pp
++ ** This variable specifies that maildir tmp directories
++ ** should have 36 hours non-accessed files deleted
++ ** This is measured in minutes, hence 36*60 minutes (36 hours)
++ ** (default: off)
++ */
++ { "maildir_tmp_clean", DT_BOOL, R_NONE, OPTCLEANMTMP, 0 },
++ { "maildir_tmp_clean_interval", DT_NUM, R_NONE, UL &MaildirTmpClnInterval, 36*60 },
++ /*
++ ** .pp
+ ** If set, mutt will restrict possible characters in mailcap % expandos
+ ** to a well-defined set of safe characters. This is the safe setting,
+ ** but we are not sure it doesn't break some more advanced MIME stuff.
diff --git a/mail/mutt-devel/files/extra-maildir-patch-mh.c b/mail/mutt-devel/files/extra-maildir-patch-mh.c
new file mode 100644
index 00000000000..7c8febeccc2
--- /dev/null
+++ b/mail/mutt-devel/files/extra-maildir-patch-mh.c
@@ -0,0 +1,111 @@
+--- mh.c.orig Fri Nov 9 10:28:55 2001
++++ mh.c Tue Dec 4 16:06:14 2001
+@@ -29,6 +29,12 @@
+ #include "buffy.h"
+ #include "sort.h"
+
++/*
++ * Additional maildir handling routines so that mutt abides
++ * by the maildir specification
++ */
++#include "maildir_clean_dir.h"
++
+ #include <sys/stat.h>
+ #include <dirent.h>
+ #include <limits.h>
+@@ -41,6 +47,8 @@
+ #include <errno.h>
+ #include <string.h>
+
++#define MACRO_MAILDIR_TMP_CLN_INTERVAL ((MaildirTmpClnInterval>0) ? (MaildirTmpClnInterval*60) : (MAILDIR_TMP_TIME_LIMIT))
++
+ struct maildir
+ {
+ HEADER *h;
+@@ -520,6 +528,11 @@
+
+ if(ctx->magic == M_MAILDIR)
+ {
++ if(option (OPTCLEANMTMP)) {
++ snprintf(buf, sizeof(buf), "%s/%s", ctx->path, "tmp");
++ if(stat (buf, &st) == 0)
++ ctx->mtime_tmp = st.st_mtime;
++ }
+ snprintf(buf, sizeof(buf), "%s/%s", ctx->path, "cur");
+ if(stat (buf, &st) == 0)
+ ctx->mtime_cur = st.st_mtime;
+@@ -750,8 +763,10 @@
+ {
+ /* maildir looks sort of like MH, except that there are two subdirectories
+ * of the main folder path from which to read messages
++ * and one to clean up
+ */
+- if (mh_read_dir (ctx, "new") == -1 || mh_read_dir (ctx, "cur") == -1)
++ if (mh_read_dir (ctx, "new") == -1 || mh_read_dir (ctx, "cur") == -1 ||
++ maildir_clean_dir (ctx, "tmp", (MACRO_MAILDIR_TMP_CLN_INTERVAL)) == -1)
+ return (-1);
+
+ return 0;
+@@ -850,8 +865,6 @@
+ return 0;
+ }
+
+-
+-
+ /*
+ * Commit a message to a maildir folder.
+ *
+@@ -1246,6 +1259,9 @@
+ struct maildir **last;
+ HASH *fnames;
+ int i, j;
++ struct stat st_tmp;
++ short aged_tmp = 0;
++ time_t rightnow = 0;
+
+ if(!option (OPTCHECKNEW))
+ return 0;
+@@ -1290,6 +1306,15 @@
+ if(stat(buf, &st_cur) == -1) /* XXX - name is bad. */
+ modified = 1;
+
++ if (option (OPTCLEANMTMP)) {
++ snprintf(buf, sizeof(buf), "%s/tmp", ctx->path);
++ if (stat(buf, &st_tmp) == -1)
++ aged_tmp = 1;
++ if ((rightnow = time(NULL)) == ((time_t) -1))
++ return -1; /* can't get time ? */
++ } else {
++ aged_tmp = 1;
++ }
+ }
+
+ if(!modified && ctx->magic == M_MAILDIR && st_cur.st_mtime > ctx->mtime_cur)
+@@ -1301,12 +1326,18 @@
+ if(modified || (ctx->magic == M_MAILDIR && st.st_mtime > ctx->mtime))
+ have_new = 1;
+
++ aged_tmp = (!aged_tmp && ctx->magic == M_MAILDIR &&
++ ((st_tmp.st_mtime > ctx->mtime_tmp) || (ctx->atime_tmp &&
++ (difftime (rightnow,ctx->atime_tmp) > (MACRO_MAILDIR_TMP_CLN_INTERVAL) )))) ? 1 : 0;
++
+ if(!modified && !have_new)
+ return 0;
+
+ ctx->mtime_cur = st_cur.st_mtime;
+ ctx->mtime = st.st_mtime;
+
++ if(aged_tmp)
++ ctx->mtime_tmp = st_tmp.st_mtime;
+ #if 0
+ if(Sort != SORT_ORDER)
+ {
+@@ -1328,6 +1359,8 @@
+ maildir_parse_dir(ctx, &last, "new", NULL);
+ if(modified)
+ maildir_parse_dir(ctx, &last, "cur", NULL);
++ if(aged_tmp)
++ maildir_clean_dir(ctx, "tmp", (MACRO_MAILDIR_TMP_CLN_INTERVAL));
+ }
+ else if(ctx->magic == M_MH)
+ {
diff --git a/mail/mutt-devel/files/extra-maildir-patch-mutt.h b/mail/mutt-devel/files/extra-maildir-patch-mutt.h
new file mode 100644
index 00000000000..33d631e710a
--- /dev/null
+++ b/mail/mutt-devel/files/extra-maildir-patch-mutt.h
@@ -0,0 +1,44 @@
+--- mutt.h.orig Wed Feb 21 02:33:48 2001
++++ mutt.h Wed Feb 21 02:34:30 2001
+@@ -16,6 +16,9 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111, USA.
+ */
+
++#ifndef _MUTT_H
++# define _MUTT_H
++
+ #include "config.h"
+
+ #include <stdio.h>
+@@ -42,6 +45,8 @@
+ # define MUTT_VERSION (VERSION)
+ #endif
+
++#define MAILDIR_TMP_TIME_LIMIT (36*60*60) /* seconds */
++
+ /* nifty trick I stole from ELM 2.5alpha. */
+ #ifdef MAIN_C
+ #define WHERE
+@@ -278,6 +283,7 @@
+ OPTBEEPNEW,
+ OPTBOUNCEDELIVERED,
+ OPTCHECKNEW,
++ OPTCLEANMTMP,
+ OPTCOLLAPSEUNREAD,
+ OPTCONFIRMAPPEND,
+ OPTCONFIRMCREATE,
+@@ -639,6 +645,8 @@
+ FILE *fp;
+ time_t mtime;
+ time_t mtime_cur; /* used with maildir folders */
++ time_t mtime_tmp; /* these 2 used with maildir folders */
++ time_t atime_tmp;
+ off_t size;
+ off_t vsize;
+ char *pattern; /* limit pattern string */
+@@ -716,3 +724,5 @@
+ #include "protos.h"
+ #include "lib.h"
+ #include "globals.h"
++
++#endif /* _MUTT_H */
diff --git a/mail/mutt-devel/files/maildir_clean_dir.c b/mail/mutt-devel/files/maildir_clean_dir.c
new file mode 100644
index 00000000000..09047f40b75
--- /dev/null
+++ b/mail/mutt-devel/files/maildir_clean_dir.c
@@ -0,0 +1,120 @@
+/*
+ * Copyright (c) 2000, 2001 Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. Neither the name of the Author nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
+ * $Header: /home/ncvs/work/ports/mutt-devel/files/Attic/maildir_clean_dir.c,v 1.1.4.1 2002/05/16 11:44:06 ust Exp $
+ */
+
+#include <sys/types.h>
+#include <sys/stat.h>
+#include <dirent.h>
+#include <limits.h>
+#include <stdio.h>
+#include <time.h>
+
+#include "config.h"
+#include "mutt.h"
+#include "mx.h"
+/*
+#include "init,h"
+*/
+#include "lib.h"
+
+# ifndef HAVE_SNPRINTF
+extern int snprintf (char *, size_t, const char *, ...);
+# endif
+
+time_t maildir_atime_entry(CONTEXT *ctx, const char *subdir, const char *fname, time_t *last_access)
+{
+ char buf[_POSIX_PATH_MAX];
+ struct stat st;
+
+ if(subdir)
+ snprintf(buf, sizeof(buf), "%s/%s/%s", ctx->path, subdir, fname);
+ else
+ snprintf(buf, sizeof(buf), "%s/%s", ctx->path, fname);
+
+ if (stat(buf, &st) == 0) {
+ (*last_access) = st.st_atime;
+ return 0;
+ } else
+ return -1;
+}
+
+int maildir_clean_dir(CONTEXT *ctx, const char *subdir, unsigned long time_limit)
+{
+ DIR *dirp;
+ struct dirent *de;
+ char buf[_POSIX_PATH_MAX];
+ time_t rightnow, last_access, llast_access;
+
+ if(!option (OPTCLEANMTMP))
+ return 0;
+
+ if(subdir)
+ snprintf(buf, sizeof(buf), "%s/%s", ctx->path, subdir);
+ else
+ strfcpy(buf, ctx->path, sizeof(buf));
+
+ if ((dirp = opendir(buf)) == NULL)
+ return -1; /* is not there a dir ? */
+
+ if ((rightnow = time(NULL)) == ((time_t) -1))
+ return -1; /* can't get time ? */
+
+ llast_access = rightnow;
+
+ while ((de = readdir (dirp)) != NULL) {
+ /* I am not dealing with validity of messages, I'll remove any given visible messages */
+/*
+ * This is a concern to both new and cur, not tmp
+ if (ctx->magic == M_MAILDIR && *de->d_name == '.')
+ continue;
+*/
+
+ dprint(2, (debugfile, "%s:%d: stating %s\n", __FILE__, __LINE__, de->d_name));
+ if (!maildir_atime_entry(ctx, subdir, de->d_name, &last_access)) {
+ if (difftime(last_access,rightnow) > 0)
+ continue; /* I neither know how to handle this right now nor care for the time being */
+
+ if (difftime(rightnow,last_access) > time_limit) {
+ if(subdir)
+ snprintf(buf, sizeof(buf), "%s/%s/%s", ctx->path, subdir, de->d_name);
+ else
+ snprintf(buf, sizeof(buf), "%s/%s", ctx->path, de->d_name);
+
+ mutt_unlink (buf);
+ } else
+ (llast_access = (llast_access > last_access) ? last_access : llast_access);
+ }
+ }
+
+ ctx->atime_tmp = (llast_access == rightnow) ? 0 : llast_access;
+
+ closedir(dirp);
+ return 0;
+}
diff --git a/mail/mutt-devel/files/maildir_clean_dir.h b/mail/mutt-devel/files/maildir_clean_dir.h
new file mode 100644
index 00000000000..353bc09c51f
--- /dev/null
+++ b/mail/mutt-devel/files/maildir_clean_dir.h
@@ -0,0 +1,42 @@
+/*
+ * Copyright (c) 2000, 2001 Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ * 3. Neither the name of the Author nor the names of its contributors
+ * may be used to endorse or promote products derived from this software
+ * without specific prior written permission.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE AUTHOR AND CONTRIBUTORS ``AS IS'' AND
+ * ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
+ * IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
+ * ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE
+ * FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
+ * DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS
+ * OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
+ * HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
+ * LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
+ * $Header: /home/ncvs/work/ports/mutt-devel/files/Attic/maildir_clean_dir.h,v 1.1.4.1 2002/05/16 11:44:06 ust Exp $
+ */
+
+#ifndef _MAILDIR_CLEAN_DIR_H
+# define _MAILDIR_CLEAN_DIR_H
+
+#include <time.h>
+
+#include "mutt.h"
+
+extern time_t maildir_atime_entry(CONTEXT *, const char *, const char *, time_t *);
+extern int maildir_clean_dir(CONTEXT *, const char *, unsigned long);
+
+#endif /* _MAILDIR_CLEAN_DIR_H */
diff --git a/mail/mutt-devel/pkg-plist b/mail/mutt-devel/pkg-plist
index 6fea339710a..e2f0fea34e9 100644
--- a/mail/mutt-devel/pkg-plist
+++ b/mail/mutt-devel/pkg-plist
@@ -422,15 +422,30 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
%%SUB_HTML%%share/doc/mutt/html/manual336.html
%%SUB_HTML%%share/doc/mutt/html/manual337.html
%%SUB_HTML%%%%SUB_PGP_A%%%%SUB_PGP%%share/doc/mutt/html/manual338.html
+%%SUB_HTML%%%%SUB_PGP_A%%%%SUB_MAILDIR%%share/doc/mutt/html/manual338.html
+%%SUB_HTML%%%%SUB_PGP_A%%%%SUB_MAILDIR%%share/doc/mutt/html/manual339.html
+%%SUB_HTML%%%%SUB_PGP_A%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual338.html
+%%SUB_HTML%%%%SUB_PGP_A%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual339.html
+%%SUB_HTML%%%%SUB_PGP_A%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual340.html
%%SUB_ADD_A%%share/doc/mutt/html/manual338.html
%%SUB_ADD_A%%share/doc/mutt/html/manual339.html
%%SUB_ADD_A%%%%SUB_PGP%%share/doc/mutt/html/manual340.html
+%%SUB_ADD_A%%%%SUB_MAILDIR%%share/doc/mutt/html/manual340.html
+%%SUB_ADD_A%%%%SUB_MAILDIR%%share/doc/mutt/html/manual341.html
+%%SUB_ADD_A%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual340.html
+%%SUB_ADD_A%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual341.html
+%%SUB_ADD_A%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual342.html
%%SUB_ADD_B%%share/doc/mutt/html/manual338.html
%%SUB_ADD_B%%share/doc/mutt/html/manual339.html
%%SUB_ADD_B%%share/doc/mutt/html/manual340.html
%%SUB_ADD_B%%share/doc/mutt/html/manual341.html
%%SUB_ADD_B%%share/doc/mutt/html/manual342.html
%%SUB_ADD_B%%%%SUB_PGP%%share/doc/mutt/html/manual343.html
+%%SUB_ADD_B%%%%SUB_MAILDIR%%share/doc/mutt/html/manual343.html
+%%SUB_ADD_B%%%%SUB_MAILDIR%%share/doc/mutt/html/manual344.html
+%%SUB_ADD_B%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual343.html
+%%SUB_ADD_B%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual344.html
+%%SUB_ADD_B%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual345.html
%%SUB_ADD_C%%share/doc/mutt/html/manual338.html
%%SUB_ADD_C%%share/doc/mutt/html/manual339.html
%%SUB_ADD_C%%share/doc/mutt/html/manual340.html
@@ -439,6 +454,11 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
%%SUB_ADD_C%%share/doc/mutt/html/manual343.html
%%SUB_ADD_C%%share/doc/mutt/html/manual344.html
%%SUB_ADD_C%%%%SUB_PGP%%share/doc/mutt/html/manual345.html
+%%SUB_ADD_C%%%%SUB_MAILDIR%%share/doc/mutt/html/manual345.html
+%%SUB_ADD_C%%%%SUB_MAILDIR%%share/doc/mutt/html/manual346.html
+%%SUB_ADD_C%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual345.html
+%%SUB_ADD_C%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual346.html
+%%SUB_ADD_C%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual347.html
%%SUB_ADD_D%%share/doc/mutt/html/manual338.html
%%SUB_ADD_D%%share/doc/mutt/html/manual339.html
%%SUB_ADD_D%%share/doc/mutt/html/manual340.html
@@ -462,6 +482,11 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
%%SUB_ADD_D%%share/doc/mutt/html/manual358.html
%%SUB_ADD_D%%share/doc/mutt/html/manual359.html
%%SUB_ADD_D%%%%SUB_PGP%%share/doc/mutt/html/manual360.html
+%%SUB_ADD_D%%%%SUB_MAILDIR%%share/doc/mutt/html/manual360.html
+%%SUB_ADD_D%%%%SUB_MAILDIR%%share/doc/mutt/html/manual361.html
+%%SUB_ADD_D%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual360.html
+%%SUB_ADD_D%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual361.html
+%%SUB_ADD_D%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual362.html
%%SUB_ADD_E%%share/doc/mutt/html/manual338.html
%%SUB_ADD_E%%share/doc/mutt/html/manual339.html
%%SUB_ADD_E%%share/doc/mutt/html/manual340.html
@@ -487,6 +512,11 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
%%SUB_ADD_E%%share/doc/mutt/html/manual360.html
%%SUB_ADD_E%%share/doc/mutt/html/manual361.html
%%SUB_ADD_E%%%%SUB_PGP%%share/doc/mutt/html/manual362.html
+%%SUB_ADD_E%%%%SUB_MAILDIR%%share/doc/mutt/html/manual362.html
+%%SUB_ADD_E%%%%SUB_MAILDIR%%share/doc/mutt/html/manual363.html
+%%SUB_ADD_E%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual362.html
+%%SUB_ADD_E%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual363.html
+%%SUB_ADD_E%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual364.html
%%SUB_ADD_F%%share/doc/mutt/html/manual338.html
%%SUB_ADD_F%%share/doc/mutt/html/manual339.html
%%SUB_ADD_F%%share/doc/mutt/html/manual340.html
@@ -515,6 +545,11 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
%%SUB_ADD_F%%share/doc/mutt/html/manual363.html
%%SUB_ADD_F%%share/doc/mutt/html/manual364.html
%%SUB_ADD_F%%%%SUB_PGP%%share/doc/mutt/html/manual365.html
+%%SUB_ADD_F%%%%SUB_MAILDIR%%share/doc/mutt/html/manual365.html
+%%SUB_ADD_F%%%%SUB_MAILDIR%%share/doc/mutt/html/manual366.html
+%%SUB_ADD_F%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual365.html
+%%SUB_ADD_F%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual366.html
+%%SUB_ADD_F%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual367.html
%%SUB_ADD_G%%share/doc/mutt/html/manual338.html
%%SUB_ADD_G%%share/doc/mutt/html/manual339.html
%%SUB_ADD_G%%share/doc/mutt/html/manual340.html
@@ -545,5 +580,10 @@ share/locale/zh_TW/LC_MESSAGES/mutt.mo
%%SUB_ADD_G%%share/doc/mutt/html/manual365.html
%%SUB_ADD_G%%share/doc/mutt/html/manual366.html
%%SUB_ADD_G%%%%SUB_PGP%%share/doc/mutt/html/manual367.html
+%%SUB_ADD_G%%%%SUB_MAILDIR%%share/doc/mutt/html/manual367.html
+%%SUB_ADD_G%%%%SUB_MAILDIR%%share/doc/mutt/html/manual368.html
+%%SUB_ADD_G%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual367.html
+%%SUB_ADD_G%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual368.html
+%%SUB_ADD_G%%%%SUB_MAILDIRPGP%%share/doc/mutt/html/manual369.html
%%SUB_HTML%%@dirrm share/doc/mutt/html
%%PORTDOCS%%@dirrm share/doc/mutt