aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-12-17 14:17:24 +0800
committeredwin <edwin@FreeBSD.org>2004-12-17 14:17:24 +0800
commitf8e5df7023787f2e9fd051edc110eef9762044c6 (patch)
treecc20a7a57557e7d93660c526fb4be5aab99a5c1a
parent829a841cf1314642828edd85ea6a972bd43fcdbc (diff)
downloadfreebsd-ports-graphics-f8e5df7023787f2e9fd051edc110eef9762044c6.tar.gz
freebsd-ports-graphics-f8e5df7023787f2e9fd051edc110eef9762044c6.tar.zst
freebsd-ports-graphics-f8e5df7023787f2e9fd051edc110eef9762044c6.zip
[MAINTAINER] mail/milter-greylist: update to 1.6
- Update to 1.6 Added file(s): - files/patch-greylist.conf - files/patch-milter-greylist.c PR: ports/75101 Submitted by: Cyril Guibourg <aragorn+ports@teaser.fr>
-rw-r--r--mail/milter-greylist/Makefile2
-rw-r--r--mail/milter-greylist/distinfo4
-rw-r--r--mail/milter-greylist/files/patch-Makefile.in27
-rw-r--r--mail/milter-greylist/files/patch-greylist.conf11
-rw-r--r--mail/milter-greylist/files/patch-milter-greylist.c13
5 files changed, 50 insertions, 7 deletions
diff --git a/mail/milter-greylist/Makefile b/mail/milter-greylist/Makefile
index b4076b467b2..df4f55933d9 100644
--- a/mail/milter-greylist/Makefile
+++ b/mail/milter-greylist/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= milter-greylist
-PORTVERSION= 1.5.6
+PORTVERSION= 1.6
CATEGORIES= mail
MASTER_SITES= ftp://ftp.espci.fr/pub/milter-greylist/
EXTRACT_SUFX= .tgz
diff --git a/mail/milter-greylist/distinfo b/mail/milter-greylist/distinfo
index 3b2da67763d..e74f6cc587d 100644
--- a/mail/milter-greylist/distinfo
+++ b/mail/milter-greylist/distinfo
@@ -1,2 +1,2 @@
-MD5 (milter-greylist-1.5.6.tgz) = 69e3a19412a61b220c06a82f2bf80858
-SIZE (milter-greylist-1.5.6.tgz) = 102202
+MD5 (milter-greylist-1.6.tgz) = 9830e3a13aadf851a799131d9a40e931
+SIZE (milter-greylist-1.6.tgz) = 105679
diff --git a/mail/milter-greylist/files/patch-Makefile.in b/mail/milter-greylist/files/patch-Makefile.in
index 00542b0d940..e462f272c35 100644
--- a/mail/milter-greylist/files/patch-Makefile.in
+++ b/mail/milter-greylist/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Wed Jun 16 22:28:30 2004
-+++ Makefile.in Fri Jun 25 16:26:41 2004
+--- Makefile.in.orig Sun Nov 28 01:33:29 2004
++++ Makefile.in Sat Dec 11 14:22:50 2004
@@ -29,9 +29,9 @@
# OF THE POSSIBILITY OF SUCH DAMAGE.
#
@@ -7,9 +7,28 @@
-CFLAGS= @CFLAGS@ -D_BSD_SOURCE
-LDFLAGS= @LDFLAGS@
-LIBS= @LIBS@
-+CFLAGS= @CFLAGS@ -D_BSD_SOURCE -pthread
-+LDFLAGS= @LDFLAGS@ -pthread
++CFLAGS= -O2 -pthread
++LDFLAGS= -pthread
+LIBS= -lmilter
prefix= @prefix@
exec_prefix= @exec_prefix@
SYSCONFDIR= @sysconfdir@
+@@ -40,15 +40,15 @@
+ MANDIR= @mandir@
+ USER= @USER@
+
+-CC= @CC@
++#CC= @CC@
+ MKDEP= @MKDEP@
+ RM= @RM@
+ MV= @MV@
+ TEST= @TEST@
+ SED= @SED@
+ INSTALL= @INSTALL@
+-LEX= @LEX@
+-YACC= @YACC@
++#LEX= @LEX@
++#YACC= @YACC@
+ TRUE= @TRUE@
+
+ OBJ= milter-greylist.o pending.o except.o sync.o \
diff --git a/mail/milter-greylist/files/patch-greylist.conf b/mail/milter-greylist/files/patch-greylist.conf
new file mode 100644
index 00000000000..e6e0cf57efa
--- /dev/null
+++ b/mail/milter-greylist/files/patch-greylist.conf
@@ -0,0 +1,11 @@
+--- greylist.conf.orig Tue Nov 9 07:57:07 2004
++++ greylist.conf Mon Nov 15 22:04:12 2004
+@@ -109,7 +109,7 @@
+ #socket "/var/milter-greylist/milter-greylist.sock"
+
+ # The dumpfile location
+-#dumpfile "/var/milter-greylist/greylist.db"
++#dumpfile "/var/db/milter-greylist/greylist.db"
+
+ # How often should we dump to the dumpfile (0: on each change, -1: never)
+ #dumpfreq 10m
diff --git a/mail/milter-greylist/files/patch-milter-greylist.c b/mail/milter-greylist/files/patch-milter-greylist.c
new file mode 100644
index 00000000000..78060529ac8
--- /dev/null
+++ b/mail/milter-greylist/files/patch-milter-greylist.c
@@ -0,0 +1,13 @@
+--- milter-greylist.c.orig Sat Nov 27 15:43:17 2004
++++ milter-greylist.c Sat Dec 11 14:17:14 2004
+@@ -56,10 +56,6 @@
+ #endif
+ #include <sysexits.h>
+
+-#if HAVE_GETOPT_H
+-#include <getopt.h>
+-#endif
+-
+ #include <sys/types.h>
+ #include <sys/time.h>
+ #include <sys/stat.h>