aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2004-02-28 19:24:53 +0800
committeredwin <edwin@FreeBSD.org>2004-02-28 19:24:53 +0800
commitf93239989a9b42f0c78809e4436a4d3167fa41bf (patch)
tree3b047b56aff7b80ea5196e2453a47dc1d3ad755d
parentbb4498df85810fc9bf6e611d349523ed560eccf4 (diff)
downloadfreebsd-ports-graphics-f93239989a9b42f0c78809e4436a4d3167fa41bf.tar.gz
freebsd-ports-graphics-f93239989a9b42f0c78809e4436a4d3167fa41bf.tar.zst
freebsd-ports-graphics-f93239989a9b42f0c78809e4436a4d3167fa41bf.zip
Fix building and running on 5.2.1.
-rw-r--r--net/ngrep-lib/Makefile10
-rw-r--r--net/ngrep-lib/files/patch-ngrep-lib.c10
2 files changed, 12 insertions, 8 deletions
diff --git a/net/ngrep-lib/Makefile b/net/ngrep-lib/Makefile
index 71d4806db78..ab7453e0626 100644
--- a/net/ngrep-lib/Makefile
+++ b/net/ngrep-lib/Makefile
@@ -16,14 +16,8 @@ COMMENT= Easy packet filtering library based on ngrep
MAN3= ngrep-lib.3
HAS_CONFIGURE= yes
-CONFIGURE_ARGS+=--prefix=${PREFIX}
+CONFIGURE_ARGS+=--prefix=${PREFIX} -without-restart
INSTALLS_SHLIB= yes
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not install on FreeBSD ${OSVERSION}"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/ngrep-lib/files/patch-ngrep-lib.c b/net/ngrep-lib/files/patch-ngrep-lib.c
new file mode 100644
index 00000000000..475ff54a8e3
--- /dev/null
+++ b/net/ngrep-lib/files/patch-ngrep-lib.c
@@ -0,0 +1,10 @@
+--- ngrep-lib.c.orig Sat Feb 28 22:23:31 2004
++++ ngrep-lib.c Sat Feb 28 22:23:46 2004
+@@ -51,6 +51,7 @@
+ #include <netinet/udp.h>
+ #include <netinet/ip_icmp.h>
+
++#define PCAP_DONT_INCLUDE_PCAP_BPF_H
+ #include <pcap.h>
+ #include <net/bpf.h>
+