aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordecke <decke@FreeBSD.org>2015-03-19 17:52:24 +0800
committerdecke <decke@FreeBSD.org>2015-03-19 17:52:24 +0800
commitfe4fd0402b81c9558f2ed659f5b22576e13b697f (patch)
tree8887642773ee6dd15260f0c7cd5676da09040932
parentc5e3170d64cb704fa2ec624cad030f828bad6049 (diff)
downloadfreebsd-ports-graphics-fe4fd0402b81c9558f2ed659f5b22576e13b697f.tar.gz
freebsd-ports-graphics-fe4fd0402b81c9558f2ed659f5b22576e13b697f.tar.zst
freebsd-ports-graphics-fe4fd0402b81c9558f2ed659f5b22576e13b697f.zip
Add workaround for GCC build failure on 9.x taken from
multimedia/libvpx Reported by: package builder
-rw-r--r--multimedia/libdvbcsa/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/multimedia/libdvbcsa/Makefile b/multimedia/libdvbcsa/Makefile
index e1e80286c83..6327465c50d 100644
--- a/multimedia/libdvbcsa/Makefile
+++ b/multimedia/libdvbcsa/Makefile
@@ -18,6 +18,14 @@ INSTALL_TARGET= install-strip
USES= libtool
USE_LDCONFIG= yes
+.include <bsd.port.options.mk>
+
+# Workaround for GCC in 9.x post r260075
+# OSVERSION taken from r260135, the closest OSVERSION
+.if ${OSVERSION} > 902505 && ${OSVERSION} < 1000000
+CFLAGS+= -flax-vector-conversions
+.endif
+
.if defined(MACHINE_CPU) && ${MACHINE_CPU:Msse2}
CONFIGURE_ARGS+=--enable-sse2
.elif defined(MACHINE_CPU) && ${MACHINE_CPU:Mmmx}