diff options
author | netchild <netchild@FreeBSD.org> | 2004-05-25 18:16:16 +0800 |
---|---|---|
committer | netchild <netchild@FreeBSD.org> | 2004-05-25 18:16:16 +0800 |
commit | 0c396e9dbf7829d90b57ae57c84a82c019aebfe4 (patch) | |
tree | bcaf106bc900087280b057b4492b315f6a51376e /Makefile | |
parent | 01bb4116014c09c9806e7c41b4507f74d9f77f57 (diff) | |
download | freebsd-ports-graphics-0c396e9dbf7829d90b57ae57c84a82c019aebfe4.tar.gz freebsd-ports-graphics-0c396e9dbf7829d90b57ae57c84a82c019aebfe4.tar.zst freebsd-ports-graphics-0c396e9dbf7829d90b57ae57c84a82c019aebfe4.zip |
Add "fetchindex" target. It fetches the recent index file (INDEX _or_
INDEX-5).
A note about the implementation: I had to add the call to chmod to make
the index file readable to everyone. I'm a little bit surprised by this,
since my umask is 022. Either fetch(1) doesn't respect the umask or it
mirrors the permissions too (I haven't investigated this). Both
possibilities aren't documented in the man-page.
Approved by: kris (previous version without the chmod)
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 3 |
1 files changed, 3 insertions, 0 deletions
@@ -70,6 +70,9 @@ index: @rm -f ${.CURDIR}/${INDEXFILE} @cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE} +fetchindex: + @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE} && chmod a+r ${INDEXFILE} + INDEX_JOBS?= 2 ${.CURDIR}/${INDEXFILE}: |