aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authornetchild <netchild@FreeBSD.org>2004-05-25 18:16:16 +0800
committernetchild <netchild@FreeBSD.org>2004-05-25 18:16:16 +0800
commit0c396e9dbf7829d90b57ae57c84a82c019aebfe4 (patch)
treebcaf106bc900087280b057b4492b315f6a51376e /Makefile
parent01bb4116014c09c9806e7c41b4507f74d9f77f57 (diff)
downloadfreebsd-ports-graphics-0c396e9dbf7829d90b57ae57c84a82c019aebfe4.tar.gz
freebsd-ports-graphics-0c396e9dbf7829d90b57ae57c84a82c019aebfe4.tar.zst
freebsd-ports-graphics-0c396e9dbf7829d90b57ae57c84a82c019aebfe4.zip
Add "fetchindex" target. It fetches the recent index file (INDEX _or_
INDEX-5). A note about the implementation: I had to add the call to chmod to make the index file readable to everyone. I'm a little bit surprised by this, since my umask is 022. Either fetch(1) doesn't respect the umask or it mirrors the permissions too (I haven't investigated this). Both possibilities aren't documented in the man-page. Approved by: kris (previous version without the chmod)
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 60d95f817bd..6dabf0719bf 100644
--- a/Makefile
+++ b/Makefile
@@ -70,6 +70,9 @@ index:
@rm -f ${.CURDIR}/${INDEXFILE}
@cd ${.CURDIR} && make ${.CURDIR}/${INDEXFILE}
+fetchindex:
+ @cd ${.CURDIR} && fetch -am http://www.FreeBSD.org/ports/${INDEXFILE} && chmod a+r ${INDEXFILE}
+
INDEX_JOBS?= 2
${.CURDIR}/${INDEXFILE}: