aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2016-02-20 04:44:52 +0800
committerbdrewery <bdrewery@FreeBSD.org>2016-02-20 04:44:52 +0800
commit870062dcf134020ce4b7ba66454e231b93706aee (patch)
tree63163e79d5fbca8ca240fef20ac95a3421ae48bb /Mk/Uses
parente0ef72cd6798b2f50ec2183c6d921fadf0ad88d7 (diff)
downloadfreebsd-ports-graphics-870062dcf134020ce4b7ba66454e231b93706aee.tar.gz
freebsd-ports-graphics-870062dcf134020ce4b7ba66454e231b93706aee.tar.zst
freebsd-ports-graphics-870062dcf134020ce4b7ba66454e231b93706aee.zip
For PYTHON_NO_DEPENDS don't pass PYTHON_VERSION to dependencies.
The PYTHON_NO_DEPENDS only really makes sense in meta ports, where passing the PYTHON_VERSION doesn't make sense. The ports listed will pick up USES+=python and the default version as needed. This fixes depending on both lang/python2 and lang/python3 in a meta package.
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/python.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index dda99a339eb..c4c96c9ddc0 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -372,7 +372,9 @@ IGNORE= needs an unsupported version of Python
# try to find a different one, if the passed version fits into
# the supported version range.
PYTHON_VERSION?= python${_PYTHON_VERSION}
+.if !defined(PYTHON_NO_DEPENDS)
DEPENDS_ARGS+= PYTHON_VERSION=${PYTHON_VERSION}
+.endif
# NOTE:
#