aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1998-10-09 09:27:21 +0800
committerasami <asami@FreeBSD.org>1998-10-09 09:27:21 +0800
commit8eb3b0975dac385c1bceac413d3c91e236bab812 (patch)
tree88942d606692c59087f73122267a37fc2feddcc7 /Mk/bsd.port.mk
parent4d017fd1b830a127a693a15fb84ac05a7242cc09 (diff)
downloadfreebsd-ports-graphics-8eb3b0975dac385c1bceac413d3c91e236bab812.tar.gz
freebsd-ports-graphics-8eb3b0975dac385c1bceac413d3c91e236bab812.tar.zst
freebsd-ports-graphics-8eb3b0975dac385c1bceac413d3c91e236bab812.zip
Add new variable NO_FILTER_SHLIBS -- it will disable ELF <-> a.out shlib
name conversion. Use it for binary ports that come with its own private shlib dirs, ports that install linux compatibility libraries (thus following their naming conventions and not ours), etc. Reviewed by: Martin Cracauer <cracauer@FreeBSD.ORG>
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 3 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index c50a8ca556c..39eafd6837d 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
-# $Id: bsd.port.mk,v 1.291 1998/09/22 23:58:49 asami Exp $
+# $Id: bsd.port.mk,v 1.292 1998/10/06 21:12:14 asami Exp $
# $NetBSD: $
#
# bsd.port.mk - 940820 Jordan K. Hubbard.
@@ -2027,6 +2027,7 @@ generate-plist:
.endif
.endfor
@${SED} ${_sedsubplist} ${PLIST} >> ${TMPPLIST}
+.if !defined(NO_FILTER_SHLIBS)
.if (${PORTOBJFORMAT} == "aout")
@${SED} -e 's,\(/lib.*\.so\.[0-9]*\)$$,\1.0,' ${TMPPLIST} > ${TMPPLIST}.tmp
.else
@@ -2034,6 +2035,7 @@ generate-plist:
.endif
@${MV} -f ${TMPPLIST}.tmp ${TMPPLIST}
.endif
+.endif
${TMPPLIST}:
@cd ${.CURDIR} && ${MAKE} generate-plist