aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2011-11-11 03:50:26 +0800
committerrakuco <rakuco@FreeBSD.org>2011-11-11 03:50:26 +0800
commit3e5ed3a3f1a43488045d99f2ee328528d07b4031 (patch)
tree6a3d37a0c8dc3392d473d200ead15e75ac467d84 /Mk
parentd03edbd37b97d06974508dcb726f799e49565a6a (diff)
downloadfreebsd-ports-graphics-3e5ed3a3f1a43488045d99f2ee328528d07b4031.tar.gz
freebsd-ports-graphics-3e5ed3a3f1a43488045d99f2ee328528d07b4031.tar.zst
freebsd-ports-graphics-3e5ed3a3f1a43488045d99f2ee328528d07b4031.zip
Remove CMAKE_USE_PTHREAD.
This has been in area51 since April, and discussions with makc indicate this was only needed when we supported FreeBSD < 7. Approved by: avilla (mentor), portmgr (tabthorpe) Feature safe: yes
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.cmake.mk14
1 files changed, 0 insertions, 14 deletions
diff --git a/Mk/bsd.cmake.mk b/Mk/bsd.cmake.mk
index 29d39d48440..ad4bf201847 100644
--- a/Mk/bsd.cmake.mk
+++ b/Mk/bsd.cmake.mk
@@ -7,8 +7,6 @@
# Default: ${CONFIGURE_ENV}
# CMAKE_ARGS - Arguments passed to cmake
# Default: see below
-# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when compiling/linking
-# Default: not set
# CMAKE_BUILD_TYPE - Type of build (cmake predefined build types).
# Projects may have their own build profiles.
# CMake supports the following types: Debug,
@@ -89,18 +87,6 @@ INSTALL_TARGET?= install/strip
PLIST_SUB+= CMAKE_BUILD_TYPE="${CMAKE_BUILD_TYPE:L}"
#
-# Instruct cmake to compile/link with pthreads
-#
-.if defined(CMAKE_USE_PTHREAD)
-CFLAGS+= ${PTHREAD_CFLAGS}
-CXXFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
-
-CMAKE_ARGS+= -DCMAKE_THREAD_LIBS:STRING="${PTHREAD_LIBS}" \
- -DCMAKE_USE_PTHREADS:BOOL=ON
-.endif
-
-#
# Force makefile verbosity if needed
#
.if defined(CMAKE_VERBOSE) || defined(BATCH)