aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorflo <flo@FreeBSD.org>2011-09-10 20:39:34 +0800
committerflo <flo@FreeBSD.org>2011-09-10 20:39:34 +0800
commit436d1c0fcd5f2c7ace3152f1d2e04ec0bfd38aa4 (patch)
tree87a261a32a94fa3cb35eebef94a61d10fd45926b /Mk
parentab724d8cc2d1e98422f8341136bb3c3c1ae2d097 (diff)
downloadfreebsd-ports-graphics-436d1c0fcd5f2c7ace3152f1d2e04ec0bfd38aa4.tar.gz
freebsd-ports-graphics-436d1c0fcd5f2c7ace3152f1d2e04ec0bfd38aa4.tar.zst
freebsd-ports-graphics-436d1c0fcd5f2c7ace3152f1d2e04ec0bfd38aa4.zip
- only grep for firefox version in stdout [1], do the same for thunderbird and
seamonkey - limit output to the first line by using head -1, this fixes -i18n ports installation, if the parent port was build with DEBUG PR: ports/160365 [1] Submitted by: amdmi3 [1]
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk12
1 files changed, 6 insertions, 6 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 338591bef5e..42e763ecaf8 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -237,9 +237,9 @@ USE_FIREFOX= ${_FIREFOX_DEFAULT_VERSION}
# Setting/finding Firefox version we want.
.if exists(${LOCALBASE}/bin/firefox)
-_FIREFOX_VER!= ${LOCALBASE}/bin/firefox --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
+_FIREFOX_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
.elif exists(${LOCALBASE}/bin/firefox3)
-_FIREFOX_VER!= ${LOCALBASE}/bin/firefox3 --version | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
+_FIREFOX_VER!= ${LOCALBASE}/bin/firefox3 --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/Mozilla Firefox \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed Firefox version matches the wanted one
@@ -310,9 +310,9 @@ USE_SEAMONKEY= ${_SEAMONKEY_DEFAULT_VERSION}
# Setting/finding SeaMonkey version we want.
.if exists(${LOCALBASE}/bin/seamonkey)
-_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey --version | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
+_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
.elif exists(${LOCALBASE}/bin/seamonkey2)
-_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey2 --version | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
+_SEAMONKEY_VER!= ${LOCALBASE}/bin/seamonkey2 --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/Mozilla SeaMonkey \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed SeaMonkey version matches the wanted one
@@ -383,9 +383,9 @@ USE_THUNDERBIRD= ${_THUNDERBIRD_DEFAULT_VERSION}
# Setting/finding Thunderbird version we want.
.if exists(${LOCALBASE}/bin/thunderbird)
-_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird --version | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
+_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
.elif exists(${LOCALBASE}/bin/thunderbird3)
-_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird3 --version | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
+_THUNDERBIRD_VER!= ${LOCALBASE}/bin/thunderbird3 --version 2>/dev/null | ${HEAD} -1 | ${SED} -e 's/ Thunderbird \([0-9]\)\.\([0-9]*\).*/\1\2/'
.endif
# Check if installed Thunderbird version matches the wanted one