aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-04-23 19:51:52 +0800
committergahr <gahr@FreeBSD.org>2013-04-23 19:51:52 +0800
commit46f22ba7bb87908e6db7504337804a01cd5b1061 (patch)
tree85fa201a8b2f77aa2eeebf378af8a1d9cc666b3a /Mk
parent2c03cc4ccce4b31cc35f5341686aa26ccd4e7e38 (diff)
downloadfreebsd-ports-graphics-46f22ba7bb87908e6db7504337804a01cd5b1061.tar.gz
freebsd-ports-graphics-46f22ba7bb87908e6db7504337804a01cd5b1061.tar.zst
freebsd-ports-graphics-46f22ba7bb87908e6db7504337804a01cd5b1061.zip
- Remove lang/tcl83 and x11-toolkits/tk83 (expired)
- Remove references to Tcl/Tk 8.3 from bsd.tcl.mk - Update ports that required 8.3+ to require 8.4+ (since 8.5 is the default, I don't expect this change to cause much trouble)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.tcl.mk19
1 files changed, 9 insertions, 10 deletions
diff --git a/Mk/bsd.tcl.mk b/Mk/bsd.tcl.mk
index caec666ad0b..bfd43e47a43 100644
--- a/Mk/bsd.tcl.mk
+++ b/Mk/bsd.tcl.mk
@@ -12,7 +12,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# USE_TCL - Add library dependency on Tcl. If no version is given by the maintainer
# via the port or by the user via defined variable try to find the highest
# stable installed version.
-# Available values: yes 86+ 85+ 84+ 83+ 85 84 83
+# Available values: yes 86+ 85+ 84+ 85 84
# NOTE: - default value 85 is used in case of USE_TCL=yes
#
# USE_TCL_BUILD - Add buildtime dependency on Tcl (tclsh).
@@ -31,9 +31,9 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# - ports using the wrapper should support default Tcl (8.5)
##
# INVALID_TCL_VER - This variable contains a list of Tcl versions not supported by the port.
-# This setting is effective only when USE_TCL is set to a range (e.g. 83+)
+# This setting is effective only when USE_TCL is set to a range (e.g. 84+)
# WITH_TCL_VER - User defined global variable to set Tcl version
-# This variable is effective only if USE_TCL is set to a range (e.g. 83+)
+# This variable is effective only if USE_TCL is set to a range (e.g. 84+)
# and WITH_TCL_VER points inside that range.
# NOTE: INVALID_TCL_VER takes precedence
# <UNIQUENAME>_WITH_TCL_VER - User defined port specific variable to set Tcl version
@@ -44,7 +44,7 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# USE_TK - Add library dependency on Tk. If no version is given by the maintainer
# via the port or by the user via defined variable try to find the highest
# stable installed version.
-# Avaliable values: yes 86+ 85+ 84+ 83+ 85 84 83
+# Avaliable values: yes 86+ 85+ 84+ 85 84
# NOTE: - overrides USE_TCL
# - default value 85 is used in case of USE_TK=yes
#
@@ -64,9 +64,9 @@ Tcl_Include_MAINTAINER= mm@FreeBSD.org
# - ports using the wrapper should support default Tk (8.5)
##
# INVALID_TK_VER - This variable contains a list of Tk versions not supported by the port
-# This setting is effective only when USE_TK is set to a range (e.g. 83+)
+# This setting is effective only when USE_TK is set to a range (e.g. 84+)
# WITH_TK_VER - User defined global variable to set Tk version.
-# This variable is effective only if USE_TK is set to a range (e.g. 83+)
+# This variable is effective only if USE_TK is set to a range (e.g. 84+)
# and WITH_TK_VER points inside that range.
# NOTE: overrides WITH_TCL_VER.
# <UNIQUENAME>_WITH_TK_VER - User defined port specific variable to set Tk version
@@ -158,11 +158,10 @@ INVALID_TCL_VER:= ${INVALID_TK_VER}
. if defined(USE_TCL)
_TCL_DEFAULT_VERSION= 85
-_TCL_VERSIONS= 86 85 84 83
-_TCL_RANGE_VERSIONS= 86+ 85+ 84+ 83+
+_TCL_VERSIONS= 86 85 84
+_TCL_RANGE_VERSIONS= 86+ 85+ 84+
# For specifying [85, 84, ..]+
-_TCL_83P= 83 84 85 86
_TCL_84P= 84 85 86
_TCL_85P= 85 86
_TCL_86P= 86
@@ -201,7 +200,7 @@ USE_TCL= ${_TCL_VER}
. endfor
. endif
-# Check for highest installed Tcl (if e.g. 83+ is specified)
+# Check for highest installed Tcl (if e.g. 84+ is specified)
# The default version of Tcl counts as the highest
. if ${_TCL_VER} == "no"
. for ver in ${_TCL_RANGE_VERSIONS}