aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2014-12-03 22:55:25 +0800
committerbeat <beat@FreeBSD.org>2014-12-03 22:55:25 +0800
commit4ada0905f426db8e0a22d973dffb8401bc442d6f (patch)
tree1a32479f5df7c300e66e4b2c4ca0ed5c4bfe2463 /Mk
parentd73e6c902b4b51ed28eff10428e9feaddcd71d44 (diff)
downloadfreebsd-ports-graphics-4ada0905f426db8e0a22d973dffb8401bc442d6f.tar.gz
freebsd-ports-graphics-4ada0905f426db8e0a22d973dffb8401bc442d6f.tar.zst
freebsd-ports-graphics-4ada0905f426db8e0a22d973dffb8401bc442d6f.zip
- Update Thunderbird to 31.3.0
- Update gmp-api to 35.0 - Update openh264 to 1.2 - Update NSS to 3.17.3 - Update Firefox to 34.0.5 - Update Firefox ESR 31.3.0 - Update libxul to 31.3.0 - Improve CONFIGURE_TARGET handling - Always build using client.mk - Switch to clang by default on systems without libc++ (/stable/8 and /stable/9) - Drop lang/python2 dependency, only lang/python27 is required to build - Use DuckDuckGo searchplugin from upstream (has suggestions and purposes) - Backport a few about:memory fixes - Backport Web Notifications libnotify integration - Add GTK3 option for www/firefox. Adwaita is a bit broken since Gtk 3.14, see: https://bugzilla.mozilla.org/show_bug.cgi?id=1073117 PR: 195559 Submitted by: Jan Beich MFH: 2014Q4 Security: http://vuxml.org/freebsd/7ae61870-9dd2-4884-a2f2-f19bb5784d09.html
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/gecko.mk6
-rw-r--r--Mk/bsd.gecko.mk45
2 files changed, 21 insertions, 30 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index caa755ec910..2b0e2abd241 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -37,12 +37,12 @@ RUN_DEPENDS+= libxul>=31:${PORTSDIR}/www/libxul
.elif ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 31
-_GECKO_VERSIONS= 31 33
+_GECKO_VERSIONS= 31 34
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
31_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-33_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+34_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
@@ -94,7 +94,7 @@ _GECKO_WANTED_VERSIONS:= ${_GECKO_VERSION:M[0-9][0-9]}
_GECKO_WANTED_VERSIONS?= ${_GECKO_DEFAULT_VERSION}
.if defined(_GECKO_MIN_VERSION)
-. for _v in _GECKO_VERSIONS
+. for _v in ${_GECKO_VERSIONS}
. if ${_GECKO_MIN_VERSION} <= ${_v}
_GECKO_WANTED_VERSIONS+= ${_v}
. endif
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index d9e7b0464e0..5fd363d5e12 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -85,8 +85,8 @@ MOZILLA_VER?= ${PORTVERSION}
MOZILLA_BIN?= ${PORTNAME}-bin
MOZILLA_EXEC_NAME?=${MOZILLA}
MOZ_RPATH?= ${MOZILLA}
-USES+= cpe compiler:c++11-lib gmake iconv perl5 pkgconfig \
- python:2,build desktop-file-utils
+USES+= cpe compiler:c++11-lang gmake iconv perl5 pkgconfig \
+ python:2.7,build desktop-file-utils
CPE_VENDOR?=mozilla
USE_PERL5= build
USE_XORG= xext xrender xt
@@ -96,10 +96,14 @@ MOZSRC?= ${WRKSRC}
WRKSRC?= ${WRKDIR}/mozilla
PLISTF?= ${WRKDIR}/plist_files
+MOZ_OBJDIR?= ${WRKSRC}/obj-${CONFIGURE_TARGET}
+
MOZ_PIS_DIR?= lib/${MOZILLA}/init.d
PORT_MOZCONFIG?= ${FILESDIR}/mozconfig.in
MOZCONFIG?= ${WRKSRC}/.mozconfig
+# XXX Not ?= because fmake uses MAKEFILE internally
+MAKEFILE= ${WRKSRC}/client.mk
MOZILLA_PLIST_DIRS?= bin lib share/pixmaps share/applications
PKGINSTALL?= ${WRKDIR}/pkg-install
PKGDEINSTALL?= ${WRKDIR}/pkg-deinstall
@@ -109,9 +113,13 @@ PKGDEINSTALL_INC?= ${.CURDIR}/../../www/firefox/files/pkg-deinstall.in
MOZ_PKGCONFIG_FILES?= ${MOZILLA}-gtkmozembed ${MOZILLA}-js \
${MOZILLA}-xpcom ${MOZILLA}-plugin
+ALL_TARGET?= build
+
+CONFIGURE_TARGET:=${ARCH:C/amd64/x86_64/}-portbld-${OPSYS:tl}${OSREL}
MOZ_EXPORT+= ${CONFIGURE_ENV} \
PERL="${PERL}"
-MOZ_OPTIONS+= --prefix="${PREFIX}"
+MOZ_OPTIONS+= ${CONFIGURE_TARGET} --prefix="${PREFIX}"
+MOZ_MK_OPTIONS+=MOZ_OBJDIR="${MOZ_OBJDIR}"
CPPFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -Wl,-rpath,${PREFIX}/lib/${MOZILLA}
@@ -330,8 +338,6 @@ MOZ_OPTIONS+= --disable-libproxy
USES:= compiler:gcc-c++11-lib ${USES:Ncompiler*c++11*}
USE_DISPLAY=yes
-.undef GNU_CONFIGURE
-MAKEFILE= ${WRKSRC}/client.mk
ALL_TARGET= profiledbuild
MOZ_EXPORT+=MOZ_OPTIMIZE_FLAGS="-Os" MOZ_PGO_OPTIMIZE_FLAGS="${CFLAGS:M-O*}"
.endif
@@ -428,7 +434,6 @@ MOZ_SED_ARGS+= -e's|@CPPFLAGS@|${CPPFLAGS}|g' \
MOZCONFIG_SED?= ${SED} ${MOZ_SED_ARGS}
.if ${ARCH} == amd64
-CONFIGURE_TARGET=x86_64-unknown-${OPSYS:tl}${OSREL}
. if ${USE_MOZILLA:M-nss}
USE_BINUTILS= # intel-gcm.s
CFLAGS+= -B${LOCALBASE}/bin
@@ -450,17 +455,6 @@ CFLAGS+= -mminimal-toc
MOZ_OPTIONS+= --disable-v1-string-abi
.endif
-.if defined(OBJDIR_BUILD)
-CONFIGURE_SCRIPT=../configure
-
-MOZ_OBJDIR= ${WRKSRC}/obj-${CONFIGURE_TARGET}
-CONFIGURE_WRKSRC=${MOZ_OBJDIR}
-BUILD_WRKSRC= ${MOZ_OBJDIR}
-INSTALL_WRKSRC= ${MOZ_OBJDIR}
-.else
-MOZ_OBJDIR= ${WRKSRC}
-.endif
-
.else # bsd.port.post.mk
pre-extract: gecko-pre-extract
@@ -566,17 +560,14 @@ gecko-moz-pis-patch:
@${MOZCONFIG_SED} < ${FILESDIR}/${moz} > ${WRKDIR}/${moz}
.endfor
-pre-configure: gecko-pre-configure
-
-gecko-pre-configure:
-.if defined(OBJDIR_BUILD)
- ${MKDIR} ${MOZ_OBJDIR}
-.endif
-
-post-configure: gecko-post-configure
+do-configure: gecko-do-configure
-gecko-post-configure:
- @${ECHO_CMD} "#define JNIIMPORT" >> ${MOZSRC}/mozilla-config.h
+gecko-do-configure:
+ @(if ! ${CONFIGURE_ENV} ${DO_MAKE_BUILD} configure; then \
+ ${ECHO_MSG} "===> Script \"${CONFIGURE_SCRIPT}\" failed unexpectedly."; \
+ (${ECHO_CMD} ${CONFIGURE_FAIL_MESSAGE}) | ${FMT} 75 79 ; \
+ ${FALSE}; \
+ fi)
pre-install: gecko-moz-pis-pre-install
post-install-script: gecko-create-plist