aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorhq <hq@FreeBSD.org>2005-02-28 07:49:33 +0800
committerhq <hq@FreeBSD.org>2005-02-28 07:49:33 +0800
commit518ec72dc353c6125a2e40a900cd66c14d908bcb (patch)
tree835ef9f3bdde6668b232e632c54376ee44703093 /Mk
parent11c069f26353f9419ce74488371b24ad65a77652 (diff)
downloadfreebsd-ports-graphics-518ec72dc353c6125a2e40a900cd66c14d908bcb.tar.gz
freebsd-ports-graphics-518ec72dc353c6125a2e40a900cd66c14d908bcb.tar.zst
freebsd-ports-graphics-518ec72dc353c6125a2e40a900cd66c14d908bcb.zip
Add JAVA_VERSION, JAVA_OS and JAVA_VENDOR to SUB_LIST.
NOTE: these are only added if the related variables are defined by the port. This should ease the configuration of launcher shell scripts used for Java application ports, when they are using javavmwrapper to invoke a JVM. From now, a simple launcher that suits most of the Java application ports can be writen using the following scheme: #!/bin/sh JAVA_VERSION="%%JAVA_VERSION%%" \ "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/myport.jar" "$@" As mentioned above, this is of course only correct provided that the port defines JAVA_VERSION. Approved by: glewis (co-maintainer)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.java.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/Mk/bsd.java.mk b/Mk/bsd.java.mk
index 24a247c1d13..6fc61b778b9 100644
--- a/Mk/bsd.java.mk
+++ b/Mk/bsd.java.mk
@@ -157,6 +157,15 @@ PLIST_SUB+= JAVASHAREDIR="${JAVASHAREDIR:S,^${PREFIX}/,,}" \
SUB_LIST+= JAVASHAREDIR="${JAVASHAREDIR}" \
JAVAJARDIR="${JAVAJARDIR}" \
JAVALIBDIR="${JAVALIBDIR}"
+. if defined(JAVA_VERSION)
+SUB_LIST+= JAVA_VERSION="${JAVA_VERSION}"
+. endif
+. if defined(JAVA_VENDOR)
+SUB_LIST+= JAVA_VENDOR="${JAVA_VENDOR}"
+. endif
+. if defined(JAVA_OS)
+SUB_LIST+= JAVA_OS="${JAVA_OS}"
+. endif
# The complete list of Java versions, os and vendors supported.
__JAVA_VERSION_LIST= 1.1 1.2 1.3 1.4 1.5
a>miwi2007-06-073-5/+62 * - Welcome X.org 7.2 \o/.flz2007-05-201-0/+1 * - Update to 1.6.0 latest snapshotrafan2007-01-233-9/+288 * - Update to 1.5.0miwi2006-11-163-103/+149 * - Remove pecl-imagick support, because pecl-imagick is deprecated and will bemiwi2006-08-282-9/+16 * Finally make this file correspond to what was tested on the cluster.linimon2006-07-091-2/+0 * Change BROKEN_WITH to IGNORE_WITH.linimon2006-07-091-1/+1 * Change all bogus uses of BROKEN to IGNORE. See CHANGES 20060705.linimon2006-07-051-0/+1 * - Fix pkg-deinstall scriptpav2006-06-271-1/+1 * - Update to 1.4.0pav2006-06-265-72/+222 * Fix package build.ale2006-05-081-4/+3