aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-04 08:29:00 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-04 08:29:00 +0800
commit7f3e0dc4ce78c48deb7287779ee515ca50789704 (patch)
tree827cac7c3246641dfe20bf7d3518cc693baf3eaf /Mk
parent3ae3f60a0e5dfea558f226a96fbfc7885703a872 (diff)
downloadfreebsd-ports-graphics-7f3e0dc4ce78c48deb7287779ee515ca50789704.tar.gz
freebsd-ports-graphics-7f3e0dc4ce78c48deb7287779ee515ca50789704.tar.zst
freebsd-ports-graphics-7f3e0dc4ce78c48deb7287779ee515ca50789704.zip
www/firefox: unbreak build with DEBUG=on after r425099
Traceback (most recent call last): File "configure.py", line 94, in <module> sys.exit(main(sys.argv)) File "configure.py", line 22, in main sandbox.run(os.path.join(os.path.dirname(__file__), 'moz.configure')) File "python/mozbuild/mozbuild/configure/__init__.py", line 241, in run self._value_for(option) File "python/mozbuild/mozbuild/configure/__init__.py", line 305, in _value_for return self._value_for_option(obj) File "python/mozbuild/mozbuild/util.py", line 924, in method_call cache[args] = self.func(instance, *args) File "python/mozbuild/mozbuild/configure/__init__.py", line 370, in _value_for_option % (e.arg, reason, e.old_arg, e.old_origin)) mozbuild.configure.options.InvalidOptionError: '--enable-debug-symbols' implied by '--enable-debug' conflicts with '--disable-debug-symbols' from the mozconfig *** Fix above errors and then restart with\ "gmake -f client.mk build" MFH: 2016Q4 (blanket)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gecko.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/Mk/bsd.gecko.mk b/Mk/bsd.gecko.mk
index 50ce2b92c44..c3a2372e09c 100644
--- a/Mk/bsd.gecko.mk
+++ b/Mk/bsd.gecko.mk
@@ -266,8 +266,7 @@ MOZ_OPTIONS+= --enable-necko-protocols=${MOZ_PROTOCOLS}
.endif
# others
MOZ_OPTIONS+= --with-system-zlib \
- --with-system-bz2 \
- --disable-debug-symbols
+ --with-system-bz2
# API keys from www/chromium
# http://www.chromium.org/developers/how-tos/api-keys
@@ -381,7 +380,7 @@ MOZ_OPTIONS+= --disable-rust
MOZ_OPTIONS+= --enable-debug --disable-release
STRIP= # ports/184285
.else
-MOZ_OPTIONS+= --disable-debug --enable-release
+MOZ_OPTIONS+= --disable-debug --disable-debug-symbols --enable-release
.endif
.if ${PORT_OPTIONS:MDTRACE}