aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authoralepulver <alepulver@FreeBSD.org>2008-02-10 07:11:51 +0800
committeralepulver <alepulver@FreeBSD.org>2008-02-10 07:11:51 +0800
commit831951cc3ce0044542ba5b71db09bfc8d12ee30e (patch)
treee9f03a6cc5ba2bef52d223034c890b64e54b74c6 /Mk
parente4dd5a9062b7429cfea1696755b48a3dfdfbc788 (diff)
downloadfreebsd-ports-graphics-831951cc3ce0044542ba5b71db09bfc8d12ee30e.tar.gz
freebsd-ports-graphics-831951cc3ce0044542ba5b71db09bfc8d12ee30e.tar.zst
freebsd-ports-graphics-831951cc3ce0044542ba5b71db09bfc8d12ee30e.zip
- Change LUA_PREFIX default value from LOCALBASE to PREFIX.
Actually the Lua prefix should be recorded on each port and read from there (as with "*-config --prefix" scripts), instead of this assumption. But supporting PREFIX is a requirement, while supporting different custom combinations of a general PREFIX for dependencies and a different PREFIX for a specific port is not. Also the latter could be achieved by changing LOCALBASE too, or directly modifying LUA_PREFIX in this case. PR: ports/120277 Submitted by: Hirohisa Yamaguchi <umq@ueo.co.jp>
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.lua.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.lua.mk b/Mk/bsd.lua.mk
index f0d00735479..32046cef039 100644
--- a/Mk/bsd.lua.mk
+++ b/Mk/bsd.lua.mk
@@ -413,7 +413,7 @@ LUA_VER_SH?= ${LUA_VER:C/[[:digit:]]\.([[:digit:]])/\1/}
LUA_VER_STR?= ${LUA_VER:S/.//g}
# Paths.
-LUA_PREFIX?= ${LOCALBASE}
+LUA_PREFIX?= ${PREFIX}
LUA_SUBDIR?= lua${LUA_VER_STR}
LUA_BINDIR?= ${LUA_PREFIX}/bin/${LUA_SUBDIR}
LUA_INCDIR?= ${LUA_PREFIX}/include/${LUA_SUBDIR}