aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-02-09 04:23:45 +0800
committermiwi <miwi@FreeBSD.org>2009-02-09 04:23:45 +0800
commit850cef4260e9e0e88eecffb7852812ca4e46c7d5 (patch)
tree751926883c8a26153b8ecc8a0f51b356a7b6fc66 /Mk
parent74a4dc231af2c5e5c5511d5c089cac68279f5e42 (diff)
downloadfreebsd-ports-graphics-850cef4260e9e0e88eecffb7852812ca4e46c7d5.tar.gz
freebsd-ports-graphics-850cef4260e9e0e88eecffb7852812ca4e46c7d5.tar.zst
freebsd-ports-graphics-850cef4260e9e0e88eecffb7852812ca4e46c7d5.zip
The KDE FreeBSD team is proud to announce the release of KDE 4.2.0
for FreeBSD. The official KDE 4.2.0 (Codename: "The Answer") release notes can be found at: http://kde.org/announcements/4.2/index.php. New supported languages include Arabic, Icelandic, Basque, Hebrew, Romanian, Tajik and several Indian languages (Bengali India, Gujarati, Kannada, Maithili, Marathi) indicating a rise in popularity in this part of Asia. New ports for KDE 4.2.0: arabic/kde4-l10n Arabic hebrew/kde4-l10n Hebrew misc/kde4-l10n-bn_IN Bengali (India) misc/kde4-l10n-eu Basque misc/kde4-l10n-gu Gujarati misc/kde4-l10n-is Icelandic misc/kde4-l10n-kn Kannada misc/kde4-l10n-mai Maithili misc/kde4-l10n-mr Marathi misc/kde4-l10n-ro Romanian misc/kde4-l10n-tg Tajik math/eigen2 Lightweight library for vector and matrix math graphics/kipi-plugins-kde4 KDE4 kipi graphics plugins sysutils/policykit-kde PolicyKit manager for KDE Unfortunately FreeBSD 6.4 support is dropped. We'd like to say thanks for feedback and help to: Matt Tosto, Kris Moore, stickibit, David Johnson, Markus Brueffer, David Naylor, Thomas Schlesinger, Warren Liddell, Thomas Abthorpe, Diego Depaoli, Mats Andreassen, portmgr for exp-run and repocopies.
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.cmake.mk6
-rw-r--r--Mk/bsd.kde4.mk60
-rw-r--r--Mk/bsd.qt.mk8
3 files changed, 51 insertions, 23 deletions
diff --git a/Mk/bsd.cmake.mk b/Mk/bsd.cmake.mk
index 812642a2737..5fcd8cf2b61 100644
--- a/Mk/bsd.cmake.mk
+++ b/Mk/bsd.cmake.mk
@@ -10,6 +10,9 @@
# CMAKE_USE_PTHREAD - Instruct cmake to use pthreads when
# compiling/linking
# Default: not set
+# CMAKE_BUILD_TYPE - Type of build (cmake predefined build types),
+# affects on CFALGS and thus should not be set.
+# Default: none (which respects CFLAGS)
# CMAKE_VERBOSE - Verbose build
# Default: not set
# CMAKE_SOURCE_PATH - Path to sourcedir for cmake
@@ -45,13 +48,14 @@ CMAKE_ARGS+= -DCMAKE_C_COMPILER:STRING="${CC}" \
-DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
-DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}" \
-DCMAKE_INSTALL_PREFIX:PATH="${CMAKE_INSTALL_PREFIX}" \
- -DCMAKE_BUILD_TYPE:STRING=""
+ -DCMAKE_BUILD_TYPE:STRING="${CMAKE_BUILD_TYPE}"
#
# Default build type and sourcedir
#
CMAKE_SOURCE_PATH?= .
CMAKE_INSTALL_PREFIX?= ${PREFIX}
+CMAKE_BUILD_TYPE?= #none
#
# Instruct cmake to compile/link with pthreads
diff --git a/Mk/bsd.kde4.mk b/Mk/bsd.kde4.mk
index 12fc8514967..6a4c3ec2ba7 100644
--- a/Mk/bsd.kde4.mk
+++ b/Mk/bsd.kde4.mk
@@ -49,7 +49,8 @@ Kde_Include_MAINTAINER= kde@FreeBSD.org
# but this could be changed in a future.
#
-KDE4_VERSION= 4.1.4
+KDE4_VERSION= 4.2.0
+KDE4_BRANCH?= stable
#
# KDE4 is installed into its own prefix to not conflict with KDE3
@@ -70,12 +71,12 @@ MASTER_SITE_KDE_kde= ${kmaster:S@%SUBDIR%/@${ksub}/@g}
#
# KDE4 modules
#
-_USE_KDE4_ALL= akonadi automoc4 kdebase kdehier kdelibs kdeprefix \
+_USE_KDE4_ALL= akonadi automoc4 kdebase kdehier kdelibs kdeprefix \
pimlibs runtime sharedmime workspace
akonadi_LIB_DEPENDS= akonadiprotocolinternals.1:${PORTSDIR}/databases/akonadi
-automoc4_BUILD_DEPENDS= ${KDE4_PREFIX}/bin/automoc4:${PORTSDIR}/devel/automoc4
+automoc4_BUILD_DEPENDS= ${LOCALBASE}/bin/automoc4:${PORTSDIR}/devel/automoc4
kdebase_LIB_DEPENDS= konq.7:${PORTSDIR}/x11/kdebase4
@@ -95,8 +96,45 @@ sharedmime_RUN_DEPENDS= kde4-shared-mime-info>=1:${PORTSDIR}/misc/kde4-shared-m
workspace_LIB_DEPENDS= kscreensaver.5:${PORTSDIR}/x11/kdebase4-workspace
+#
+# Common build related stuff for kde4 ports. It's not intended for usage
+# in KDE4-dependent ports
+#
+.if defined(KDE4_BUILDENV)
+
+.if ${OSVERSION} < 700042
+BROKEN= does not build on 6.x. See http://miwi.bsdcrew.de/2009/01/30/status-report-kde-42-and-freebsd-64-support/
+.endif
+
+.if ${KDE4_BRANCH} == "unstable"
+WITH_DEBUG=yes
+.endif
+
+.if defined(WITH_DEBUG)
+CMAKE_BUILD_TYPE= debug
+.else
+CMAKE_BUILD_TYPE= release
.endif
+PLIST_SUB+= KDE4_VERSION="${KDE4_VERSION}" \
+ KDE4_BUILD_TYPE="${CMAKE_BUILD_TYPE}"
+
+USE_LDCONFIG= yes
+
+USE_CMAKE= yes
+# TODO: bsd.cmake.mk should be fixed first
+# CMAKE_SOURCE_PATH= ${WRKSRC}
+# CONFIGURE_WRKSRC?= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
+# BUILD_WRKSRC?= ${CONFIGURE_WRKSRC}
+# INSTALL_WRKSRC?= ${CONFIGURE_WRKSRC}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
+CMAKE_SOURCE_PATH= ..
+
+.endif # KDE4_BUILDENV
+
+.endif #!defined(_POSTMKINCLUDED) && !defined(Kde_Pre_Include)
+
.if defined(_POSTMKINCLUDED) && !defined(Kde_Post_Include)
Kde_Post_Include= bsd.kde4.mk
@@ -119,18 +157,4 @@ IGNORE= cannot install: Unknown component ${component}
. endif
.endfor
-#
-# Common build related stuff for kde4 ports. It's not intended for usage
-# in KDE4-dependent ports
-#
-.if defined(KDE4_BUILDENV)
-USE_CMAKE= yes
-
-USE_LDCONFIG= ${KDE4_PREFIX}/lib ${KDE4_PREFIX}/lib/kde4
-
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
-CMAKE_SOURCE_PATH= ..
-
-.endif # KDE4_BUILDENV
-
-.endif
+.endif #defined(_POSTMKINCLUDED) && !defined(Kde_Post_Include)
diff --git a/Mk/bsd.qt.mk b/Mk/bsd.qt.mk
index 9b55b13b942..a4494200acf 100644
--- a/Mk/bsd.qt.mk
+++ b/Mk/bsd.qt.mk
@@ -93,7 +93,7 @@ QT4_VERSION?= 4.4.3
_QT_COMPONENTS_ALL= accessible assistant assistant-adp assistantclient \
clucene codecs-cn codecs-jp codecs-kr codecs-tw corelib \
dbus designer doc help help-tools gui iconengines imageformats \
- inputmethods linguist makeqpf moc network opengl \
+ inputmethods linguist l10n makeqpf moc network opengl \
pixeltool porting phonon phonon-gst qdbusviewer \
qmake qt3support qtconfig qtestlib qvfb rcc script \
sql svg uic uic3 webkit xml xmlpatterns xmlpatterns-tool
@@ -119,6 +119,7 @@ iconengines_DEPENDS= graphics/qt4-iconengines
imageformats_DEPENDS= graphics/qt4-imageformats
inputmethods_DEPENDS= x11/qt4-inputmethods
linguist_DEPENDS= devel/qt4-linguist
+l10n_DEPENDS= misc/qt4-l10n
makeqpf_DEPENDS= devel/qt4-makeqpf
moc_DEPENDS= devel/qt4-moc
network_DEPENDS= net/qt4-network
@@ -165,6 +166,7 @@ iconengines_build_DEPENDS= ${iconengines_DEPENDS}
imageformats_build_DEPENDS= ${imageformats_DEPENDS}
inputmethods_build_DEPENDS= ${inputmethods_DEPENDS}
linguist_build_DEPENDS= ${linguist_DEPENDS}
+l10n_build_DEPENDS= ${l10n_DEPENDS}
makeqpf_build_DEPENDS= ${makeqpf_DEPENDS}
moc_build_DEPENDS= ${moc_DEPENDS}
network_build_DEPENDS= ${network_DEPENDS}
@@ -211,6 +213,7 @@ iconengines_run_DEPENDS= ${iconengines_DEPENDS}
imageformats_run_DEPENDS= ${imageformats_DEPENDS}
inputmethods_run_DEPENDS= ${inputmethods_DEPENDS}
linguist_run_DEPENDS= ${linguist_DEPENDS}
+l10n_run_DEPENDS= ${l10n_DEPENDS}
makeqpf_run_DEPENDS= ${makeqpf_DEPENDS}
moc_run_DEPENDS= ${moc_DEPENDS}
network_run_DEPENDS= ${network_DEPENDS}
@@ -262,9 +265,6 @@ RUN_DEPENDS+= ${${ext}_QT4_PREFIX}${${ext}_NAME}>=${${ext}_QT4_VERSION}:${PORTSD
IGNORE= cannot install: unknown Qt4 component -- ${ext}
.endif
.endfor
-.else
-BUILD_DEPENDS+= qt4>=${QT4_VERSION}:${PORTSDIR}/devel/qt4
-RUN_DEPENDS+= qt4>=${QT4_VERSION}:${PORTSDIR}/devel/qt4
.endif
.endif