aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-11-04 17:30:22 +0800
committerrene <rene@FreeBSD.org>2013-11-04 17:30:22 +0800
commita0385912846a0fdac08cf28d0f4ef8dea65a3a57 (patch)
tree5b64406211c1cc28cce0af30ec91a7be678c567f /Mk
parent6b19e2b93c7966fb10330656954504ee91170616 (diff)
downloadfreebsd-ports-graphics-a0385912846a0fdac08cf28d0f4ef8dea65a3a57.tar.gz
freebsd-ports-graphics-a0385912846a0fdac08cf28d0f4ef8dea65a3a57.tar.zst
freebsd-ports-graphics-a0385912846a0fdac08cf28d0f4ef8dea65a3a57.zip
Using stage does not magically enforce the use of sane package tools, so
always use the "@unexec rmdir" form in TMPPLIST. @dirrmtry lines are substituted with this in bsd.port.mk, but only when generating TMPPLIST. While here update the description in the header. Submitted by: QAT for commit r332642 (8.4-QAT/i386)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/kmod.mk6
1 files changed, 2 insertions, 4 deletions
diff --git a/Mk/Uses/kmod.mk b/Mk/Uses/kmod.mk
index 1a2db0ad386..bb0cc92d2e6 100644
--- a/Mk/Uses/kmod.mk
+++ b/Mk/Uses/kmod.mk
@@ -1,6 +1,6 @@
# $FreeBSD$
#
-# Handles dependency on kernel sources
+# Handles common items for kernel module ports.
#
# MAINTAINER: rene@FreeBSD.org
#
@@ -43,10 +43,8 @@ kmod-post-install:
${ECHO_CMD} "@exec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
${ECHO_CMD} "@unexec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
.if defined(NO_STAGE)
- ${ECHO_CMD} "@unexec rmdir ${KMODDIR} 2>/dev/null || true" >> ${TMPPLIST}
/usr/sbin/kldxref ${KMODDIR}
-.else
- ${ECHO_CMD} "@dirrmtry ${KMODDIR}" >> ${TMPPLIST}
.endif
+ ${ECHO_CMD} "@unexec rmdir ${KMODDIR} 2>/dev/null || true" >> ${TMPPLIST}
.endif