aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-04-23 06:13:14 +0800
committerbapt <bapt@FreeBSD.org>2013-04-23 06:13:14 +0800
commitb7a471d70159ad7829669a1e86b707e4d588a11e (patch)
tree8623071cb31f1d8e8aaacfccc958bfc09e200cbe /Mk
parent4d87b0cb64473d5816550176c261ebd04edcad47 (diff)
downloadfreebsd-ports-graphics-b7a471d70159ad7829669a1e86b707e4d588a11e.tar.gz
freebsd-ports-graphics-b7a471d70159ad7829669a1e86b707e4d588a11e.tar.zst
freebsd-ports-graphics-b7a471d70159ad7829669a1e86b707e4d588a11e.zip
Remove old links while creating the new packages
Force creation of the symlink for pkgng to avoid failure if the link already exists Submitted by: ohauer@
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.pkgng.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/bsd.pkgng.mk b/Mk/bsd.pkgng.mk
index 1cd9a8f15c0..b5c0a27422d 100644
--- a/Mk/bsd.pkgng.mk
+++ b/Mk/bsd.pkgng.mk
@@ -258,6 +258,9 @@ do-package: ${TMPPLIST}
fi; \
fi; \
fi;
+ @for cat in ${CATEGORIES}; do \
+ ${RM} -fv ${PACKAGES}/$$cat/${PKGNAMEPREFIX}${PORTNAME}*${PKG_SUFX} ; \
+ done
@if ${PKG_CREATE} -o ${PKGREPOSITORY} ${PKGNAME}; then \
if [ "${PKGORIGIN}" = "ports-mgmt/pkg" ]; then \
if [ ! -d ${PKGLATESTREPOSITORY} ]; then \
@@ -266,7 +269,7 @@ do-package: ${TMPPLIST}
exit 1; \
fi; \
fi ; \
- ${LN} -s ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
+ ${LN} -sf ../${PKGREPOSITORYSUBDIR}/${PKGNAME}${PKG_SUFX} ${PKGLATESTFILE} ; \
fi; \
else \
cd ${.CURDIR} && eval ${MAKE} delete-package; \