aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1994-09-02 09:53:33 +0800
committerjkh <jkh@FreeBSD.org>1994-09-02 09:53:33 +0800
commitd05564a1b3780e679cd29952a9d1a0d5b20f95c2 (patch)
tree98950089b5920911aabba8da12c2b2a7b7b1768d /Mk
parente6238221f627ff11195290404b60b6a16188b299 (diff)
downloadfreebsd-ports-graphics-d05564a1b3780e679cd29952a9d1a0d5b20f95c2.tar.gz
freebsd-ports-graphics-d05564a1b3780e679cd29952a9d1a0d5b20f95c2.tar.zst
freebsd-ports-graphics-d05564a1b3780e679cd29952a9d1a0d5b20f95c2.zip
Fixed a couple of typos. Ok, this works now. Only one significant hurdle
remains, and that's that this does not work with multiple targets, which sort of throws the tk and fvwm distributions into a mess. tk needs both a tarball and a patch file from the same site, fvwm needs up to 3 different files if you want all the options. If anyone wants to take this the last few steps of the way towards somehow handling cases like this, I'd be very happy. Submitted by: jkh
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index ac8ec59d56a..01861916153 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1,7 +1,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.25 1994/09/02 01:13:47 jkh Exp $
+# $Id: bsd.port.mk,v 1.26 1994/09/02 01:32:13 jkh Exp $
#
# Supported Variables and their behaviors:
@@ -284,13 +284,13 @@ ${EXTRACT_COOKIE}:
echo ">> Sorry, I can't seem to find: ${DISTFILE}"; \
echo ">> on this system."; \
if [ -f ${NCFTP} ]; then \
- echo ">> Attempting to fetch ${HOME_LOCATION}.";\
- if [ ! -d `dirname ${DISTFILE}`; then \
+ echo ">> Attempting to fetch ${HOME_LOCATION}."; \
+ if [ ! -d `dirname ${DISTFILE}` ]; then \
mkdir -p `dirname ${DISTFILE}`; \
- fi \
+ fi; \
if cd `dirname ${DISTFILE}`; then \
if ${NCFTP} ${HOME_LOCATION}; then \
- ${EXTRACT_CMD} ${EXTRACT_ARGS}; \
+ ${EXTRACT_CMD} ${EXTRACT_ARGS} ${DISTFILE}; \
else \
echo ">> Couldn't fetch it - please retreive ${DISTFILE} manually and try again."; \
exit 1; \