aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2016-04-26 07:12:04 +0800
committerswills <swills@FreeBSD.org>2016-04-26 07:12:04 +0800
commitd87b0ec219a48036ba03e8643abb8f2644ce2804 (patch)
tree449a97f69dd536961bcbec42c49d27f7cffb8cc7 /Mk
parent17d1671da2fcdc8acafbce498fe55e53f517e2b4 (diff)
downloadfreebsd-ports-graphics-d87b0ec219a48036ba03e8643abb8f2644ce2804.tar.gz
freebsd-ports-graphics-d87b0ec219a48036ba03e8643abb8f2644ce2804.tar.zst
freebsd-ports-graphics-d87b0ec219a48036ba03e8643abb8f2644ce2804.zip
remove RUBY_SHEBANG_FILES since USES=shebangfix does the same
PR: 209051
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.ruby.mk32
1 files changed, 0 insertions, 32 deletions
diff --git a/Mk/bsd.ruby.mk b/Mk/bsd.ruby.mk
index a3c653bb857..e3b868ff9ac 100644
--- a/Mk/bsd.ruby.mk
+++ b/Mk/bsd.ruby.mk
@@ -52,7 +52,6 @@ Ruby_Include_MAINTAINER= ruby@FreeBSD.org
# expression will be set to RUBY_PROVIDED, which is
# left undefined if the result is nil, false or a
# zero-length string. Implies USE_RUBY.
-# RUBY_SHEBANG_FILES - Specify the files which shebang lines you want to fix.
# RUBY_RD_FILES - Specify the RD files which you want to generate HTML
# documents from. If this is defined and not empty,
# USE_RUBY_RDTOOL is implied and RUBY_RD_HTML_FILES is
@@ -388,37 +387,6 @@ RUBY_PROVIDED= "should be" # the latest version is going to be installed
.endif
.endif
-# fix shebang lines
-.if defined(RUBY_SHEBANG_FILES) && !empty(RUBY_SHEBANG_FILES)
-USE_RUBY= yes
-
-post-patch: ruby-shebang-patch
-
-ruby-shebang-patch:
- @cd ${WRKSRC}; for f in ${RUBY_SHEBANG_FILES}; do \
- ${ECHO_MSG} "===> Fixing the #! line of $$f"; \
- TMPFILE=`mktemp -t rubyshebang`; \
- cp $$f $$TMPFILE; \
- ${AWK} 'BEGIN {flag = 0;} \
- { \
- if (flag == 0) { \
- if ($$0 ~ /^#!/) { \
- sub(/#!(.*\/)?(env[[:space:]]+)?ruby/, "#!${RUBY}", $$0);\
- print $$0; \
- } \
- else { \
- print "#!${RUBY}"; \
- print $$0; \
- } \
- flag = 1; \
- } else { \
- print $$0; \
- } \
- }' $$TMPFILE > $$f; \
- rm -f $$TMPFILE; \
- done
-.endif
-
.if ${PORT_OPTIONS:MDEBUG}
RUBY_FLAGS+= -d
.endif