aboutsummaryrefslogtreecommitdiffstats
path: root/Tools
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-05-10 17:14:40 +0800
committersobomax <sobomax@FreeBSD.org>2002-05-10 17:14:40 +0800
commit69f79d70b12a1aa4ad4ac4b0f84cfa3bfa8ae5c4 (patch)
tree847809c6560a6464d7c2f0af2842ddcdfd3f4c56 /Tools
parent0570d38a5686b6ff40280813b7ca76890f793184 (diff)
downloadfreebsd-ports-graphics-69f79d70b12a1aa4ad4ac4b0f84cfa3bfa8ae5c4.tar.gz
freebsd-ports-graphics-69f79d70b12a1aa4ad4ac4b0f84cfa3bfa8ae5c4.tar.zst
freebsd-ports-graphics-69f79d70b12a1aa4ad4ac4b0f84cfa3bfa8ae5c4.zip
- Make ${DISTDIR} auto-detection actually working;
- unbroke when either ${PORTSDIR} or ${DISTDIR} is symlink.
Diffstat (limited to 'Tools')
-rwxr-xr-xTools/scripts/distclean.sh7
1 files changed, 5 insertions, 2 deletions
diff --git a/Tools/scripts/distclean.sh b/Tools/scripts/distclean.sh
index 8c3f773fc54..c24873c255c 100755
--- a/Tools/scripts/distclean.sh
+++ b/Tools/scripts/distclean.sh
@@ -14,7 +14,7 @@
# Maxim Sobolev
# ----------------------------------------------------------------------------
#
-# $FreeBSD: /tmp/pcvs/ports/Tools/scripts/distclean.sh,v 1.12 2002-05-07 14:04:05 sobomax Exp $
+# $FreeBSD: /tmp/pcvs/ports/Tools/scripts/distclean.sh,v 1.13 2002-05-10 09:14:40 sobomax Exp $
#
# MAINTAINER= sobomax@FreeBSD.org
@@ -34,9 +34,12 @@ if [ ! -d ${PORTSDIR} ]; then
exit 1
fi
-DISTDIR=`(cd ${PORTSDIR} && make -V DISTDIR) 2>/dev/null`
+DISTDIR=`(make -V DISTDIR -f ${PORTSDIR}/Mk/bsd.port.mk) 2>/dev/null`
DISTDIR=${DISTDIR:-/usr/ports/distfiles}
+PORTSDIR="${PORTSDIR}/"
+DISTDIR="${DISTDIR}/"
+
echo "Assumes that your ports are in ${PORTSDIR} and distfiles in ${DISTDIR}."
echo ""