aboutsummaryrefslogtreecommitdiffstats
path: root/archivers/unzip/Makefile
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2006-08-12 21:11:23 +0800
committerache <ache@FreeBSD.org>2006-08-12 21:11:23 +0800
commite13b7fb8e857e13a42ff897ea464c2c53a1afbd6 (patch)
treead6d2a013a057526f8480bf4e1aa02db40502f55 /archivers/unzip/Makefile
parent3db9eef0e7e9925fa7ddbb59bcc7bc6c4954d4ae (diff)
downloadfreebsd-ports-graphics-e13b7fb8e857e13a42ff897ea464c2c53a1afbd6.tar.gz
freebsd-ports-graphics-e13b7fb8e857e13a42ff897ea464c2c53a1afbd6.tar.zst
freebsd-ports-graphics-e13b7fb8e857e13a42ff897ea464c2c53a1afbd6.zip
- Respect DESTDIR
- Eliminate plist PR: 101816 Submitted by: gabor
Diffstat (limited to 'archivers/unzip/Makefile')
-rw-r--r--archivers/unzip/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/archivers/unzip/Makefile b/archivers/unzip/Makefile
index 55e0737c370..4006d970e46 100644
--- a/archivers/unzip/Makefile
+++ b/archivers/unzip/Makefile
@@ -19,6 +19,8 @@ COMMENT?= List, test and extract compressed files in a ZIP archive
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
MAKEFILE= unix/Makefile
MAKE_ENV= LOCAL_UNZIP="${CFLAGS} -DUSE_UNSHRINK"
+PLIST_FILES= bin/unzip bin/funzip bin/unzipsfx bin/zipgrep bin/zipinfo
+PORTDOCS= README WHERE
MAN1= funzip.1 unzip.1 unzipsfx.1 zipgrep.1 zipinfo.1
.if defined(WITH_UNZIP_UNREDUCE)
@@ -50,17 +52,17 @@ pre-build:
do-install:
.for file in funzip unzip unzipsfx
- ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${file} ${TARGETDIR}/bin
.endfor
- ${LN} -sf unzip ${PREFIX}/bin/zipinfo
- ${INSTALL_SCRIPT} ${WRKSRC}/unix/zipgrep ${PREFIX}/bin
+ ${LN} -sf unzip ${TARGETDIR}/bin/zipinfo
+ ${INSTALL_SCRIPT} ${WRKSRC}/unix/zipgrep ${TARGETDIR}/bin
.for f in ${MAN1}
- ${INSTALL_MAN} ${WRKSRC}/man/${f} ${PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/${f} ${MAN1PREFIX}/man/man1
.endfor
.if !defined(NOPORTDOCS)
- @${MKDIR} ${PREFIX}/share/doc/unzip
-.for f in README WHERE
- ${INSTALL_DATA} ${WRKSRC}/${f} ${PREFIX}/share/doc/unzip
+ @${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif