aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
committermat <mat@FreeBSD.org>2015-11-05 20:36:25 +0800
commit344522393988339d341fda0818f0281645323f90 (patch)
tree9cbf2a263e7841be76898ae832e7bfb273d3fd08 /archivers
parenta8ea83538e74965157afe830f9873190be5ac78a (diff)
downloadfreebsd-ports-graphics-344522393988339d341fda0818f0281645323f90.tar.gz
freebsd-ports-graphics-344522393988339d341fda0818f0281645323f90.tar.zst
freebsd-ports-graphics-344522393988339d341fda0818f0281645323f90.zip
Fix ports that confused the meaning of WRKDIR and WRKSRC.
PR: 204056 Submitted by: mat Reviewed by: bapt Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D2735
Diffstat (limited to 'archivers')
-rw-r--r--archivers/paq/Makefile2
-rw-r--r--archivers/szip/Makefile4
-rw-r--r--archivers/undms/Makefile4
3 files changed, 5 insertions, 5 deletions
diff --git a/archivers/paq/Makefile b/archivers/paq/Makefile
index 63cbbf5006c..4bfe799bbf4 100644
--- a/archivers/paq/Makefile
+++ b/archivers/paq/Makefile
@@ -17,7 +17,7 @@ LICENSE_COMB= multi
USES= dos2unix zip:infozip
-EXTRACT_AFTER_ARGS= -x *.bat *.exe readme.txt -d ${WRKDIR}
+EXTRACT_AFTER_ARGS= -x *.bat *.exe readme.txt -d ${WRKSRC}
NO_WRKSUBDIR= yes
OPTIONS_DEFINE= OPENMP DOCS
SUB_FILES= pkg-message
diff --git a/archivers/szip/Makefile b/archivers/szip/Makefile
index 32adce3e71a..2d9502946f2 100644
--- a/archivers/szip/Makefile
+++ b/archivers/szip/Makefile
@@ -28,8 +28,8 @@ post-patch:
${WRKSRC}/makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${WRKDIR}/*.txt ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.txt ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/archivers/undms/Makefile b/archivers/undms/Makefile
index 2304423b2d2..df8fafcbe8e 100644
--- a/archivers/undms/Makefile
+++ b/archivers/undms/Makefile
@@ -16,8 +16,8 @@ NO_WRKSUBDIR= yes
PLIST_FILES= bin/undms
do-extract:
- ${MKDIR} ${WRKDIR}
- ${GZCAT} ${DISTDIR}/${DISTFILES} > ${WRKDIR}/${DISTNAME}
+ ${MKDIR} ${WRKSRC}
+ ${GZCAT} ${DISTDIR}/${DISTFILES} > ${WRKSRC}/${DISTNAME}
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} -o undms undms-1.3.c