aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2008-11-09 06:54:17 +0800
committerolgeni <olgeni@FreeBSD.org>2008-11-09 06:54:17 +0800
commit6460190be3e9f7962e36791cd163ee226ae56264 (patch)
tree625b35afd718c57cc3926538d2de70a9af3df17c /archivers
parentf1a63d67df905d529c43d4bd3de30a5aa72f8682 (diff)
downloadfreebsd-ports-graphics-6460190be3e9f7962e36791cd163ee226ae56264.tar.gz
freebsd-ports-graphics-6460190be3e9f7962e36791cd163ee226ae56264.tar.zst
freebsd-ports-graphics-6460190be3e9f7962e36791cd163ee226ae56264.zip
Use PYTHON_CMD with the -m flag to run compileall (avoid referencing PYTHON_SITELIBDIR).
Diffstat (limited to 'archivers')
-rw-r--r--archivers/rox-archive/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/archivers/rox-archive/Makefile b/archivers/rox-archive/Makefile
index f80e703620b..0455dec30f9 100644
--- a/archivers/rox-archive/Makefile
+++ b/archivers/rox-archive/Makefile
@@ -25,8 +25,8 @@ post-patch:
@${FIND} ${WRKSRC} -name CVS | ${XARGS} ${RM} -r
do-build:
- @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
- @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${WRKSRC}
+ @${PYTHON_CMD} -m compileall ${WRKSRC}
+ @${PYTHON_CMD} -O -m compileall ${WRKSRC}
do-install:
@${MKDIR} ${PREFIX}/apps