aboutsummaryrefslogtreecommitdiffstats
path: root/archivers
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2003-07-14 10:37:44 +0800
committersf <sf@FreeBSD.org>2003-07-14 10:37:44 +0800
commite4c18f2955f27cbf53bbe698b6182ffe3eb91f30 (patch)
treef9e659e32fcfa76d66c0b6fa01e9a87e7ca1c4a6 /archivers
parent95b6ba9e63e84046c152afeb7a530d2485f9dd3d (diff)
downloadfreebsd-ports-graphics-e4c18f2955f27cbf53bbe698b6182ffe3eb91f30.tar.gz
freebsd-ports-graphics-e4c18f2955f27cbf53bbe698b6182ffe3eb91f30.tar.zst
freebsd-ports-graphics-e4c18f2955f27cbf53bbe698b6182ffe3eb91f30.zip
get rid of libgnugetopt dependency for -CURRENT,
use USE_GETOPT_LONG instead. respect CC, CFLAGS.
Diffstat (limited to 'archivers')
-rw-r--r--archivers/lbrate/Makefile10
-rw-r--r--archivers/lbrate/files/patch-Makefile20
2 files changed, 18 insertions, 12 deletions
diff --git a/archivers/lbrate/Makefile b/archivers/lbrate/Makefile
index 68018665745..3d7ddcddf01 100644
--- a/archivers/lbrate/Makefile
+++ b/archivers/lbrate/Makefile
@@ -7,22 +7,20 @@
PORTNAME= lbrate
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= archivers
MASTER_SITES= ftp://ftp.ibiblio.org/pub/Linux/utils/compress/
MAINTAINER= gslin@ccca.nctu.edu.tw
COMMENT= Extract/decompress CP/M LBR archives
-LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
-
+USE_GETOPT_LONG=yes
USE_REINPLACE= yes
+MAKE_ENV= CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
MAN1= lbrate.1
-post-patch:
- @${REINPLACE_CMD} -e "s,^CC|^PREFIX,#,g" ${WRKSRC}/Makefile
- @${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" ${WRKSRC}/Makefile
-
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
diff --git a/archivers/lbrate/files/patch-Makefile b/archivers/lbrate/files/patch-Makefile
index 8ed29bafdf4..ce621f67846 100644
--- a/archivers/lbrate/files/patch-Makefile
+++ b/archivers/lbrate/files/patch-Makefile
@@ -1,20 +1,28 @@
---- Makefile.orig Wed Aug 29 19:07:24 2001
-+++ Makefile Wed Aug 29 19:08:13 2001
-@@ -1,7 +1,7 @@
+--- Makefile.orig Fri Aug 31 01:03:17 2001
++++ Makefile Sun Jul 6 05:09:19 2003
+@@ -1,13 +1,13 @@
# Makefile - makefile for lbrate
- CC=gcc
+-CC=gcc
-CFLAGS=-O2 -Wall
-+CFLAGS+=-I%%LOCALBASE%%/include
++CC?= gcc
++CFLAGS+=$(CPPFLAGS)
# Set BINDIR to directory for binary,
# MANDIR to directory for man page.
+ # Usually it will be simpler to just set PREFIX.
+ #
+-PREFIX=/usr/local
++PREFIX?=/usr/local
+ BINDIR=$(PREFIX)/bin
+ MANDIR=$(PREFIX)/man/man1
+
@@ -19,7 +19,7 @@
all: lbrate
lbrate: $(OBJ)
- $(CC) $(CFLAGS) -o lbrate $(OBJ)
-+ $(CC) $(CFLAGS) -o lbrate $(OBJ) -L%%LOCALBASE%%/lib -lgnugetopt
++ $(CC) $(CFLAGS) -o lbrate $(OBJ) $(LDFLAGS)
installdirs:
/bin/sh ./mkinstalldirs $(BINDIR) $(MANDIR)