aboutsummaryrefslogtreecommitdiffstats
path: root/astro/viking
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-01 14:57:16 +0800
committerbapt <bapt@FreeBSD.org>2012-06-01 14:57:16 +0800
commitb557076221bc64a31bd5b376790cb714f486c893 (patch)
treeba92db0751c943ce993ff1ab39dfac9c225c1981 /astro/viking
parent8033973ca84c7935f11bc3068cf3a5d5f6287da8 (diff)
downloadfreebsd-ports-graphics-b557076221bc64a31bd5b376790cb714f486c893.tar.gz
freebsd-ports-graphics-b557076221bc64a31bd5b376790cb714f486c893.tar.zst
freebsd-ports-graphics-b557076221bc64a31bd5b376790cb714f486c893.zip
Convert to new options framework
Diffstat (limited to 'astro/viking')
-rw-r--r--astro/viking/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
index 760393e61e2..146906c556c 100644
--- a/astro/viking/Makefile
+++ b/astro/viking/Makefile
@@ -20,8 +20,10 @@ LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
expat.6:${PORTSDIR}/textproc/expat2
RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
-OPTIONS= GEOTAG "Enable Geotag support" on \
- GPSD "Enable realtime GPS tracking" off
+OPTIONS_DEFINE= GEOTAR GPSD
+OPTIONS_DEFAULT= GEOTAG
+GEOTAG_DESC= Enable Geotag support
+GPSD_DESC= Enable realtime GPS tracking
USE_GNOME= gnomedocutils gtk20
USE_PERL5_RUN= yes
@@ -37,13 +39,13 @@ LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
.include <bsd.port.options.mk>
-.if defined(WITH_GEOTAG)
+.if ${PORT_OPTIONS:MGEOTAG}
LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
.else
CONFIGURE_ARGS+= --disable-geotag
.endif
-.if defined(WITH_GPSD)
+.if ${PORT_OPTIONS:MGPSD}
LIB_DEPENDS+= gps.20:${PORTSDIR}/astro/gpsd
.else
CONFIGURE_ARGS+= --disable-realtime-gps-tracking