aboutsummaryrefslogtreecommitdiffstats
path: root/astro/xplanet
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2002-05-20 06:31:31 +0800
committerwill <will@FreeBSD.org>2002-05-20 06:31:31 +0800
commit3ccdc9a04b53dfd428fa067ca51b4634a0303efe (patch)
treef305962efaf93767d3aec4d11148e1fb2c02633f /astro/xplanet
parente36577356fe8ebd21573a4715f6a713eb3880644 (diff)
downloadfreebsd-ports-graphics-3ccdc9a04b53dfd428fa067ca51b4634a0303efe.tar.gz
freebsd-ports-graphics-3ccdc9a04b53dfd428fa067ca51b4634a0303efe.tar.zst
freebsd-ports-graphics-3ccdc9a04b53dfd428fa067ca51b4634a0303efe.zip
Update to 0.94. Greatly simplify this port by removing the options to
use a specific version of Tk and other fluff. Install the markers that come with the xearth port. PR: 36185 (Update to 0.93) Submitted by: Lars Eggert <larse@isi.edu>
Diffstat (limited to 'astro/xplanet')
-rw-r--r--astro/xplanet/Makefile80
-rw-r--r--astro/xplanet/distinfo3
-rw-r--r--astro/xplanet/pkg-plist45
3 files changed, 61 insertions, 67 deletions
diff --git a/astro/xplanet/Makefile b/astro/xplanet/Makefile
index d4daf800e28..be7a2f547b0 100644
--- a/astro/xplanet/Makefile
+++ b/astro/xplanet/Makefile
@@ -6,83 +6,53 @@
#
PORTNAME= xplanet
-PORTVERSION= 0.84
-CATEGORIES= astro x11
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
- http://www.radcyberzine.com/xglobe/
+PORTVERSION= 0.94
+CATEGORIES= astro
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX} depths_800.jpg
-EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= will@FreeBSD.org
-LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg \
+ freetype.9:${PORTSDIR}/print/freetype2 \
+ ungif.5:${PORTSDIR}/graphics/libungif \
+ png.5:${PORTSDIR}/graphics/png \
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ pnm.1:${PORTSDIR}/graphics/netpbm
+
+RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
USE_X_PREFIX= yes
USE_MESA= yes
USE_GMAKE= yes
-USE_IMLIB= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-map-extension=jpg
+
+CONFIGURE_ARGS= --with-map-extension=jpg --with-freetype --with-gif \
+ --with-png --with-pnm --with-tiff
+
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
- LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
+ LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm" \
+ WISH=${LOCALBASE}/bin/wish8.3
+
MAKE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
LIBS="-L${LOCALBASE}/lib -L${X11BASE}/lib -lm"
MAN1= xplanet.1 xplanetbg.1 tkxplanet.1 tzcoord.pl.1
+MANCOMPRESSED= no
.include <bsd.port.pre.mk>
-.if (!defined(WITH_TK80) && !defined(WITH_TK81) && !defined(WITH_TK82) && !defined(WITH_TK83))
-.if exists(${LOCALBASE}/bin/wish8.3)
-WITH_TK83= yes
-.elif exists(${LOCALBASE}/bin/wish8.2)
-WITH_TK82= yes
-.elif exists(${LOCALBASE}/bin/wish8.1)
-WITH_TK81= yes
-.else
-WITH_TK80= yes
-.endif
-.endif
-
-.if defined(WITH_TK80)
-RUN_DEPENDS= wish8.0:${PORTSDIR}/x11-toolkits/tk80
-WISH= ${LOCALBASE}/bin/wish8.0
-TKVERMSG= "Using Tk 8.0"
-.endif
-
-.if defined(WITH_TK81)
-RUN_DEPENDS= wish8.1:${PORTSDIR}/x11-toolkits/tk81
-WISH= ${LOCALBASE}/bin/wish8.1
-TKVERMSG= "Using Tk 8.1"
-.endif
-
-.if defined(WITH_TK82)
-RUN_DEPENDS= wish8.2:${PORTSDIR}/x11-toolkits/tk82
-WISH= ${LOCALBASE}/bin/wish8.2
-TKVERMSG= "Using Tk 8.2"
-.endif
-
-.if defined(WITH_TK83)
-RUN_DEPENDS= wish8.3:${PORTSDIR}/x11-toolkits/tk83
-WISH= ${LOCALBASE}/bin/wish8.3
-TKVERMSG= "Using Tk 8.3"
-.endif
-
-CONFIGURE_ENV+= WISH=${WISH}
-
-pre-fetch:
- @${ECHO} ${TKVERMSG}
- @${ECHO} "Define WITH_TK80, WITH_TK81, WITH_TK82, or WITH_TK83"
- @${ECHO} "To use a different version of TK"
-
pre-configure:
- @${PERL} -pi -e 's|-O3|${CFLAGS}|' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-O3||' ${WRKSRC}/configure
pre-build:
@${PERL} -pi -e "s:/usr/local:${PREFIX}:g" ${WRKSRC}/auxfiles.h
+# Install the list of FreeBSD sites & committers locations from astro/xearth
post-install:
- @${INSTALL_DATA} ${DISTDIR}/depths_800.jpg ${PREFIX}/share/xplanet/earth.jpg
+.for file in freebsd.committers.markers freebsd.ftp.markers
+ @${INSTALL_DATA} ${PORTSDIR}/astro/xearth/files/${file} \
+ ${PREFIX}/share/xplanet/markers
+.endfor
.include <bsd.port.post.mk>
diff --git a/astro/xplanet/distinfo b/astro/xplanet/distinfo
index c4a903c9e86..f46b0a78c25 100644
--- a/astro/xplanet/distinfo
+++ b/astro/xplanet/distinfo
@@ -1,2 +1 @@
-MD5 (xplanet-0.84.tar.gz) = ccdd90be5622eca6813523a8f1e5c000
-MD5 (depths_800.jpg) = cf9e09624ecaafc3611578f2a7de37e1
+MD5 (xplanet-0.94.tar.gz) = 10faa5934cc24f3d913ea100b1df915d
diff --git a/astro/xplanet/pkg-plist b/astro/xplanet/pkg-plist
index 1ab732aed3e..b54269a51cc 100644
--- a/astro/xplanet/pkg-plist
+++ b/astro/xplanet/pkg-plist
@@ -1,19 +1,44 @@
-bin/tkxplanet
-bin/tzcoord.pl
bin/xplanet
bin/xplanetbg
-share/xplanet/earth.jpg
-share/xplanet/fonts/README
-share/xplanet/fonts/helr____.ttf
-share/xplanet/images/README
-share/xplanet/images/earth.jpg
-share/xplanet/images/night.jpg
-share/xplanet/images/smile.png
+bin/tkxplanet
+bin/tzcoord.pl
+share/xplanet/satellites/science
+share/xplanet/satellites/iss
+share/xplanet/satellites/science.tle
+share/xplanet/satellites/iss.tle
+share/xplanet/markers/locale/ru_RU/earth
+share/xplanet/markers/locale/el_GR/earth
+share/xplanet/markers/locale/ja_JP/earth
+share/xplanet/markers/locale/ko_KR/earth
+share/xplanet/markers/locale/zh_CN/earth
+share/xplanet/markers/locale/zh_TW/earth
share/xplanet/markers/earth
-share/xplanet/markers/mars
share/xplanet/markers/moon
+share/xplanet/markers/mars
+share/xplanet/markers/freebsd.committers.markers
+share/xplanet/markers/freebsd.ftp.markers
+share/xplanet/images/night.jpg
+share/xplanet/images/iss.png
+share/xplanet/images/smile.png
+share/xplanet/images/hubble.png
+share/xplanet/images/shuttle.png
+share/xplanet/images/sublunar.png
+share/xplanet/images/subsolar.png
+share/xplanet/images/earth.jpg
+share/xplanet/images/README
+share/xplanet/fonts/helr____.ttf
+share/xplanet/fonts/README
share/xplanet/rgb.txt
+@dirrm share/xplanet/satellites
+@dirrm share/xplanet/markers/locale/ru_RU
+@dirrm share/xplanet/markers/locale/el_GR
+@dirrm share/xplanet/markers/locale/ja_JP
+@dirrm share/xplanet/markers/locale/ko_KR
+@dirrm share/xplanet/markers/locale/zh_CN
+@dirrm share/xplanet/markers/locale/zh_TW
+@dirrm share/xplanet/markers/locale
@dirrm share/xplanet/markers
@dirrm share/xplanet/images
@dirrm share/xplanet/fonts
+@dirrm share/xplanet/arcs
@dirrm share/xplanet