aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorsat <sat@FreeBSD.org>2006-08-26 23:08:14 +0800
committersat <sat@FreeBSD.org>2006-08-26 23:08:14 +0800
commit62c5e43d7d237add5c92a614a1d42a569f936ad0 (patch)
tree271da6e6e2a848be55e8c67f444de0917b6f9a02 /astro
parent867ec430b5899e629ccd841f7667d5e03c54529a (diff)
downloadfreebsd-ports-graphics-62c5e43d7d237add5c92a614a1d42a569f936ad0.tar.gz
freebsd-ports-graphics-62c5e43d7d237add5c92a614a1d42a569f936ad0.tar.zst
freebsd-ports-graphics-62c5e43d7d237add5c92a614a1d42a569f936ad0.zip
Add port astro/xeartk:
xeartk is a tkgeomap application that uses the geomap::wdgeomap command to create an interactive map. The geographic data is from the xearth root window program. by Kirk Lauritz Johnson in an interactive widget. xeartk is not part of and does not require xearth. It only uses the outline data defined in file mapdata.c of the xearth source distribution. The cities are from factmonster. Adjust the map view by Shift-Double-Clicking or Shift-Dragging. Double click a dot to display information about the city there on the terminal. WWW: http://www.tkgeomap.org/xeartk.html Author: Gordon Carrie <tkgeomap@users.sourceforge.net>
Diffstat (limited to 'astro')
-rw-r--r--astro/Makefile1
-rw-r--r--astro/xeartk/Makefile34
-rw-r--r--astro/xeartk/distinfo3
-rw-r--r--astro/xeartk/pkg-descr12
4 files changed, 50 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 6124f04beb4..22cb4fe788e 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -73,6 +73,7 @@
SUBDIR += wmspaceweather
SUBDIR += wmsun
SUBDIR += xearth
+ SUBDIR += xeartk
SUBDIR += xephem
SUBDIR += xglobe
SUBDIR += xmoontool
diff --git a/astro/xeartk/Makefile b/astro/xeartk/Makefile
new file mode 100644
index 00000000000..d87c190600b
--- /dev/null
+++ b/astro/xeartk/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xeartk
+# Date created: 26 August 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xeartk
+PORTVERSION= 2.2
+CATEGORIES= astro tk84
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= tkgeomap
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Small demo for tkgeomap
+
+LIB_DEPENDS= tkgeomap2.9.0:${PORTSDIR}/astro/tkgeomap
+
+USE_XLIB= yes
+USE_TK= yes
+NO_BUILD= yes
+DATA_FILES= README cities land.xdr rivers.xdr water.xdr
+PLIST_FILES= bin/${PORTNAME} ${DATA_FILES:S,^,%%DATADIR%%/,}
+PLIST_DIRS= %%DATADIR%%
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,data/,${DATADIR}/,g;s,wish,${WISH},' ${WRKSRC}/src/XEartk.tcl
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/src/XEartk.tcl ${PREFIX}/bin/${PORTNAME}
+ @${INSTALL} -d ${DATADIR}
+ @${INSTALL_DATA} ${DATA_FILES:S,^,${WRKSRC}/data/,} ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/astro/xeartk/distinfo b/astro/xeartk/distinfo
new file mode 100644
index 00000000000..30140ec8957
--- /dev/null
+++ b/astro/xeartk/distinfo
@@ -0,0 +1,3 @@
+MD5 (xeartk-2.2.tar.gz) = 45604cfe33d018f1f879208e74946d32
+SHA256 (xeartk-2.2.tar.gz) = 06b49e204cfe39b3ce05271147d2368ac3ea0b258197aa67f889eeea8c335125
+SIZE (xeartk-2.2.tar.gz) = 150214
diff --git a/astro/xeartk/pkg-descr b/astro/xeartk/pkg-descr
new file mode 100644
index 00000000000..b007e92d319
--- /dev/null
+++ b/astro/xeartk/pkg-descr
@@ -0,0 +1,12 @@
+xeartk is a tkgeomap application that uses the geomap::wdgeomap command
+to create an interactive map. The geographic data is from the xearth
+root window program. by Kirk Lauritz Johnson in an interactive widget.
+xeartk is not part of and does not require xearth. It only uses the
+outline data defined in file mapdata.c of the xearth source
+distribution. The cities are from factmonster.
+
+Adjust the map view by Shift-Double-Clicking or Shift-Dragging. Double
+click a dot to display information about the city there on the terminal.
+
+WWW: http://www.tkgeomap.org/xeartk.html
+Author: Gordon Carrie <tkgeomap@users.sourceforge.net>