aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-09-23 17:09:09 +0800
committergahr <gahr@FreeBSD.org>2013-09-23 17:09:09 +0800
commitafd332686b3befa1b316b2cb0e36357187052ad7 (patch)
treea5fe5a9985ce0207cdaf3a804e92c638d426aa03 /astro
parent62050e38f14b12b9fd06698753c4e0b4ced67a6d (diff)
downloadfreebsd-ports-graphics-afd332686b3befa1b316b2cb0e36357187052ad7.tar.gz
freebsd-ports-graphics-afd332686b3befa1b316b2cb0e36357187052ad7.tar.zst
freebsd-ports-graphics-afd332686b3befa1b316b2cb0e36357187052ad7.zip
- Convert to USES+=tcl
- Convert to new LIB_DEPENDS format - Fix a format bug in the cities file
Diffstat (limited to 'astro')
-rw-r--r--astro/xeartk/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/astro/xeartk/Makefile b/astro/xeartk/Makefile
index 106ea7fece8..97d3b0acf34 100644
--- a/astro/xeartk/Makefile
+++ b/astro/xeartk/Makefile
@@ -10,10 +10,10 @@ MASTER_SITES= SF/tkgeomap/${PORTNAME}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Small demo for tkgeomap
-LIB_DEPENDS= tkgeomap.0:${PORTSDIR}/astro/tkgeomap
+LIB_DEPENDS= libtkgeomap.so:${PORTSDIR}/astro/tkgeomap
NO_STAGE= yes
-USE_TK_RUN= yes
+USES+= tk:run
NO_BUILD= yes
DATA_FILES= README cities land.xdr rivers.xdr water.xdr
PLIST_FILES= bin/${PORTNAME} ${DATA_FILES:S,^,%%DATADIR%%/,}
@@ -21,6 +21,7 @@ PLIST_DIRS= %%DATADIR%%
post-patch:
@${REINPLACE_CMD} -e 's,data/,${DATADIR}/,g;s,wish,${WISH},' ${WRKSRC}/src/XEartk.tcl
+ @${REINPLACE_CMD} -e 's| 0\([0-9]\)| \1|g' ${WRKSRC}/data/cities
do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/src/XEartk.tcl ${PREFIX}/bin/${PORTNAME}