aboutsummaryrefslogtreecommitdiffstats
path: root/astro
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2012-09-29 13:07:44 +0800
committerdanfe <danfe@FreeBSD.org>2012-09-29 13:07:44 +0800
commitb3cf57391b0f91e87ab2da3a9b4311a4350261db (patch)
tree34fcd9d46d1700ae1fe1a28a424eae5fe599fb04 /astro
parent60349cf9435f535eeb5f1808840f01920efd978f (diff)
downloadfreebsd-ports-graphics-b3cf57391b0f91e87ab2da3a9b4311a4350261db.tar.gz
freebsd-ports-graphics-b3cf57391b0f91e87ab2da3a9b4311a4350261db.tar.zst
freebsd-ports-graphics-b3cf57391b0f91e87ab2da3a9b4311a4350261db.zip
- Use `pre-su-install' target to unbreak non-root installation
- Switch from checking NOPORTDOCS to PORT_OPTIONS:MDOCS - Cleanup Makefile header, fix COMMENT text, wrap overly long lines - Synchronize descriptions and add a note about one port being a helper library for another
Diffstat (limited to 'astro')
-rw-r--r--astro/libroadnav/Makefile15
-rw-r--r--astro/libroadnav/pkg-descr2
-rw-r--r--astro/roadnav/Makefile16
-rw-r--r--astro/roadnav/pkg-descr18
4 files changed, 29 insertions, 22 deletions
diff --git a/astro/libroadnav/Makefile b/astro/libroadnav/Makefile
index 6fe2d386db2..9fce7c613d9 100644
--- a/astro/libroadnav/Makefile
+++ b/astro/libroadnav/Makefile
@@ -1,4 +1,4 @@
-# Created by: stevef
+# Created by: Steve Franks <stevefranks@ieee.org>
# $FreeBSD$
PORTNAME= libroadnav
@@ -8,7 +8,7 @@ CATEGORIES= astro geography
MASTER_SITES= SF/roadnav/LibRoadnav/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= Helper library for Roadnav: A 3D GPS Mapping program
+COMMENT= Helper library for Roadnav (3D GPS mapping program)
USE_WX= 2.6+
WX_COMPS= wx contrib
@@ -21,10 +21,13 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
-.if defined(NOPORTDOCS)
+.include <bsd.port.pre.mk>
+
post-patch:
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-libroadnavdocDATA||' \
- ${WRKSRC}/Makefile.in
+.if ! ${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} -e \
+ '/^install-data-am:/s|install-libroadnavdocDATA||' \
+ ${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/astro/libroadnav/pkg-descr b/astro/libroadnav/pkg-descr
index 3574e171b0b..9483da2e327 100644
--- a/astro/libroadnav/pkg-descr
+++ b/astro/libroadnav/pkg-descr
@@ -10,4 +10,6 @@ with the GNIS state and topical gazetteer data from the USGS to identify
locations. It has experimental support for scripting, LCDproc, importing
OpenStreetMap data, and importing GPX waypoints and tracks.
+This port provides helper library for Roadnav.
+
WWW: http://roadnav.sourceforge.net/
diff --git a/astro/roadnav/Makefile b/astro/roadnav/Makefile
index 27d73d3ebe4..f518edf9e60 100644
--- a/astro/roadnav/Makefile
+++ b/astro/roadnav/Makefile
@@ -1,4 +1,4 @@
-# Created by: stevef
+# Created by: Steve Franks <stevefranks@ieee.org>
# $FreeBSD$
PORTNAME= roadnav
@@ -8,7 +8,7 @@ CATEGORIES= astro geography
MASTER_SITES= SF/${PORTNAME}/Roadnav/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A 3D GPS Mapping program
+COMMENT= 3D GPS mapping program
BUILD_DEPENDS= ${LOCALBASE}/lib/libroadnav.a:${PORTSDIR}/astro/libroadnav
@@ -23,15 +23,17 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTDOCS= *
-pre-install:
- ${MKDIR} ${PREFIX}/share/applications
+.include <bsd.port.pre.mk>
+
+pre-su-install:
+ @${MKDIR} ${PREFIX}/share/applications
post-patch:
@${REINPLACE_CMD} -e 's|/usr/share|${PREFIX}/share|g' \
${WRKSRC}/Makefile.in ${WRKSRC}/src/Makefile.in
-.if defined(NOPORTDOCS)
- @${REINPLACE_CMD} -e '/^install-data-am:/ s|install-roadnavdocDATA||' \
+.if ! ${PORT_OPTIONS:MDOCS}
+ @${REINPLACE_CMD} -e '/^install-data-am:/s|install-roadnavdocDATA||' \
${WRKSRC}/Makefile.in
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/astro/roadnav/pkg-descr b/astro/roadnav/pkg-descr
index 71155ea3a40..3574e171b0b 100644
--- a/astro/roadnav/pkg-descr
+++ b/astro/roadnav/pkg-descr
@@ -1,13 +1,13 @@
-Roadnav is an open source street navigation solution capable of running on a
-variety of operating systems. It can obtain your position from a GPS unit,
-plot a map of your area, and provide directions to locations in the USA. It
-can also verbalize directions using Microsoft SAPI 5.1, Festival, flite, and
+Roadnav is an open source street navigation solution capable of running on a
+variety of operating systems. It can obtain your position from a GPS unit,
+plot a map of your area, and provide directions to locations in the USA. It
+can also verbalize directions using Microsoft SAPI 5.1, Festival, flite, and
OS X's built in text to speech engine.
-Roadnav uses the free TIGER/Line (Topologically Integrated Geographic
-Encoding and Referencing) files from the US Census Bureau to build the maps,
-along with the GNIS state and topical gazetteer data from the USGS to identify
-locations. It has experimental support for scripting, LCDproc, importing
-OpenStreetMap data, and importing GPX waypoints and tracks.
+Roadnav uses free TIGER/Line (Topologically Integrated Geographic Encoding
+and Referencing) files from the US Census Bureau to build the maps, along
+with the GNIS state and topical gazetteer data from the USGS to identify
+locations. It has experimental support for scripting, LCDproc, importing
+OpenStreetMap data, and importing GPX waypoints and tracks.
WWW: http://roadnav.sourceforge.net/