aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ascd/Makefile
diff options
context:
space:
mode:
authorjim <jim@FreeBSD.org>2000-08-07 04:27:11 +0800
committerjim <jim@FreeBSD.org>2000-08-07 04:27:11 +0800
commit6900e199863ed6ce5894360ab0faab396a890490 (patch)
treef55498c45c90e3bc59081c28acf3a57f65395e63 /audio/ascd/Makefile
parentd8deab2e83f116c7bcfc89c19d7813e6fde0da70 (diff)
downloadfreebsd-ports-graphics-6900e199863ed6ce5894360ab0faab396a890490.tar.gz
freebsd-ports-graphics-6900e199863ed6ce5894360ab0faab396a890490.tar.zst
freebsd-ports-graphics-6900e199863ed6ce5894360ab0faab396a890490.zip
Support CFLAGS/PREFIX properly.
PR: 20413 Submitted by: KATO Tsuguru <tkato@prontomail.ne.jp>
Diffstat (limited to 'audio/ascd/Makefile')
-rw-r--r--audio/ascd/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/audio/ascd/Makefile b/audio/ascd/Makefile
index ea169edc278..398df0f0c47 100644
--- a/audio/ascd/Makefile
+++ b/audio/ascd/Makefile
@@ -16,17 +16,21 @@ MAINTAINER= jim@FreeBSD.org
LIB_DEPENDS= workman.1:${PORTSDIR}/audio/libworkman
WRKSRC= ${WRKDIR}/${PKGNAME}
+
USE_IMAKE= yes
USE_XPM= yes
-HAS_CONFIGURE= yes
-CONFIGURE_SCRIPT= default
+
DATAFILES= ascd-0.13pr6-themes.tgz
THEMESDIR= ascd-0.13pr6-themes
MAN1= ascd.1
post-patch:
- @${LN} -fs ${WRKSRC}/misc/default ${WRKSRC}/default
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
+ ${WRKSRC}/misc/config.h.default > ${WRKSRC}/config.h
+ @${SED} -e "s:%%PREFIX%%:${PREFIX}:g" \
+ ${WRKSRC}/misc/dirs.h.default > ${WRKSRC}/dirs.h
+ @${CAT} ${WRKSRC}/version.h >> ${WRKSRC}/config.h
post-install:
@${CP} ${FILESDIR}/install ${WRKDIR}/${THEMESDIR}