aboutsummaryrefslogtreecommitdiffstats
path: root/audio/aureal-kmod
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2010-12-17 11:36:21 +0800
committerlinimon <linimon@FreeBSD.org>2010-12-17 11:36:21 +0800
commit4695677d4bb1a54c4d240e2a119bf53b57d2adec (patch)
treeff3d984033d0c3bacc5951b0616629564ff9ff98 /audio/aureal-kmod
parent2b33801f5b8e594bb3e4730d78351c2b4bf51b04 (diff)
downloadfreebsd-ports-graphics-4695677d4bb1a54c4d240e2a119bf53b57d2adec.tar.gz
freebsd-ports-graphics-4695677d4bb1a54c4d240e2a119bf53b57d2adec.tar.zst
freebsd-ports-graphics-4695677d4bb1a54c4d240e2a119bf53b57d2adec.zip
Change from $SRCPREFIX to $SRC_BASE to be in accordance with new
standard usage. Approved by: maintainer
Diffstat (limited to 'audio/aureal-kmod')
-rw-r--r--audio/aureal-kmod/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/audio/aureal-kmod/Makefile b/audio/aureal-kmod/Makefile
index e767fd2d24d..4b1ccda2501 100644
--- a/audio/aureal-kmod/Makefile
+++ b/audio/aureal-kmod/Makefile
@@ -18,7 +18,6 @@ COMMENT= A FreeBSD Driver for Aureal Vortex based soundcards
NO_PACKAGE= Should be in sync with the kernel to work correctly
ONLY_FOR_ARCHS= i386
-SRCPREFIX?= /usr/src
STRAYFILES= au88x0.h au88x0.c asp10.o asp20.o asp30.o
DISTREVISION= 4
@@ -43,22 +42,22 @@ BROKEN= doesn't build on RELENG_8
.endif
# Make sure kernel sources are present before going any further
-.if ! exists(${SRCPREFIX}/sys/dev/sound/pcm/sound.c)
+.if ! exists(${SRC_BASE}/sys/dev/sound/pcm/sound.c)
IGNORE= you need to extract kernel source tree before building this package
.endif
pre-everything::
.for STRAY in ${STRAYFILES}
-.if exists(${SRCPREFIX}/sys/dev/sound/pci/${STRAY})
+.if exists(${SRC_BASE}/sys/dev/sound/pci/${STRAY})
@${ECHO}
@${ECHO} "You have stray code in your tree. Make sure you"
@${ECHO} "do not have any of the following:"
@${ECHO}
- @${ECHO} "${SRCPREFIX}/sys/dev/sound/pci/au88x0.c"
- @${ECHO} "${SRCPREFIX}/sys/dev/sound/pci/au88x0.h"
- @${ECHO} "${SRCPREFIX}/sys/dev/sound/pci/asp10.o"
- @${ECHO} "${SRCPREFIX}/sys/dev/sound/pci/asp20.o"
- @${ECHO} "${SRCPREFIX}/sys/dev/sound/pci/asp30.o"
+ @${ECHO} "${SRC_BASE}/sys/dev/sound/pci/au88x0.c"
+ @${ECHO} "${SRC_BASE}/sys/dev/sound/pci/au88x0.h"
+ @${ECHO} "${SRC_BASE}/sys/dev/sound/pci/asp10.o"
+ @${ECHO} "${SRC_BASE}/sys/dev/sound/pci/asp20.o"
+ @${ECHO} "${SRC_BASE}/sys/dev/sound/pci/asp30.o"
@${ECHO}
@${FALSE}
.endif