aboutsummaryrefslogtreecommitdiffstats
path: root/audio/ccaudio/Makefile
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2005-10-14 20:05:42 +0800
committervs <vs@FreeBSD.org>2005-10-14 20:05:42 +0800
commitb7469294e16e9729a3f91c9d60eeb97bffff7345 (patch)
tree4d50a6563c93fb5f3de1493d2751961f36dd4559 /audio/ccaudio/Makefile
parent219cee8312ad79934aaf8a05f2139964a1ac2d89 (diff)
downloadfreebsd-ports-graphics-b7469294e16e9729a3f91c9d60eeb97bffff7345.tar.gz
freebsd-ports-graphics-b7469294e16e9729a3f91c9d60eeb97bffff7345.tar.zst
freebsd-ports-graphics-b7469294e16e9729a3f91c9d60eeb97bffff7345.zip
Fix breakage of ccscript on 4.x by lifting requisite commoncpp to gcc 3.4
(and track this for ccaudio which also uses commoncpp)
Diffstat (limited to 'audio/ccaudio/Makefile')
-rw-r--r--audio/ccaudio/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/audio/ccaudio/Makefile b/audio/ccaudio/Makefile
index 91c3b8ebd6d..993d47f2fe9 100644
--- a/audio/ccaudio/Makefile
+++ b/audio/ccaudio/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= ccgnu2-1.3.1:${PORTSDIR}/devel/commoncpp
USE_GNOME= gnometarget
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4
INSTALL_TARGET= install man
INSTALLS_SHLIB= yes
@@ -31,4 +32,7 @@ post-patch:
@${REINPLACE_CMD} -e \
's|<stdint\.h>|<stdlib.h>|g' ${WRKSRC}/src/dtmf.cpp
+pre-configure:
+ @${CP} ${LTMAIN} ${WRKSRC}/config
+
.include <bsd.port.mk>