aboutsummaryrefslogtreecommitdiffstats
path: root/audio/cueplayer
diff options
context:
space:
mode:
authorsylvio <sylvio@FreeBSD.org>2010-02-04 05:38:42 +0800
committersylvio <sylvio@FreeBSD.org>2010-02-04 05:38:42 +0800
commitdd05473c62c609587b3eb19753af361119cc767d (patch)
treedf9e9a16177936a3fea9efac93ff2533a99728f1 /audio/cueplayer
parentc66cbe5e9dbca84a9d76de96adc2c28e1a5ebf62 (diff)
downloadfreebsd-ports-graphics-dd05473c62c609587b3eb19753af361119cc767d.tar.gz
freebsd-ports-graphics-dd05473c62c609587b3eb19753af361119cc767d.tar.zst
freebsd-ports-graphics-dd05473c62c609587b3eb19753af361119cc767d.zip
- Lightweight media player based on Qt and Gstreamer
WWW: http://code.google.com/p/cueplayer PR: ports/142909 Submitted by: zloidemon <g.veniamin@googlemail.com> Approved by: miwi (mentor)
Diffstat (limited to 'audio/cueplayer')
-rw-r--r--audio/cueplayer/Makefile37
-rw-r--r--audio/cueplayer/distinfo3
-rw-r--r--audio/cueplayer/pkg-descr3
-rw-r--r--audio/cueplayer/pkg-plist20
4 files changed, 63 insertions, 0 deletions
diff --git a/audio/cueplayer/Makefile b/audio/cueplayer/Makefile
new file mode 100644
index 00000000000..0b71b2ea192
--- /dev/null
+++ b/audio/cueplayer/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: cueplayer
+# Date created: 2010-01-17
+# Whom: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cueplayer
+PORTVERSION= 0.21
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= CUE player
+
+USE_QT_VER= 4
+QT_COMPONENTS= gui xml qmake_build uic_build moc_build rcc_build network
+USE_GSTREAMER= yes
+
+DESKTOP_ENTRIES="Cueplayer" "Lightweight media player based on Qt and Gstreamer" \
+ "${DATADIR}/knotify.png" "${PORTNAME}" \
+ "AudioVideo;Audio;Video;" ${FALSE}
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,images/,share/${PORTNAME}/,g' \
+ ${WRKSRC}/*.cpp
+
+do-configure:
+ cd ${WRKSRC} && ${QMAKE}
+
+do-install:
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/images/*.png ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/audio/cueplayer/distinfo b/audio/cueplayer/distinfo
new file mode 100644
index 00000000000..eb455094bbd
--- /dev/null
+++ b/audio/cueplayer/distinfo
@@ -0,0 +1,3 @@
+MD5 (cueplayer-0.21.tar.gz) = fd6006d5083ff7e4523cbbd9727ee970
+SHA256 (cueplayer-0.21.tar.gz) = 75079618000c5072e36d70e82c896a7dbc750a5e7b3d9482f98c62f837db3a3d
+SIZE (cueplayer-0.21.tar.gz) = 68338
diff --git a/audio/cueplayer/pkg-descr b/audio/cueplayer/pkg-descr
new file mode 100644
index 00000000000..a70a64fcf86
--- /dev/null
+++ b/audio/cueplayer/pkg-descr
@@ -0,0 +1,3 @@
+Lightweight media player based on Qt and Gstreamer
+
+WWW: http://code.google.com/p/cueplayer/
diff --git a/audio/cueplayer/pkg-plist b/audio/cueplayer/pkg-plist
new file mode 100644
index 00000000000..130ac2bc09b
--- /dev/null
+++ b/audio/cueplayer/pkg-plist
@@ -0,0 +1,20 @@
+bin/cueplayer
+%%DATADIR%%/application-exit.png
+%%DATADIR%%/convertor.png
+%%DATADIR%%/fileopen.png
+%%DATADIR%%/format-indent-more.png
+%%DATADIR%%/format-list-unordered.png
+%%DATADIR%%/help-about.png
+%%DATADIR%%/hint.png
+%%DATADIR%%/knotify.png
+%%DATADIR%%/media-optical.png
+%%DATADIR%%/net-stream.png
+%%DATADIR%%/next.png
+%%DATADIR%%/pause.png
+%%DATADIR%%/play.png
+%%DATADIR%%/prev.png
+%%DATADIR%%/speaker.png
+%%DATADIR%%/stop.png
+%%DATADIR%%/text-field.png
+%%DATADIR%%/tool-animator.png
+@dirrm %%DATADIR%%