aboutsummaryrefslogtreecommitdiffstats
path: root/audio/extace/files
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-08-30 21:54:17 +0800
committersobomax <sobomax@FreeBSD.org>2002-08-30 21:54:17 +0800
commit8093e485c52ea8bcd3c12878b6815d438b5e4ab9 (patch)
tree6896a79751fd57ddfcd84ee5a1cfff395c667f50 /audio/extace/files
parent1bed84dc73dc3e84814ad7c81495a9e8afaf13df (diff)
downloadfreebsd-ports-graphics-8093e485c52ea8bcd3c12878b6815d438b5e4ab9.tar.gz
freebsd-ports-graphics-8093e485c52ea8bcd3c12878b6815d438b5e4ab9.tar.zst
freebsd-ports-graphics-8093e485c52ea8bcd3c12878b6815d438b5e4ab9.zip
Update to 1.7.3.
PR: 40183 41280 Submitted by: Tilman Linneweh <tilman@arved.de> Oliver Lehmann <lehmann@ans-netz.de>
Diffstat (limited to 'audio/extace/files')
-rw-r--r--audio/extace/files/patch-aa51
-rw-r--r--audio/extace/files/patch-ab45
-rw-r--r--audio/extace/files/patch-ad6
-rw-r--r--audio/extace/files/patch-src::color_win.c36
-rw-r--r--audio/extace/files/patch-src::getfft.c (renamed from audio/extace/files/patch-ac)7
5 files changed, 97 insertions, 48 deletions
diff --git a/audio/extace/files/patch-aa b/audio/extace/files/patch-aa
index 714b4b358be..b35fd39b80f 100644
--- a/audio/extace/files/patch-aa
+++ b/audio/extace/files/patch-aa
@@ -1,30 +1,38 @@
---- configure.orig Sat Jul 22 07:40:27 2000
-+++ configure Mon Jul 31 12:39:34 2000
-@@ -1210,9 +1210,9 @@
+--- configure.orig Sun May 26 19:57:47 2002
++++ configure Sat Aug 3 10:36:04 2002
+@@ -1595,13 +1595,13 @@
+ CFLAGS="$ac_save_CFLAGS"
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++# CFLAGS="-g -O2"
+ else
+ CFLAGS="-g"
fi
else
if test "$GCC" = yes; then
- CFLAGS="-O2"
+# CFLAGS="-O2"
else
-- CFLAGS=
-+# CFLAGS=
+ CFLAGS=
fi
- fi
-
-@@ -1748,9 +1748,9 @@
+@@ -5706,13 +5706,13 @@
+ CFLAGS="$ac_save_CFLAGS"
+ elif test $ac_cv_prog_cc_g = yes; then
+ if test "$GCC" = yes; then
+- CFLAGS="-g -O2"
++# CFLAGS="-g -O2"
+ else
+ CFLAGS="-g"
fi
else
if test "$GCC" = yes; then
- CFLAGS="-O2"
+# CFLAGS="-O2"
else
-- CFLAGS=
-+# CFLAGS=
+ CFLAGS=
fi
- fi
-
-@@ -2764,7 +2764,7 @@
+@@ -6717,7 +6717,7 @@
done
@@ -32,13 +40,22 @@
+#CFLAGS="-O2 "
- EXTRA_LIBS=""
-@@ -3301,7 +3301,7 @@
+ EFENCE=""
+@@ -7149,7 +7149,8 @@
echo $ac_n "(cached) $ac_c" 1>&6
else
ac_save_LIBS="$LIBS"
-LIBS="-lgdk_imlib `gtk-config --libs` $LIBS"
-+LIBS="-lgdk_imlib `$GTK_CONFIG --libs` $LIBS"
++IMLIB_LIBS=`imlib-config --libs`
++LIBS="-lgdk_imlib ${GTK_LIBS} ${IMLIB_LIBS} $LIBS"
cat > conftest.$ac_ext <<EOF
- #line 3307 "configure"
+ #line 7155 "configure"
#include "confdefs.h"
+@@ -7383,6 +7384,7 @@
+ s%@GTK_CONFIG@%$GTK_CONFIG%g
+ s%@GTK_CFLAGS@%$GTK_CFLAGS%g
+ s%@GTK_LIBS@%$GTK_LIBS%g
++s%@IMLIB_LIBS@%$IMLIB_LIBS%g
+ s%@GLIB_CONFIG@%$GLIB_CONFIG%g
+ s%@GLIB_CFLAGS@%$GLIB_CFLAGS%g
+ s%@GLIB_LIBS@%$GLIB_LIBS%g
diff --git a/audio/extace/files/patch-ab b/audio/extace/files/patch-ab
index dde6d284f2f..f51002a1f10 100644
--- a/audio/extace/files/patch-ab
+++ b/audio/extace/files/patch-ab
@@ -1,38 +1,31 @@
---- extace/Makefile.in.orig Tue Jan 2 11:26:24 2001
-+++ extace/Makefile.in Tue Jan 2 11:33:29 2001
-@@ -101,7 +101,7 @@
- extace_LDADD = @GTK_LIBS@ @ESD_LIBS@ @EXTRA_LIBS@ @ALSA_LIBS@ -lgdk_imlib
- #extace_LDADD = -lefence @GTK_LIBS@ @ESD_LIBS@ @EXTRA_LIBS@ @ALSA_LIBS@ -lgdk_imlib
+--- src/Makefile.in.orig Sun May 26 19:59:24 2002
++++ src/Makefile.in Sat Aug 3 10:36:57 2002
+@@ -146,9 +146,9 @@
+ options.c
--LIBS = -lpthread
-+LIBS = #-lpthread
-
- COMMON_FLAGS = @PFLAGS@ @DFLAGS@
-@@ -109,7 +109,9 @@
+-extace_LDADD = @EFENCE@ @GTK_LIBS@ @ESD_LIBS@ @EXTRA_LIBS@ @ALSA_LIBS@ -lgdk_imlib
++extace_LDADD = @EFENCE@ @GTK_LIBS@ @ESD_LIBS@ @EXTRA_LIBS@ @ALSA_LIBS@ @IMLIB_LIBS@ -lgdk_imlib
- EXTRA_DIST = extace.desktop README NEWS TODO
+-LIBS = -lpthread
++#LIBS = -lpthread
-+.ifdef HAVE_GNOME
- Multimedia_DATA = extace.desktop
-+.endif
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../config.h
- CONFIG_CLEAN_FILES =
-@@ -239,7 +241,6 @@
+ COMMON_FLAGS = @PFLAGS@ @DFLAGS@
+@@ -321,7 +323,6 @@
+ uninstall-info-am:
install-MultimediaDATA: $(Multimedia_DATA)
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(Multimediadir)
@list='$(Multimedia_DATA)'; for p in $$list; do \
- if test -f $(srcdir)/$$p; then \
- echo " $(INSTALL_DATA) $(srcdir)/$$p $(DESTDIR)$(Multimediadir)/$$p"; \
-@@ -325,7 +326,7 @@
- install-strip:
- $(MAKE) $(AM_MAKEFLAGS) AM_INSTALL_PROGRAM_FLAGS=-s install
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f="`echo $$p | sed -e 's|^.*/||'`"; \
+@@ -395,7 +396,7 @@
+ all-am: Makefile $(PROGRAMS) $(DATA)
+
installdirs:
-- $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(Multimediadir)
+- $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(Multimediadir)
+ $(mkinstalldirs) $(DESTDIR)$(bindir)
-
- mostlyclean-generic:
+ install: install-am
+ install-exec: install-exec-am
diff --git a/audio/extace/files/patch-ad b/audio/extace/files/patch-ad
index 598ac6f055b..9e9a468fabd 100644
--- a/audio/extace/files/patch-ad
+++ b/audio/extace/files/patch-ad
@@ -1,6 +1,6 @@
---- extace/sound.c 2001/01/02 09:31:56 1.1
-+++ extace/sound.c 2001/01/02 09:32:16
-@@ -24,7 +24,9 @@
+--- src/sound.c.orig Sat Aug 3 10:25:15 2002
++++ src/sound.c Sat Aug 3 10:25:49 2002
+@@ -23,7 +23,9 @@
#include <fcntl.h>
#include <gtk/gtk.h>
#include <esd.h>
diff --git a/audio/extace/files/patch-src::color_win.c b/audio/extace/files/patch-src::color_win.c
new file mode 100644
index 00000000000..728d2feedaf
--- /dev/null
+++ b/audio/extace/files/patch-src::color_win.c
@@ -0,0 +1,36 @@
+
+$FreeBSD$
+
+--- src/color_win.c 2002/08/30 13:00:11 1.1
++++ src/color_win.c 2002/08/30 13:00:52
+@@ -61,18 +61,18 @@
+ // printf("Color_button()\n");
+ switch ((gint)data)
+ {
+- case (gpointer)SET_COLOR:
++ case (gint)SET_COLOR:
+ update_gradient(NULL, color_loc);
+ init_colortab();
+ gradient_update();
+ break;
+
+- case (gpointer)CLOSE:
++ case (gint)CLOSE:
+ gtk_widget_hide(grad_win_ptr);
+ grad_win_present = 0;
+ break;
+
+- case (gpointer)SAVE:
++ case (gint)SAVE:
+ filew = gtk_file_selection_new("Save Colormap");
+ gtk_signal_connect (GTK_OBJECT(filew), "destroy",
+ (GtkSignalFunc) gtk_widget_destroy, GTK_OBJECT (filew));
+@@ -85,7 +85,7 @@
+ gtk_file_selection_set_filename(GTK_FILE_SELECTION(filew),g_strconcat(g_get_home_dir(),"/.eXtace/ColorMaps/", NULL));
+ gtk_widget_show(filew);
+ break;
+- case (gpointer)LOAD:
++ case (gint)LOAD:
+ filew = gtk_file_selection_new("Load Colormap");
+ gtk_signal_connect (GTK_OBJECT(filew), "destroy",
+ (GtkSignalFunc) gtk_widget_destroy, GTK_OBJECT (filew));
diff --git a/audio/extace/files/patch-ac b/audio/extace/files/patch-src::getfft.c
index 5679e4e1337..eb8734c6336 100644
--- a/audio/extace/files/patch-ac
+++ b/audio/extace/files/patch-src::getfft.c
@@ -1,5 +1,8 @@
---- extace/misc.c 2001/01/02 09:29:43 1.1
-+++ extace/misc.c 2001/01/02 09:30:30
+
+$FreeBSD$
+
+--- src/getfft.c 2002/08/30 12:59:05 1.1
++++ src/getfft.c 2002/08/30 12:59:26
@@ -20,7 +20,9 @@
#include <protos.h>
#include <math.h>