aboutsummaryrefslogtreecommitdiffstats
path: root/audio/festlex-czech
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2008-03-13 23:02:41 +0800
committerpav <pav@FreeBSD.org>2008-03-13 23:02:41 +0800
commit6f6155262f8c05c369f9028fe66530206b87a159 (patch)
treeee4c541c738c43363030e64fa517fdf512cebe0b /audio/festlex-czech
parentf95e4655d40bfb8d066432a90358a76b93b6b555 (diff)
downloadfreebsd-ports-graphics-6f6155262f8c05c369f9028fe66530206b87a159.tar.gz
freebsd-ports-graphics-6f6155262f8c05c369f9028fe66530206b87a159.tar.zst
freebsd-ports-graphics-6f6155262f8c05c369f9028fe66530206b87a159.zip
Czech support for festival speech system. It provides the lexicon and language
rules. Quality free Czech diphone database. Primary goal is for speech system Festival but it's not limited on it. Sources, sound files and boundaries are available so it can be used in other free speech synthetizer systems too. WWW: http://www.freebsoft.org/festival-czech PR: ports/119044 Submitted by: Frantisek Dvorak <valtri@civ.zcu.cz>
Diffstat (limited to 'audio/festlex-czech')
-rw-r--r--audio/festlex-czech/Makefile32
-rw-r--r--audio/festlex-czech/distinfo3
-rw-r--r--audio/festlex-czech/files/patch-Makefile14
-rw-r--r--audio/festlex-czech/files/patch-czech-lexicon.out100
-rw-r--r--audio/festlex-czech/files/patch-czech-lexicon.scm54
-rw-r--r--audio/festlex-czech/files/patch-czech.scm.in11
-rw-r--r--audio/festlex-czech/pkg-descr4
-rw-r--r--audio/festlex-czech/pkg-plist9
8 files changed, 227 insertions, 0 deletions
diff --git a/audio/festlex-czech/Makefile b/audio/festlex-czech/Makefile
new file mode 100644
index 00000000000..1e1a7e39654
--- /dev/null
+++ b/audio/festlex-czech/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: festlex-czech
+# Date created: 2008-04-29
+# Whom: František Dvořák <valtri@civ.zcu.cz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= festlex-czech
+PORTVERSION= 0.2.1
+CATEGORIES= audio accessibility
+MASTER_SITES= http://www.freebsoft.org/pub/projects/festival-czech/
+DISTNAME= festival-czech-${PORTVERSION}
+DIST_SUBDIR= festival
+
+MAINTAINER= valtri@civ.zcu.cz
+COMMENT= Czech language support for Festival
+
+FHOME= ${PREFIX}/share/festival
+NO_BUILD= yes
+rulez= czech-debug.scm czech-mbrola.scm czech-unisyn.scm czech.scm
+lexicons= czech-lexicon.scm czech-lexicon.out
+
+post-patch:
+ ${MV} ${WRKSRC}/czech.scm ${WRKSRC}/czech.scm.in
+ ${SED} -e "s,@FESTIVAL_TARGET_DIR@,${FHOME}/lib/dicts," ${WRKSRC}/czech.scm.in > ${WRKSRC}/czech.scm
+
+post-install:
+ ${MKDIR} ${FHOME}/lib/dicts/
+ ${INSTALL} -m 644 ${rulez:C/^/${WRKSRC}\//} ${FHOME}/lib/
+ ${INSTALL} -m 644 ${lexicons:C/^/${WRKSRC}\//} ${FHOME}/lib/dicts/
+
+.include <bsd.port.mk>
diff --git a/audio/festlex-czech/distinfo b/audio/festlex-czech/distinfo
new file mode 100644
index 00000000000..887d73fb47c
--- /dev/null
+++ b/audio/festlex-czech/distinfo
@@ -0,0 +1,3 @@
+MD5 (festival/festival-czech-0.2.1.tar.gz) = 8fed1217a179fd1cee0d1a20d33d9b74
+SHA256 (festival/festival-czech-0.2.1.tar.gz) = 3d2b542f14788888414856338a78a3fdbd5257e6a9b3d877a244a9f1b05c2c46
+SIZE (festival/festival-czech-0.2.1.tar.gz) = 48977
diff --git a/audio/festlex-czech/files/patch-Makefile b/audio/festlex-czech/files/patch-Makefile
new file mode 100644
index 00000000000..b1c264ddac3
--- /dev/null
+++ b/audio/festlex-czech/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig Wed Jun 21 09:32:07 2006
++++ Makefile Wed Dec 26 16:42:28 2007
+@@ -36,10 +36,9 @@
+ all: czech-lexicon.out
+
+ %.out: %.scm
+- festival --batch '(lex.compile "$<" "$@")'
++ echo '(lex.compile "$<" "$@")' | festival
+
+ install: all
+- $(INSTALL_PROGRAM) -m 644 $(distfiles) $(festival_path)/
+
+ install-strip:
+ $(MAKE) INSTALL_PROGRAM='$(INSTALL_PROGRAM) -s' install
diff --git a/audio/festlex-czech/files/patch-czech-lexicon.out b/audio/festlex-czech/files/patch-czech-lexicon.out
new file mode 100644
index 00000000000..da80f6a0479
--- /dev/null
+++ b/audio/festlex-czech/files/patch-czech-lexicon.out
@@ -0,0 +1,100 @@
+--- czech-lexicon.out.orig Wed Dec 26 17:22:12 2007
++++ czech-lexicon.out Wed Dec 26 17:28:09 2007
+@@ -45,7 +45,9 @@
+ ("a" nil (((a) 0)))
+ ("a" sym (((a:) 0)))
+ ("b" nil (((b e:) 0)))
++("Base" nil (((b e j z) 0)))
+ ("c" nil (((c e:) 0)))
++("Calc" nil (((k o: l k) 0)))
+ ("cca" nil (((c i r k a) 0)))
+ ("ch" nil (((ch a:) 0)))
+ ("Chocomy¹l" nil (((ch o c o m i s~ l) 0)))
+@@ -78,7 +80,16 @@
+ ("copyrightùm" nil (((k o p i r a j t u: m) 0)))
+ ("czech" nil (((c~ e k) 0)))
+ ("d" nil (((d e:) 0)))
++("Draw" nil (((d r o:) 0)))
+ ("e" nil (((e:) 0)))
++("Einstein" nil (((a j n s~ t a j n) 0)))
++("Einsteina" nil (((a j n s~ t a j n a) 0)))
++("Einsteinem" nil (((a j n s~ t a j n e m) 0)))
++("Einsteinova" nil (((a j n s~ t a j n o v a) 0)))
++("Einsteinovi" nil (((a j n s~ t a j n o v i) 0)))
++("Einsteinovou" nil (((a j n s~ t a j n o v o u) 0)))
++("Einsteinovy" nil (((a j n s~ t a j n o v i) 0)))
++("Einsteinovì" nil (((a j n s~ t a j n o v j e) 0)))
+ ("Emacs" nil (((i: m e k s) 0)))
+ ("Emacsech" nil (((i: m e k s e ch) 0)))
+ ("Emacsem" nil (((i: m e k s e m) 0)))
+@@ -101,6 +112,7 @@
+ ("Emacsùm" nil (((i: m e k s u: m) 0)))
+ ("escape" nil (((i s k e j p) 0)))
+ ("f" nil (((e f) 0)))
++("Firefox" nil (((f a j r f o k s) 0)))
+ ("foundation" nil (((f a u n d e j s~ n) 0)))
+ ("freeware" nil (((f r i: v e: r e) 0)))
+ ("freewarech" nil (((f r i: v e: r e ch) 0)))
+@@ -145,15 +157,45 @@
+ ("hardwary" nil (((h a r d v e: r i) 0)))
+ ("hardwarù" nil (((h a r d v e: r u:) 0)))
+ ("hardwarùm" nil (((h a r d v e: r u: m) 0)))
++("Impress" nil (((i m p r e s) 0)))
+ ("j" nil (((j e:) 0)))
+ ("k" nil (((k) 0)))
+ ("k" sym (((k a:) 0)))
+ ("Kè" nil (((k o r u n) 0)))
+ ("l" nil (((e l) 0)))
+ ("m" nil (((e m) 0)))
++("Marsem" nil (((m a r z e m) 0)))
++("Marsovy" nil (((m a r z o v i) 0)))
++("Marsových" nil (((m a r z o v i: ch) 0)))
++("Marsovým" nil (((m a r z o v i: m) 0)))
++("Marsovými" nil (((m a r z o v i: m i) 0)))
++("Marsu" nil (((m a r z u) 0)))
++("Maryland" nil (((m e r y l e n d) 0)))
++("Math" nil (((m a: f) 0)))
++("Michigan" nil (((m i s~ i g e n) 0)))
++("monitorovat" nil (((m o n i t o r o v a t) 0)))
++("monitoruje" nil (((m o n i t o r u j e) 0)))
++("monitorujeme" nil (((m o n i t o r u j e m e) 0)))
++("monitorujete" nil (((m o n i t o r u j e t e) 0)))
++("monitoruje¹" nil (((m o n i t o r u j e s~) 0)))
++("monitoruji" nil (((m o n i t o r u j i) 0)))
++("monitorují" nil (((m o n i t o r u j i:) 0)))
++("Mozilla" nil (((m o z i l a) 0)))
+ ("n" nil (((e n) 0)))
++("Newton" nil (((n~ u: t n) 0)))
++("Newtona" nil (((n~ u: t n a) 0)))
++("Newtonem" nil (((n~ u: t n e m) 0)))
++("Newtonova" nil (((n~ u: t n o v a) 0)))
++("Newtonovi" nil (((n~ u: t n o v a) 0)))
++("Newtonovou" nil (((n~ u: t n o v o u) 0)))
++("Newtonovy" nil (((n~ u: t n o v y) 0)))
++("Newtonovì" nil (((n~ u: t n o v j e) 0)))
+ ("o" nil (((o) 0)))
+ ("o" sym (((o:) 0)))
++("office" nil (((o f i s) 0)))
++("OpenOffice" nil (((o p e n o f i s) 0)))
++("Orca" nil (((o r k a) 0)))
++("Orcy" nil (((o r k y) 0)))
+ ("p" nil (((p e:) 0)))
+ ("pst" nil (((p s t) 0)))
+ ("q" nil (((k v e:) 0)))
+@@ -205,10 +247,16 @@
+ ("softwarù" nil (((s o f t v e: r u:) 0)))
+ ("softwarùm" nil (((s o f t v e: r u: m) 0)))
+ ("t" nil (((t e:) 0)))
++("technika" nil (((t e ch n i k a) 0)))
++("techniku" nil (((t e ch n i k u) 0)))
+ ("u" nil (((u) 0)))
+ ("u" sym (((u:) 0)))
++("university" nil (((u n i v e r z i t y) 0)))
+ ("v" nil (((v) 0)))
+ ("v" sym (((v e:) 0)))
++("Writer" nil (((v r a j t r) 0)))
++("WWW" nil (((v e: v e: v e:) 0)))
++("www" nil (((v e: v e: v e:) 0)))
+ ("x" nil (((i k s) 0)))
+ ("y" nil (((i p s i l o n) 0)))
+ ("z" nil (((z) 0)))
diff --git a/audio/festlex-czech/files/patch-czech-lexicon.scm b/audio/festlex-czech/files/patch-czech-lexicon.scm
new file mode 100644
index 00000000000..21ca0a900a4
--- /dev/null
+++ b/audio/festlex-czech/files/patch-czech-lexicon.scm
@@ -0,0 +1,54 @@
+--- czech-lexicon.scm.orig Wed Dec 26 17:22:02 2007
++++ czech-lexicon.scm Wed Dec 26 17:28:09 2007
+@@ -263,3 +263,51 @@
+ ("softwary" nil (((s o f t v e: r i) 0)))
+ ("softwarù" nil (((s o f t v e: r u:) 0)))
+ ("softwarùm" nil (((s o f t v e: r u: m) 0)))
++("office" nil (((o f i s) 0)))
++("Firefox" nil (((f a j r f o k s) 0)))
++("Mozilla" nil (((m o z i l a) 0)))
++("OpenOffice" nil (((o p e n o f i s) 0)))
++("Orca" nil (((o r k a) 0)))
++("Orcy" nil (((o r k y) 0)))
++("Base" nil (((b e j z) 0)))
++("Calc" nil (((k o: l k) 0)))
++("Draw" nil (((d r o:) 0)))
++("Impress" nil (((i m p r e s) 0)))
++("Math" nil (((m a: f) 0)))
++("Writer" nil (((v r a j t r) 0)))
++("www" nil (((v e: v e: v e:) 0)))
++("WWW" nil (((v e: v e: v e:) 0)))
++("Einstein" nil (((a j n s~ t a j n) 0)))
++("Einsteina" nil (((a j n s~ t a j n a) 0)))
++("Einsteinovi" nil (((a j n s~ t a j n o v i) 0)))
++("Einsteinem" nil (((a j n s~ t a j n e m) 0)))
++("Einsteinova" nil (((a j n s~ t a j n o v a) 0)))
++("Einsteinovy" nil (((a j n s~ t a j n o v i) 0)))
++("Einsteinovì" nil (((a j n s~ t a j n o v j e) 0)))
++("Einsteinovou" nil (((a j n s~ t a j n o v o u) 0)))
++("Newton" nil (((n~ u: t n) 0)))
++("Newtona" nil (((n~ u: t n a) 0)))
++("Newtonovi" nil (((n~ u: t n o v a) 0)))
++("Newtonem" nil (((n~ u: t n e m) 0)))
++("Newtonova" nil (((n~ u: t n o v a) 0)))
++("Newtonovy" nil (((n~ u: t n o v y) 0)))
++("Newtonovì" nil (((n~ u: t n o v j e) 0)))
++("Newtonovou" nil (((n~ u: t n o v o u) 0)))
++("university" nil (((u n i v e r z i t y) 0)))
++("Maryland" nil (((m e r y l e n d) 0)))
++("Michigan" nil (((m i s~ i g e n) 0)))
++("technika" nil (((t e ch n i k a) 0)))
++("techniku" nil (((t e ch n i k u) 0)))
++("monitorovat" nil (((m o n i t o r o v a t) 0)))
++("monitoruji" nil (((m o n i t o r u j i) 0)))
++("monitoruje¹" nil (((m o n i t o r u j e s~) 0)))
++("monitoruje" nil (((m o n i t o r u j e) 0)))
++("monitorujeme" nil (((m o n i t o r u j e m e) 0)))
++("monitorujete" nil (((m o n i t o r u j e t e) 0)))
++("monitorují" nil (((m o n i t o r u j i:) 0)))
++("Marsu" nil (((m a r z u) 0)))
++("Marsem" nil (((m a r z e m) 0)))
++("Marsovy" nil (((m a r z o v i) 0)))
++("Marsových" nil (((m a r z o v i: ch) 0)))
++("Marsovým" nil (((m a r z o v i: m) 0)))
++("Marsovými" nil (((m a r z o v i: m i) 0)))
diff --git a/audio/festlex-czech/files/patch-czech.scm.in b/audio/festlex-czech/files/patch-czech.scm.in
new file mode 100644
index 00000000000..21cd8d13423
--- /dev/null
+++ b/audio/festlex-czech/files/patch-czech.scm.in
@@ -0,0 +1,11 @@
+--- czech.scm.orig Wed Jun 21 09:32:07 2006
++++ czech.scm Sat Apr 28 23:28:07 2007
+@@ -917,7 +917,7 @@
+ (lex.create "czech")
+ (lex.set.phoneset "czech")
+ (lex.select "czech")
+-(let ((dirs '("." "/usr/share/festival"))
++(let ((dirs '("@FESTIVAL_TARGET_DIR@"))
+ (lexfile nil))
+ (while dirs
+ (let ((file (path-append (car dirs) czech-lexicon-file)))
diff --git a/audio/festlex-czech/pkg-descr b/audio/festlex-czech/pkg-descr
new file mode 100644
index 00000000000..75c85d32f07
--- /dev/null
+++ b/audio/festlex-czech/pkg-descr
@@ -0,0 +1,4 @@
+Czech support for festival speech system. It provides the lexicon and language
+rules.
+
+WWW: http://www.freebsoft.org/festival-czech
diff --git a/audio/festlex-czech/pkg-plist b/audio/festlex-czech/pkg-plist
new file mode 100644
index 00000000000..a530c119abd
--- /dev/null
+++ b/audio/festlex-czech/pkg-plist
@@ -0,0 +1,9 @@
+share/festival/lib/czech.scm
+share/festival/lib/czech-debug.scm
+share/festival/lib/czech-mbrola.scm
+share/festival/lib/czech-unisyn.scm
+share/festival/lib/dicts/czech-lexicon.out
+share/festival/lib/dicts/czech-lexicon.scm
+@dirrmtry share/festival/lib/dicts
+@dirrmtry share/festival/lib
+@dirrmtry share/festival