aboutsummaryrefslogtreecommitdiffstats
path: root/audio/glame/Makefile
diff options
context:
space:
mode:
authorkrion <krion@FreeBSD.org>2004-03-16 22:10:42 +0800
committerkrion <krion@FreeBSD.org>2004-03-16 22:10:42 +0800
commit34c980f31bda7201ef787f863f789b1b275fb1be (patch)
treef652ebb256388d1bb5dade4951fd6e6b6e67a284 /audio/glame/Makefile
parent638447d19ea0cc4497b4088fec4bd29bd955e499 (diff)
downloadfreebsd-ports-graphics-34c980f31bda7201ef787f863f789b1b275fb1be.tar.gz
freebsd-ports-graphics-34c980f31bda7201ef787f863f789b1b275fb1be.tar.zst
freebsd-ports-graphics-34c980f31bda7201ef787f863f789b1b275fb1be.zip
- Update to version 1.0.2
PR: ports/64329 Submitted by: Ports Fury
Diffstat (limited to 'audio/glame/Makefile')
-rw-r--r--audio/glame/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/audio/glame/Makefile b/audio/glame/Makefile
index 490e38793c1..93344d0cc4f 100644
--- a/audio/glame/Makefile
+++ b/audio/glame/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= glame
-PORTVERSION= 1.0.1
-PORTREVISION= 3
+PORTVERSION= 1.0.2
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -19,15 +18,13 @@ BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
ltdl.4:${PORTSDIR}/devel/libltdl
-USE_REINPLACE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget libglade
+USE_GNOME= gnomehack gnomeprefix gnometarget libglade lthack
USE_GMAKE= yes
USE_LIBTOOL_VER= 13
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib -lltdl ${PTHREAD_LIBS}" \
MAKEINFO="makeinfo --no-split"
-INSTALLS_SHLIB= yes
INFO= glame glame-dev
@@ -41,9 +38,9 @@ post-extract:
@cd ${WRKSRC}/doc && ${RM} -f *.info*
post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in*" | ${XARGS} ${REINPLACE_CMD} -e \
- 's|-lpthread|${PTHREAD_LIBS}|g'
- @${GREP} -lR "<values\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
- 's|<values\.h>|<limits.h>|'
+ @${REINPLACE_CMD} -e 's| libltdl||g ; \
+ s|,$$LIBLTDL,|,,|g ; \
+ s|,$$LTDLINCL,|,,|g ; \
+ s|,$$LTLIBOBJS,|,,|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>