aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gnomemedia2/Makefile
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
committermarcus <marcus@FreeBSD.org>2005-11-05 12:53:48 +0800
commit194069571a0e4c7bad7bce0f33a042d707e9e171 (patch)
treec3c8a6312bab5325147ea9ea2ad87f0cc44a5fec /audio/gnomemedia2/Makefile
parent232533f87b435da7ed2bac7daeae3e90680d9e1d (diff)
downloadfreebsd-ports-graphics-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.gz
freebsd-ports-graphics-194069571a0e4c7bad7bce0f33a042d707e9e171.tar.zst
freebsd-ports-graphics-194069571a0e4c7bad7bce0f33a042d707e9e171.zip
Presenting GNOME 2.12 for FreeBSD. The release is chock full of bug fixes
and new features. Don't believe me? Then see for yourself at http://www.gnome.org/start/2.12/notes/en/. DO NOT USE portupgrade by itself to upgrade to GNOME 2.12. Instead, use the gnome_upgrade.sh script from http://www.marcuscom.com/downloads/gnome_upgrade212.sh. This script will circumvent some potential pitfalls users can see if they use portupgrade by itself. In keeping with tradition, GNOME 2.12 for FreeBSD comes with a special splash screen. The winner of this release's contest is Dominique Goncalves <dominique.goncalves@gmail.com>. His splash screen was inspired by http://art.gnome.org/contests/2.12-splash/83. The FreeBSD GNOME Team would lank to thank the following users for their contributions to this release: Matthew Luckie <mjl@luckie.org.nz> ade sajd on #freebsd-gnome Caelian on #freebsd-gnome mnag Yasuda Keisuke <kysd@po.harenet.ne.jp> Mark Hobden <markhobden@gmail.com> Sergey Akifyev <asa@agava.com> Andreas Kohn For more information on GNOME on FreeBSD, checkout http://www.FreeBSD.org/gnome/. The 2.12 documentation will be posted shortly.
Diffstat (limited to 'audio/gnomemedia2/Makefile')
-rw-r--r--audio/gnomemedia2/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/audio/gnomemedia2/Makefile b/audio/gnomemedia2/Makefile
index 51946794819..d1236e0f19f 100644
--- a/audio/gnomemedia2/Makefile
+++ b/audio/gnomemedia2/Makefile
@@ -3,13 +3,14 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
+# $MCom: ports/audio/gnomemedia2/Makefile,v 1.79 2005/09/04 21:49:55 marcus Exp $
#
PORTNAME= gnomemedia2
-PORTVERSION= 2.10.2
+PORTVERSION= 2.12.0
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-media/2.10
+MASTER_SITE_SUBDIR= sources/gnome-media/2.12
DISTNAME= gnome-media-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -20,7 +21,7 @@ USE_BZIP2= yes
INSTALLS_OMF= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
GNOME_DESKTOP_VERSION=2
@@ -31,7 +32,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
GCONF_SCHEMAS= CDDB-Slave2.schemas gnome-audio-profiles.schemas \
- gnome-cd.schemas gnome-sound-recorder.schemas
+ gnome-cd.schemas gnome-sound-recorder.schemas \
+ gnome-volume-control.schemas
.include <bsd.port.pre.mk>
@@ -43,10 +45,5 @@ post-patch:
.else
@${REINPLACE_CMD} -e 's|%%CDROM%%|acd0c|' ${WRKSRC}/configure
.endif
-.if ${OSVERSION} < 504000
- @${REINPLACE_CMD} -e 's|lrint|rint|' \
- ${WRKSRC}/gnome-cd/gst-cdparanoia-cdrom.c \
- ${WRKSRC}/gst-mixer/src/volume.c
-.endif
.include <bsd.port.post.mk>