aboutsummaryrefslogtreecommitdiffstats
path: root/audio/goobox
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2005-03-01 06:16:10 +0800
committerahze <ahze@FreeBSD.org>2005-03-01 06:16:10 +0800
commit67b0bcb755f8b2e738f1628212a462100010232d (patch)
tree66219c98689ff4395c07681f6494f6d4f242fc09 /audio/goobox
parentaa4e4e91097b7da2ff4497ebcbbc802bddb95dc7 (diff)
downloadfreebsd-ports-graphics-67b0bcb755f8b2e738f1628212a462100010232d.tar.gz
freebsd-ports-graphics-67b0bcb755f8b2e738f1628212a462100010232d.tar.zst
freebsd-ports-graphics-67b0bcb755f8b2e738f1628212a462100010232d.zip
- split multimedia/gstreamer-plugins in to individual ports per
gstreamer plugin (52 new ports). - Chase changes to ports that used USE_GNOME=gstreamerplugisn to use new USE_GSTREAMER= macro, Bump PORTREVISION's -- Examples of new USE_GSTREAMER macro: USE_GSTREAMER= dvd lame flac .include <bsd.port.mk> If you want to use USE_GSTREAMER after <bsd.port.pre.mk> you must follow one of the examples listed below WANT_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_VORBIS) USE_GSTREAMER+= vorbis .endif or USE_GSTREAMER= yes .include <bsd.port.pre.mk> .if defined(WITH_FAAD) USE_GSTREAMER+= faad .endif Note: USE_GSTREAMER=yes will always add a dependency to ports/multimedia/gstreamer-plugins -- Thanks to krion for runing this on pointyhat Thanks to kwm for helping with this, and many bug fixes , and updates.
Diffstat (limited to 'audio/goobox')
-rw-r--r--audio/goobox/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/audio/goobox/Makefile b/audio/goobox/Makefile
index 0f215b0fd7d..ed01563fe76 100644
--- a/audio/goobox/Makefile
+++ b/audio/goobox/Makefile
@@ -7,6 +7,7 @@
PORTNAME= goobox
PORTVERSION= 0.7.1
+PORTREVISION= 1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -20,8 +21,8 @@ RUN_DEPENDS= cddb-slave2-properties:${PORTSDIR}/audio/gnomemedia2
USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libglade2 libbonobo \
- gstreamerplugins
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libglade2 libbonobo
+USE_GSTREAMER= cdparanoia
USE_LIBTOOL_VER=15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"