aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gspeakers
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-06-23 22:14:00 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-06-23 22:14:00 +0800
commit144d439fd962c167a75e98d8ee7c1e93ccbb2ca9 (patch)
treebd54cb545e6e003a30612f362ebdc34756b5d3c7 /audio/gspeakers
parentc5cae729dfac87d6ed7044161b9ee62ee8401c8f (diff)
downloadfreebsd-ports-graphics-144d439fd962c167a75e98d8ee7c1e93ccbb2ca9.tar.gz
freebsd-ports-graphics-144d439fd962c167a75e98d8ee7c1e93ccbb2ca9.tar.zst
freebsd-ports-graphics-144d439fd962c167a75e98d8ee7c1e93ccbb2ca9.zip
- Switch to USES=autoreconf
- Turn WITH_SPICE into an option
Diffstat (limited to 'audio/gspeakers')
-rw-r--r--audio/gspeakers/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/audio/gspeakers/Makefile b/audio/gspeakers/Makefile
index 475f027db42..31342229254 100644
--- a/audio/gspeakers/Makefile
+++ b/audio/gspeakers/Makefile
@@ -4,7 +4,7 @@
PORTNAME= gspeakers
PORTVERSION= 0.11
-PORTREVISION= 15
+PORTREVISION= 16
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -13,16 +13,20 @@ COMMENT= Gnome-based loudspeaker design program
LIB_DEPENDS= libgtkmm-2.4.so:${PORTSDIR}/x11-toolkits/gtkmm24
-USES= gmake pkgconfig
+USES= autoreconf gmake pkgconfig
USE_GNOME= gnomeprefix libxml2
-USE_AUTOTOOLS= automake:env
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CFLAGS+= -O0
-.if defined(WITH_SPICE)
+OPTIONS_DEFINE= SPICE
+SPICE_DESC= Use spice instead of gnucap
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSPICE}
RUN_DEPENDS+= spice3:${PORTSDIR}/cad/spice
.else
RUN_DEPENDS+= gnucap:${PORTSDIR}/cad/gnucap
@@ -33,15 +37,12 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's|$$(datadir)/pixmaps|$$(pkgdatadir)/pixmaps|g' \
- ${WRKSRC}/pixmaps/Makefile.in
+ ${WRKSRC}/pixmaps/Makefile.am
@${REINPLACE_CMD} -e 's|-Wall -O0|@CXXFLAGS@|g' \
- ${WRKSRC}/src/Makefile.in
+ ${WRKSRC}/src/Makefile.am
@${REINPLACE_CMD} -e 's|$$(datadir)/xml|$$(pkgdatadir)/xml|g' \
- ${WRKSRC}/xml/Makefile.in
+ ${WRKSRC}/xml/Makefile.am
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' \
${WRKSRC}/src/*.cc ${WRKSRC}/src/cellitemcrossover.h
-pre-configure:
- @${CP} ${AUTOMAKE_DIR}/depcomp ${WRKSRC}
-
.include <bsd.port.mk>