aboutsummaryrefslogtreecommitdiffstats
path: root/audio/lash
diff options
context:
space:
mode:
authortrasz <trasz@FreeBSD.org>2008-01-03 03:35:26 +0800
committertrasz <trasz@FreeBSD.org>2008-01-03 03:35:26 +0800
commitbae2cb30dc9d38e9899a1aba4fb2748ef39a3874 (patch)
tree3ac7694b011bbe8485c02ec99b7db932905c3b86 /audio/lash
parent24d9d5a9bef384223eeed7e02d6bc871ace186f8 (diff)
downloadfreebsd-ports-graphics-bae2cb30dc9d38e9899a1aba4fb2748ef39a3874.tar.gz
freebsd-ports-graphics-bae2cb30dc9d38e9899a1aba4fb2748ef39a3874.tar.zst
freebsd-ports-graphics-bae2cb30dc9d38e9899a1aba4fb2748ef39a3874.zip
- Work around session resuming problem.
Diffstat (limited to 'audio/lash')
-rw-r--r--audio/lash/Makefile1
-rw-r--r--audio/lash/files/patch-lashd-conn_mgr.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/audio/lash/Makefile b/audio/lash/Makefile
index 81ddca21047..3891f6e1e33 100644
--- a/audio/lash/Makefile
+++ b/audio/lash/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lash
PORTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.savannah.gnu.org/releases/lash/
diff --git a/audio/lash/files/patch-lashd-conn_mgr.c b/audio/lash/files/patch-lashd-conn_mgr.c
new file mode 100644
index 00000000000..38042102d93
--- /dev/null
+++ b/audio/lash/files/patch-lashd-conn_mgr.c
@@ -0,0 +1,15 @@
+--- lashd/conn_mgr.c.orig 2008-01-02 20:26:00.000000000 +0100
++++ lashd/conn_mgr.c 2008-01-02 20:27:11.000000000 +0100
+@@ -759,7 +759,11 @@
+
+ fprintf(stderr, "%s: error calling select(): %s\n", __FUNCTION__,
+ strerror(errno));
+- return NULL;
++
++ if (errno == EBADF)
++ continue;
++ else
++ return NULL;
+ }
+
+ if (conn_mgr->quit)