aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libao/Makefile
diff options
context:
space:
mode:
authorsf <sf@FreeBSD.org>2001-03-03 06:07:37 +0800
committersf <sf@FreeBSD.org>2001-03-03 06:07:37 +0800
commit849d1dac70dcae3331ed39b6ca0b34d25d0a162e (patch)
tree10270f27c2852807518f3a7c300fa0a6b8220618 /audio/libao/Makefile
parent222224560b7e8e854beb480e5b33b9c963270530 (diff)
downloadfreebsd-ports-graphics-849d1dac70dcae3331ed39b6ca0b34d25d0a162e.tar.gz
freebsd-ports-graphics-849d1dac70dcae3331ed39b6ca0b34d25d0a162e.tar.zst
freebsd-ports-graphics-849d1dac70dcae3331ed39b6ca0b34d25d0a162e.zip
o respect CFLAGS (libao, libogg, libvorbis)
o add ESOUND and KDE2 knob. (libao) o add WWW. (libogg) o get rid of xmms dependency. (vorbis) Approved by: maintainer
Diffstat (limited to 'audio/libao/Makefile')
-rw-r--r--audio/libao/Makefile20
1 files changed, 19 insertions, 1 deletions
diff --git a/audio/libao/Makefile b/audio/libao/Makefile
index c76f03da787..38df08d0478 100644
--- a/audio/libao/Makefile
+++ b/audio/libao/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://home.student.utwente.nl/t.vanklaveren/distfiles/ \
MAINTAINER= t.vanklaveren@student.utwente.nl
+WANT_ESOUND= yes
+
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
@@ -20,4 +22,20 @@ USE_AUTOMAKE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_ESOUND)
+USE_ESOUND= yes
+PLIST_SUB= ESOUND=""
+.else
+PLIST_SUB= ESOUND="@comment "
+.endif
+
+.if exists(${LOCALBASE}/bin/artsc-config)
+LIB_DEPENDS= artsc.0:${PORTSDIR}/x11/kdelibs2
+PLIST_SUB+= ARTS=""
+.else
+PLIST_SUB+= ARTS="@comment "
+.endif
+
+.include <bsd.port.post.mk>