aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libbs2b
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
committerbapt <bapt@FreeBSD.org>2012-07-26 13:40:22 +0800
commit8a3f534c898f1045896626964b7f3e3e406f946b (patch)
tree73bea5baa559b61c5e812c50ac96fad638950c75 /audio/libbs2b
parentccde37a9b75ee6a15ed85af7d0f2e60c16c42192 (diff)
downloadfreebsd-ports-graphics-8a3f534c898f1045896626964b7f3e3e406f946b.tar.gz
freebsd-ports-graphics-8a3f534c898f1045896626964b7f3e3e406f946b.tar.zst
freebsd-ports-graphics-8a3f534c898f1045896626964b7f3e3e406f946b.zip
new devel/pkgconf added to replace devel/pkg-config. new version of pkg-config
are no more self hosting so we are stuck with 0.25 version while pkgconf provide the same set of features as 0.27 and a compatible frontend. A symlink to pkg-config has been added for convenience and compatibility This also introduces a new macro to use pkgconf in your ports: USE_PKGCONFIG it can take the following arguments: - yes (meaning build only dep) - build (meaning build only dep) - run (meaning run only dep) - both (meaning run and build dep) From now USE_GNOME= pkgconfig is deprecated in favour of USE_PKGCONFIG The old gnome macro has been modified to use pkgconf but still the sameway: run and build dep to avoid large breakage. While here fix some ports relying on pkg-config but not specifying it, fix some ports broken because testing wrong .pc files, and fix ports using pkg-config --version to determine pkg-config version instead of pkg-config --modversion pkg-config like recommanded by pkg-config With Hat: portmgr Exp-runs by: bapt (pointhat-west), beat (pointyhat)
Diffstat (limited to 'audio/libbs2b')
-rw-r--r--audio/libbs2b/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/audio/libbs2b/Makefile b/audio/libbs2b/Makefile
index b9d15d2328f..38a13f51418 100644
--- a/audio/libbs2b/Makefile
+++ b/audio/libbs2b/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= SF/bs2b/bs2b/${PORTVERSION}
MAINTAINER= liangtai.s4@gmail.com
COMMENT= Bauer Stereophonic-to-Binaural DSP
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkg-config
LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile \
ogg:${PORTSDIR}/audio/libogg \
FLAC:${PORTSDIR}/audio/flac \
@@ -23,6 +22,7 @@ LIB_DEPENDS+= sndfile:${PORTSDIR}/audio/libsndfile \
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
+USE_PKGCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= CFLAGS=`pkg-config --cflags sndfile` \
LDFLAGS=`pkg-config --libs-only-L sndfile`