aboutsummaryrefslogtreecommitdiffstats
path: root/audio/libmpcdec
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2004-12-01 05:03:12 +0800
committerkwm <kwm@FreeBSD.org>2004-12-01 05:03:12 +0800
commitc936252f9dbcc62ce62a6a0a522017c3e05f7ef0 (patch)
tree779bac1758a7496a7ef1de0d946bf6ed4e59d4ee /audio/libmpcdec
parent420f13a8c37dbf0ae11e1a77ebc57a0e1594865c (diff)
downloadfreebsd-ports-graphics-c936252f9dbcc62ce62a6a0a522017c3e05f7ef0.tar.gz
freebsd-ports-graphics-c936252f9dbcc62ce62a6a0a522017c3e05f7ef0.tar.zst
freebsd-ports-graphics-c936252f9dbcc62ce62a6a0a522017c3e05f7ef0.zip
add libmusepack. Musepack is an audio compression format with a strong
emphasis on high quality. It's not lossless, but it is designed for transparency, so that you won't be able to hear differences between the original wave file and the much smaller MPC file. Approved by: pav (mentor)
Diffstat (limited to 'audio/libmpcdec')
-rw-r--r--audio/libmpcdec/Makefile27
-rw-r--r--audio/libmpcdec/distinfo2
-rw-r--r--audio/libmpcdec/pkg-descr10
-rw-r--r--audio/libmpcdec/pkg-plist10
4 files changed, 49 insertions, 0 deletions
diff --git a/audio/libmpcdec/Makefile b/audio/libmpcdec/Makefile
new file mode 100644
index 00000000000..2f50c611a6c
--- /dev/null
+++ b/audio/libmpcdec/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: libmusepack
+# Date created: 29 November 2004
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libmusepack
+PORTVERSION= 1.0.3
+CATEGORIES= audio
+MASTER_SITES= http://www.saunalahti.fi/grimmel/musepack.net/source/
+
+MAINTAINER= kwm@FreeBSD.org
+COMMENT= High quality audio compression format
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_GNOME= gnometarget
+USE_LIBTOOL_VER=15
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O3\ -fomit-frame-pointer||g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/audio/libmpcdec/distinfo b/audio/libmpcdec/distinfo
new file mode 100644
index 00000000000..edd4c91433c
--- /dev/null
+++ b/audio/libmpcdec/distinfo
@@ -0,0 +1,2 @@
+MD5 (libmusepack-1.0.3.tar.bz2) = 01a0b1f338244e6a7d95f826c382f70b
+SIZE (libmusepack-1.0.3.tar.bz2) = 226099
diff --git a/audio/libmpcdec/pkg-descr b/audio/libmpcdec/pkg-descr
new file mode 100644
index 00000000000..77d16c9de36
--- /dev/null
+++ b/audio/libmpcdec/pkg-descr
@@ -0,0 +1,10 @@
+Musepack is an audio compression format with a strong emphasis on high quality.
+It's not lossless, but it is designed for transparency, so that you won't be
+able to hear differences between the original wave file and the much smaller
+MPC file.
+
+It is based on the MPEG-1 Layer-2 / MP2 algorithms, but has rapidly developed
+and vastly improved and is now at an advanced stage in which it contains
+heavily optimized and patentless code.
+
+WWW: http://www.musepack.net/
diff --git a/audio/libmpcdec/pkg-plist b/audio/libmpcdec/pkg-plist
new file mode 100644
index 00000000000..444b739bd77
--- /dev/null
+++ b/audio/libmpcdec/pkg-plist
@@ -0,0 +1,10 @@
+include/musepack/config_types.h
+include/musepack/mpc_dec.h
+include/musepack/mpc_math.h
+include/musepack/requant.h
+include/musepack/stdafx.h
+include/musepack/streaminfo.h
+lib/libmusepack.a
+lib/libmusepack.so
+lib/libmusepack.so.1
+@dirrm include/musepack