aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mhwaveedit
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2003-12-27 22:46:45 +0800
committerpav <pav@FreeBSD.org>2003-12-27 22:46:45 +0800
commit76f6e43b45c2a3d3f3a6f9e4f66360fe272d5a0c (patch)
treeef8a0733da9e72e0a079b3f1eae97a3163f4169a /audio/mhwaveedit
parentb03645db461417df987f338a26f3e4890b879ff4 (diff)
downloadfreebsd-ports-graphics-76f6e43b45c2a3d3f3a6f9e4f66360fe272d5a0c.tar.gz
freebsd-ports-graphics-76f6e43b45c2a3d3f3a6f9e4f66360fe272d5a0c.tar.zst
freebsd-ports-graphics-76f6e43b45c2a3d3f3a6f9e4f66360fe272d5a0c.zip
- Update to 1.2.4
PR: ports/60618 Submitted by: Ports Fury
Diffstat (limited to 'audio/mhwaveedit')
-rw-r--r--audio/mhwaveedit/Makefile2
-rw-r--r--audio/mhwaveedit/distinfo2
-rw-r--r--audio/mhwaveedit/files/patch-src::datasource.c12
-rw-r--r--audio/mhwaveedit/files/patch-src::viewcache.c14
4 files changed, 14 insertions, 16 deletions
diff --git a/audio/mhwaveedit/Makefile b/audio/mhwaveedit/Makefile
index 93751a3d51d..e6393cbc426 100644
--- a/audio/mhwaveedit/Makefile
+++ b/audio/mhwaveedit/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= mhwaveedit
-PORTVERSION= 1.2.3
+PORTVERSION= 1.2.4
CATEGORIES= audio
MASTER_SITES= http://www.mtek.chalmers.se/~hjormagn/
diff --git a/audio/mhwaveedit/distinfo b/audio/mhwaveedit/distinfo
index a0484b74a65..0278cfae210 100644
--- a/audio/mhwaveedit/distinfo
+++ b/audio/mhwaveedit/distinfo
@@ -1 +1 @@
-MD5 (mhwaveedit-1.2.3.tar.gz) = 25fb4d7c03f52acda4dd523b7ce7662e
+MD5 (mhwaveedit-1.2.4.tar.gz) = 136507e084ef715481129e6c241b2d32
diff --git a/audio/mhwaveedit/files/patch-src::datasource.c b/audio/mhwaveedit/files/patch-src::datasource.c
new file mode 100644
index 00000000000..9213f316e59
--- /dev/null
+++ b/audio/mhwaveedit/files/patch-src::datasource.c
@@ -0,0 +1,12 @@
+--- src/datasource.c.orig Tue Dec 23 07:06:26 2003
++++ src/datasource.c Sat Dec 27 00:59:02 2003
+@@ -212,8 +212,8 @@
+
+ Datasource *datasource_byteswap(Datasource *source)
+ {
+- if (source == NULL) return NULL;
+ Datasource *ds;
++ if (source == NULL) return NULL;
+ ds = gtk_type_new(datasource_get_type());
+ ds->type = DATASOURCE_BYTESWAP;
+ memcpy(&(ds->format),&(source->format),sizeof(Dataformat));
diff --git a/audio/mhwaveedit/files/patch-src::viewcache.c b/audio/mhwaveedit/files/patch-src::viewcache.c
deleted file mode 100644
index a45dc8675c6..00000000000
--- a/audio/mhwaveedit/files/patch-src::viewcache.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/viewcache.c.orig Wed Jun 4 15:23:06 2003
-+++ src/viewcache.c Wed Jun 4 15:23:45 2003
-@@ -24,6 +24,11 @@
- #include "inifile.h"
- #include "main.h"
-
-+#ifndef HAVE_CEILL
-+# define ceill(x) ceil((double)(x))
-+# define HAVE_CEILL
-+#endif
-+
- /* How many columns to update (max) for each call to view_cache_update */
- #define PIXELS_PER_UPDATE 10
- #define GUINT32(x) ((guint32)x)