aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mpdscribble
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2008-06-01 20:34:11 +0800
committerrafan <rafan@FreeBSD.org>2008-06-01 20:34:11 +0800
commit5f4ade63bf0ab7c3766173242a7870f2d8215459 (patch)
tree81507e43535111c173e66b2658616e68ae5e8ef4 /audio/mpdscribble
parent14ca62a1b4fbac5acafcca78fe3a8a267cc5921e (diff)
downloadfreebsd-ports-graphics-5f4ade63bf0ab7c3766173242a7870f2d8215459.tar.gz
freebsd-ports-graphics-5f4ade63bf0ab7c3766173242a7870f2d8215459.tar.zst
freebsd-ports-graphics-5f4ade63bf0ab7c3766173242a7870f2d8215459.zip
- Do not assume /bin/sh is bash in setup.sh
- Install setup.sh as mpdscribble-setup which is required at runtime - Bump PORTREVISION PR: ports/122993 Submitted by: Sokolov Alexey <sokolov at truebsd.org>
Diffstat (limited to 'audio/mpdscribble')
-rw-r--r--audio/mpdscribble/Makefile6
-rw-r--r--audio/mpdscribble/files/patch-setup.sh20
2 files changed, 25 insertions, 1 deletions
diff --git a/audio/mpdscribble/Makefile b/audio/mpdscribble/Makefile
index 57b51bc7541..cca9ffd9cb2 100644
--- a/audio/mpdscribble/Makefile
+++ b/audio/mpdscribble/Makefile
@@ -7,6 +7,7 @@
PORTNAME= mpdscribble
PORTVERSION= 0.2.12
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.frob.nl/projects/scribble/
@@ -18,6 +19,9 @@ LIB_DEPENDS= soup:${PORTSDIR}/devel/libsoup22
GNU_CONFIGURE= yes
MAN1= mpdscribble.1
-PLIST_FILES= bin/mpdscribble
+PLIST_FILES= bin/mpdscribble bin/mpdscribble-setup
+
+post-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/setup.sh ${PREFIX}/bin/mpdscribble-setup
.include <bsd.port.mk>
diff --git a/audio/mpdscribble/files/patch-setup.sh b/audio/mpdscribble/files/patch-setup.sh
new file mode 100644
index 00000000000..10b8d03b3a7
--- /dev/null
+++ b/audio/mpdscribble/files/patch-setup.sh
@@ -0,0 +1,20 @@
+--- setup.sh.orig 2008-06-01 19:53:53.000000000 +0800
++++ setup.sh 2008-06-01 19:54:16.000000000 +0800
+@@ -26,7 +26,7 @@
+ echo
+ echo "press ctrl-c to cancel if this is not intended."
+ echo "continue..."
+-read -s
++read
+
+ mkdir -p $CONF_DIR
+ mkdir -p $CACHE_DIR
+@@ -35,7 +35,7 @@
+ echo -n "Please enter your audioscrobbler username: "
+ read -e USERNAME
+ echo -n "and password: "
+-read -s -e PASSWORD
++read -e PASSWORD
+
+ echo "username = $USERNAME" > $LOGIN
+ chmod 600 $LOGIN