aboutsummaryrefslogtreecommitdiffstats
path: root/audio/mpg123
diff options
context:
space:
mode:
authorjkoshy <jkoshy@FreeBSD.org>1999-08-25 19:25:01 +0800
committerjkoshy <jkoshy@FreeBSD.org>1999-08-25 19:25:01 +0800
commit44a395a9111e7c6ff6b2b3d4ec3d54cf995b761f (patch)
treeccfbd52cd87c4ec194d236bd121d595672663a5a /audio/mpg123
parent8e822d10bc955d65877b33275fb6d12554cbf163 (diff)
downloadfreebsd-ports-graphics-44a395a9111e7c6ff6b2b3d4ec3d54cf995b761f.tar.gz
freebsd-ports-graphics-44a395a9111e7c6ff6b2b3d4ec3d54cf995b761f.tar.zst
freebsd-ports-graphics-44a395a9111e7c6ff6b2b3d4ec3d54cf995b761f.zip
Set a default optimization level for the lazy and hopeless :).
Requested by: Nick Hibma <nick.hibma@jrc.it>
Diffstat (limited to 'audio/mpg123')
-rw-r--r--audio/mpg123/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/audio/mpg123/Makefile b/audio/mpg123/Makefile
index 096faf892b9..2309abf5fa6 100644
--- a/audio/mpg123/Makefile
+++ b/audio/mpg123/Makefile
@@ -25,8 +25,7 @@ pre-configure:
.if $(MACHINE_ARCH) == "i386"
.if !defined(OPT_ARCH) || (($(OPT_ARCH) != "i486") && ($(OPT_ARCH) != "i586"))
@echo "+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++"
- @echo "Please considering setting OPT_ARCH to match your hardware to build mpg123"
- @echo "optimised for your hardware (e.g: make OPT_ARCH=i486)"
+ @echo "Note: you can set OPT_ARCH to optimize for your hardware. (Eg:- make OPT_ARCH=i486)"
.if $(PORTOBJFORMAT) == "elf"
@echo "Valid values are: i486, i586"
.else
@@ -36,4 +35,17 @@ pre-configure:
.endif
.endif
+.if $(PORTOBJFORMAT) == "elf"
+OPT_ARCH?= i586
+.else
+OPT_ARCH?= i486
+.endif
+
+# Uncomment this line below to optimise for i486 family CPUs on ELF boxes
+# OPT_ARCH= i486
+
+.if defined(OPT_ARCH)
+MAKE_ARGS+= OPT_ARCH=$(OPT_ARCH)
+.endif
+
.include <bsd.port.post.mk>